Results 1 to 14 of 14

Thread: UPCP error - how to fix?

  1. #1
    Registered Member
    Join Date
    Oct 2006
    Location
    Brazil
    Posts
    63

    Default UPCP error - how to fix?

    Hello,

    my servers are 100% cPanel defaults, so the UPCP is:

    /usr/local/cpanel/scripts/upcp --cron

    In last 3 weeks, all updates are failing. In all three servers, same error, but I dont know how to fix, securelly:

    Running rpm_check_debug
    ERROR with rpm_check_debug vs depsolve:
    httpd-mmn = 20051115 is needed by mod_wsgi-3.2-3.el6.x86_64
    ** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
    frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0
    1:mod_ssl-2.2.15-15.el6.centos.1.x86_64 has missing requires of httpd
    1:mod_ssl-2.2.15-15.el6.centos.1.x86_64 has missing requires of httpd = ('0', '2.2.15', '15.el6.centos.1')
    1:mod_ssl-2.2.15-15.el6.centos.1.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
    mod_wsgi-3.2-1.el6.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
    Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2013-08-05-09-583dv6iZ.yumtx


    Can you help me?

    Thank you!

  2. #2
    Registered Member
    Join Date
    Jul 2004
    Posts
    700

    Default Re: UPCP error - how to fix?

    The comand is /usr/local/cpanel/scripts/upcp
    Or
    /usr/local/cpanel/scripts/upcp --force
    if this fails on three servers you need to submit a ticket to cpanel https://tickets.cpanel.net/submit/in...eqtype=tickets
    Get professional cpanel hosting from 1uhost.com
    Advertise your site in our business directory frontiereconomy.com

  3. #3
    Registered Member
    Join Date
    Apr 2006
    Location
    Disillusioned in England
    Posts
    315
    cPanel/WHM Access Level

    Root Administrator

    Default Re: UPCP error - how to fix?

    What version of cPanel are you current running, and what is the output of rpm -qa mod_wsgi ? All the components of the web server should be built via easyapache and not installed as rpms.

    You might want to check the exclue line in /etc/yum.conf and run us a perl -v too
    Available for helpdesk work, weddings and bar mitzvahs.
    If this post helped, click the badge icon in the bottom left!

  4. #4
    Registered Member
    Join Date
    Oct 2006
    Location
    Brazil
    Posts
    63

    Default Re: UPCP error - how to fix?

    Hello!

    CENTOS 6.3 x86_64 standard – server WHM 11.38.1 (build 15)
    cPanel 11.38.1 (build 15)

    root@server [~]# rpm -qa mod_wsgi
    mod_wsgi-3.2-1.el6.x86_64

    Everything on all servers are built using EasyApache (in fact is the only way I know). No rpms installed directly into Apache.

    Yum.conf:
    [main]
    exclude=bind-chroot courier* dovecot* exim* filesystem httpd* mod_ssl* mydns* mysql* nsd* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*

    root@server [~]# perl -v

    This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi


    Thank you!

  5. #5
    Registered Member
    Join Date
    Apr 2006
    Location
    Disillusioned in England
    Posts
    315
    cPanel/WHM Access Level

    Root Administrator

    Default Re: UPCP error - how to fix?

    Haven't got a terminal in front of me but I don't believe that mod_wsgi should be installed as an RPM, this can be provided with EA but I think via an opt-mod rather than an rpm

    http://forums.cpanel.net/f442/mod_ws...le-173501.html

    Does your yum log happen to show when the rpm was installed? Certainly from the error log you provided it looks like maybe this rpm has been force installed when technically speaking it will conflict with the cPanel / EA way of doing things (currently without rpms)
    Available for helpdesk work, weddings and bar mitzvahs.
    If this post helped, click the badge icon in the bottom left!

  6. #6
    Registered Member
    Join Date
    Oct 2006
    Location
    Brazil
    Posts
    63

    Default Re: UPCP error - how to fix?

    I've installed other softwares, like Munin and MRTG, that I dont believe is related. Munin installed from WHM, MRTG by command line. And Nagios NRPE plugin too, but no other software.

    I read that this mod_wsgi is something related to Python, but I dont use it. How can I exclude this mod_wsgi without need to run EasyApache again (servers in production, cannot risk). Or a way to ignore it from YUM.

    I really dont care about this mod_wsgi, but I need to update others...
    Last edited by Arvy; 08-05-2013 at 05:20 PM.

  7. #7
    Registered Member
    Join Date
    Oct 2006
    Location
    Brazil
    Posts
    63

    Default Re: UPCP error - how to fix?

    I found this:

    http://forums.cpanel.net/f5/system-n...ng-344171.html

    Helps?

    root@server [~]# yum history list mod_wsgi
    Loaded plugins: fastestmirror, security
    ID | Login user | Date and time | Action(s) | Altered
    -------------------------------------------------------------------------------
    1 | System <unset> | 2012-07-04 12:00 | Install | 407

    2012-07-04 is when I've installed CentOS, WHM/Cpanel and those basic monitoring systems (nagios,mrtg,munin).

  8. #8
    Registered Member
    Join Date
    Apr 2006
    Location
    Disillusioned in England
    Posts
    315
    cPanel/WHM Access Level

    Root Administrator

    Default Re: UPCP error - how to fix?

    If you run a yum remove on the package it *should* warn you if anything else depends on it and give you an option to quit if you don't want to proceed. You might be able to get away with adding the package to the excludes line (never tried it for this sort of situation) but I'd advise against that with EA eventually moving to rpms in the future
    Available for helpdesk work, weddings and bar mitzvahs.
    If this post helped, click the badge icon in the bottom left!

  9. #9
    Registered Member
    Join Date
    Oct 2006
    Location
    Brazil
    Posts
    63

    Default Re: UPCP error - how to fix?

    Hi Thinlce,

    if I remove the package and see something wrong, in theory I can just reinstall the package after the yum update and everything will run fine again, right?

  10. #10
    cPanel Staff cPanelMichael's Avatar
    Join Date
    Apr 2011
    Posts
    11,799
    cPanel/WHM Access Level

    Root Administrator

    Default Re: UPCP error - how to fix?

    Hello

    The primary issue I see is that you have RPMs installed that are not native to cPanel. These RPMs are not required if you use EasyApache to handle your Apache installation. I recommend removing the "mod_wsgi" and "mod_ssl" RPMs and then running the following command to ensure YUM updates normally:

    Code:
    yum update
    While it would be possible for you to reinstall the RPMs if necessary, I do not foresee that being an issue if you have not installed any custom applications.

    Thank you.
    cPResources: Support Options - Submit a ticket here - Additional Support Options - Forums Search - Mailing Lists - Documentation - Migration Services - Change Logs
    -- cPanelMichael - Migration Specialist, Technical Analyst, cPanel Technical Support

  11. #11
    Registered Member
    Join Date
    Apr 2006
    Location
    Disillusioned in England
    Posts
    315
    cPanel/WHM Access Level

    Root Administrator

    Default Re: UPCP error - how to fix?

    Quote Originally Posted by Arvy View Post
    Hi Thinlce,

    if I remove the package and see something wrong, in theory I can just reinstall the package after the yum update and everything will run fine again, right?
    Yup, although as Michael points out this shouldn't be necessary. The point I was making was that yum will also threaten to remove any packages that depend upon this one when you go to remove it, as such you should be able to see anything at dire risk of breaking (I'm talking here about stuff you might have installed prior to putting cPanel on the machine).

    Edit: Although, you'd probably have to force reinstall them as they'll likely depend on other httpd* rpms. Dealing with orphaned packages and dependency issues like this is always a giant PITA, I'm amazed at the number of systems out there that weren't originally done as minimal installs / everything and the kitchen sink removed before cPanel was put on
    Last edited by ThinIce; 08-06-2013 at 08:44 AM.
    Available for helpdesk work, weddings and bar mitzvahs.
    If this post helped, click the badge icon in the bottom left!

  12. #12
    Registered Member
    Join Date
    Oct 2006
    Location
    Brazil
    Posts
    63

    Default Re: UPCP error - how to fix?

    My actual Apache was built using EasyApache. The point is, after configuring cPanel, I've installed additional softwares:

    - MRTG (snmpd)
    - Nagios NRPE
    - Munin (via WHM)
    - Xinetd


    All rest came with the server.

    In theory, removing this package with "yum remove mod_wsgi" won't require re-run EasyApache again, since it's an additional module on Apache, nor will break the Apache, right? That's my main concern (I'm not expert in Linux, but I know enough for administer).

  13. #13
    cPanel Staff cPanelMichael's Avatar
    Join Date
    Apr 2011
    Posts
    11,799
    cPanel/WHM Access Level

    Root Administrator

    Default Re: UPCP error - how to fix?

    Yes, that is correct. You should not have to run EasyApache after removing those RPMs because EasyApache does not incorporate RPM installations of Apache modules. You may want to remove the RPMs directly with a command such as:

    Code:
    rpm -e --nodeps package-name
    This will ensure only the RPM itself is removed, and no additional dependencies.

    Thank you.
    cPResources: Support Options - Submit a ticket here - Additional Support Options - Forums Search - Mailing Lists - Documentation - Migration Services - Change Logs
    -- cPanelMichael - Migration Specialist, Technical Analyst, cPanel Technical Support

  14. #14
    Registered Member
    Join Date
    Oct 2006
    Location
    Brazil
    Posts
    63

    Default Re: UPCP error - how to fix?

    Hello,

    thank you very much, Thinlce and Michael. I did:

    rpm -e --nodeps mod_wsgi
    yum clean all
    yum update

    and now my servers are updated, no problem detected after removing mod_wsgi. Everything is perfect.

    Again, thank you!!

Similar Threads

  1. Daily upcp try to downlond stupid file. How to fix?
    By kiat in forum cPanel & WHM Discussions
    Replies: 45
    Last Post: 05-31-2007, 01:36 PM
  2. UPCP mail: "Mail failure - message too big" how to fix?
    By Miss Jacky in forum cPanel & WHM Discussions
    Replies: 2
    Last Post: 02-06-2006, 04:25 PM
  3. Cant run upcp syntax error at /scripts/upcp line 46, near "system"
    By BianchiDude in forum cPanel & WHM Discussions
    Replies: 5
    Last Post: 07-20-2005, 11:03 AM
  4. latest Cpanel upcp fix
    By lost in forum cPanel & WHM Discussions
    Replies: 2
    Last Post: 12-24-2004, 10:14 AM

Tags for this Thread

bargain