Results 1 to 6 of 6

Thread: Compatibility: HipHop for PHP "transforms PHP source code into highly optimized C++"?

  1. #1
    Registered Member
    Join Date
    Jan 2010
    Posts
    13

    Question Compatibility: HipHop for PHP "transforms PHP source code into highly optimized C++"?

    talking about: Building and installing - hiphop-php - GitHub

    would hiphop cause any problems with cpanel?

    has anyone tried it?

  2. #2
    cPanel Quality Assurance Analyst cPanelDon's Avatar
    Join Date
    Nov 2008
    Location
    Houston, Texas, U.S.A.
    Posts
    2,549
    cPanel/WHM Access Level

    DataCenter Provider

    Arrow Friendly Moderator Note

    Quote Originally Posted by vashrf View Post
    talking about: Building and installing - hiphop-php - GitHub

    would hiphop cause any problems with cpanel?

    has anyone tried it?
    I have revised the thread title to include a more verbose description of of the inquiry; in addition, I have relocated the discussion thread into the forums category for cPanel and WHM Optimization to help attract more relevant attention considering the "optimization" purpose of using HipHop for PHP.

    Of note, I would consider carefully reviewing entries in the HipHop for PHP bug tracker in addition to other pages in their wiki:


    The following may be a concern for anyone using a 32-bit OS installation or anyone using the latest version of PHP 5.3:
    • "At the moment, HipHop can only run on 64 bits systems."
    • "HipHop currently supports PHP version 5.2 and will be updated to support 5.3."

  3. #3
    Registered Member
    Join Date
    Jan 2010
    Posts
    13

    Default

    thanks Don.

    I saw those pages as well and I met the requirements for everything except the 64bit OS. However, I am moving servers soon and that problem will be resolved.

    So, my question is:

    1. will hiphop interfere with cpanel?

    2. has anyone tried hiphop with cpanel?

    3. comments or suggestions?

  4. #4
    cPanel Product Evangelist Infopro's Avatar
    Join Date
    May 2003
    Location
    Pennsylvania
    Posts
    10,912
    cPanel/WHM Access Level

    Root Administrator

    Lightbulb

    You might to ask them over there (if you're getting no replies here). I do remember Scott MacVicar from over at vBulletin, he's a great guy and has experience with cPanel, IIRC, from his old posts at vb.

  5. #5
    Registered Member
    Join Date
    Sep 2011
    Posts
    16
    cPanel/WHM Access Level

    Website Owner

    Default Re: Compatibility: HipHop for PHP "transforms PHP source code into highly o

    With the release of the HipHop virtual machine has anyone got this up and running with cpanel?

  6. #6
    Registered Member
    Join Date
    Dec 2008
    Posts
    85

    Default Re: Compatibility: HipHop for PHP "transforms PHP source code into highly o

    50% cpu reduction, this seems worth looking into.

Similar Threads

  1. Trying to save php file after using "Code Editor"
    By cmkelly29 in forum New User Questions
    Replies: 1
    Last Post: 01-16-2011, 04:34 AM
  2. cPanel 11.28 compatibility with "Softaculous" and "RVskin"
    By basic in forum cPanel & WHM Discussions
    Replies: 4
    Last Post: 10-21-2010, 12:04 PM
  3. Replies: 0
    Last Post: 09-14-2010, 02:50 AM
  4. Is there any way to "hard code" our current php.ini settings?
    By jols in forum cPanel & WHM Discussions
    Replies: 1
    Last Post: 08-15-2008, 07:28 AM
  5. FireFox and PHP "application/x-httpd-php" Error
    By RuneOwn in forum New User Questions
    Replies: 21
    Last Post: 08-11-2007, 07:16 AM
bargain