Page 15 of 52 FirstFirst ... 5131415161725 ... LastLast
Results 211 to 225 of 780

Thread: nginx automated installer

  1. #211
    Registered Member
    Join Date
    Feb 2010
    Posts
    10

    Default

    In the old version(such as blargman's original installer and other derivative versions), if the customers adds a wildcard domain will cause nginx down.
    try to use the new version here.

    without cache version(better than old version): http://icodex.org/public_nocache.tar
    with proxy_cache version(can be purged): http://icodex.org/public.tar

    sorry for my poor english, because i live in China, english is not my mother tongue
    Last edited by icodex; 08-12-2010 at 02:43 AM.

  2. #212
    Registered Member
    Join Date
    Feb 2010
    Posts
    10

    Default

    purge cache

    squidclient -h[proxy_ip] -p[proxy_port] -mPURGE -v http://www.yourdomain.com/path/
    or
    curl -I http://www.yourdomain.com/purge/path/
    Last edited by icodex; 08-12-2010 at 01:13 AM.

  3. #213
    Registered Member
    Join Date
    Jul 2004
    Posts
    703

    Default

    Quote Originally Posted by icodex View Post
    In the old version(such as blargman's original installer and other derivative versions), if the customers adds a wildcard domain will cause nginx down.
    try to use the new version here.

    without cache version(better than old version): http://icodex.org/public_nocache.tar
    with proxy_cache version(can be purged): http://icodex.org/public.tar

    sorry for my poor english, because i live in China, english is not my mother tongue
    What is the difference between your no cache version, and 9xlinux latest version?
    Your English is OK did you notice 9xlinux website is also hosted in China ?

  4. #214
    Registered Member InterServed's Avatar
    Join Date
    Jul 2007
    Posts
    255
    cPanel/WHM Access Level

    DataCenter Provider

    Default

    There's no version made by 9xlinux. The version 9xlinux posted was made by icodex some good months ago.

  5. #215
    Registered Member
    Join Date
    Aug 2008
    Posts
    73

    Default

    I get this message after installing:

    root@host3 [/usr/src/publicnginx]# /etc/init.d/nginx restart
    Restarting nginx daemon: nginxcat: /var/run/nginx.pid: No such file or directory
    kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]
    not running[emerg]: bind() to IP:80 failed (98: Address already in use)
    [emerg]: bind() to IP:80 failed (98: Address already in use)
    [emerg]: bind() to IP:80 failed (98: Address already in use)
    [emerg]: bind() to IP:80 failed (98: Address already in use)
    [emerg]: bind() to IP:80 failed (98: Address already in use)
    [emerg]: still could not bind()
    already running.

  6. #216
    Registered Member
    Join Date
    Aug 2008
    Posts
    73

    Default

    Quote Originally Posted by desiguru View Post
    I get this message after installing:

    root@host3 [/usr/src/publicnginx]# /etc/init.d/nginx restart
    Restarting nginx daemon: nginxcat: /var/run/nginx.pid: No such file or directory
    kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]
    not running[emerg]: bind() to IP:80 failed (98: Address already in use)
    [emerg]: bind() to IP:80 failed (98: Address already in use)
    [emerg]: bind() to IP:80 failed (98: Address already in use)
    [emerg]: bind() to IP:80 failed (98: Address already in use)
    [emerg]: bind() to IP:80 failed (98: Address already in use)
    [emerg]: still could not bind()
    already running.

    After the install do I need to stop the Apache and then start nginX?

    And also do I need to change Apache port in httpd.conf or from Tweak Settings?

  7. #217
    Registered Member
    Join Date
    Feb 2010
    Posts
    10

    Default

    Quote Originally Posted by desiguru View Post
    After the install do I need to stop the Apache and then start nginX?

    And also do I need to change Apache port in httpd.conf or from Tweak Settings?
    Installation Complete -- run /etc/init.d/httpd restart to start nginx and apache

  8. #218
    Registered Member
    Join Date
    Jun 2008
    Posts
    6

    Default

    Hello;

    How about the problem with add on domain and traffic log?

  9. #219
    Registered Member
    Join Date
    Aug 2008
    Posts
    73

    Default

    Quote Originally Posted by icodex View Post
    Installation Complete -- run /etc/init.d/httpd restart to start nginx and apache
    So just restart the httpd and that's about it? No need to start nginx?

  10. #220
    Registered Member
    Join Date
    Oct 2004
    Posts
    42

    Default

    Why not remove those source-installs from that nginx installer, leave it to user to choose which way to install as some may choose to go for a more distro-compliant way and use RPMs instead of tainting the OS with even more source installs, and leave only the nginx conf files and scripts that cpanel uses and make it a practical, small and portable nginx configurator instead of bulgy installer that forces source installs?

  11. #221
    Registered Member
    Join Date
    Mar 2010
    Posts
    16

    Default Apache Status not showing

    After installing, the "Apache Status" page in WHM doesn't work anymore:

    Failed to receive status information from Apache.
    Unable to connect to local httpd server.

    @icodex: latest version, "no cache"
    Last edited by mediagenerator; 08-23-2010 at 09:15 AM. Reason: add. info

  12. #222
    cix
    cix is offline
    Registered Member
    Join Date
    Nov 2003
    Posts
    75

    Default

    I think I'm running the latest version.

    Two doubts:
    1. How can I fix apache server status ( I tried everything you recommended here).

    2. How can I see nginx server status?

  13. #223
    Registered Member
    Join Date
    Mar 2009
    Posts
    7

    Default

    i get this message and nginx will ot start
    [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)
    [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)
    [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)
    [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)
    [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)
    [emerg]: still could not bind()

  14. #224
    Registered Member
    Join Date
    Mar 2004
    Posts
    8

    Default

    Quote Originally Posted by fazaha View Post
    i get this message and nginx will ot start
    [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)
    [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)
    [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)
    [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)
    [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)
    [emerg]: still could not bind()
    Try, reboot server and see again !

  15. #225
    cPanel Quality Assurance Analyst cPanelDon's Avatar
    Join Date
    Nov 2008
    Location
    Houston, Texas, U.S.A.
    Posts
    2,554
    cPanel/WHM Access Level

    DataCenter Provider

    Default

    Quote Originally Posted by mediagenerator View Post
    After installing, the "Apache Status" page in WHM doesn't work anymore:

    Failed to receive status information from Apache.
    Unable to connect to local httpd server.
    Quote Originally Posted by cix View Post
    1. How can I fix apache server status ( I tried everything you recommended here).
    Please refer to the following forums thread: Apache status not working after customizing port - cPanel Forums

Page 15 of 52 FirstFirst ... 5131415161725 ... LastLast

Similar Threads

  1. I want to install NGINX
    By imtiax in forum New User Questions
    Replies: 4
    Last Post: 06-19-2013, 04:47 AM
  2. Is nginx admin is best nginx plugin for WHM?
    By lowhigh in forum cPanel & WHM Discussions
    Replies: 12
    Last Post: 02-14-2013, 04:39 AM
  3. Replies: 6
    Last Post: 08-19-2011, 03:38 AM
  4. Replies: 2
    Last Post: 01-11-2011, 09:51 AM

Tags for this Thread

bargain