Results 1 to 8 of 8

Thread: phpMyAdmin export.php: Missing parameter: (what|export_type) (FAQ 2.8)

  1. #1
    Registered User
    Join Date
    Nov 2010
    Posts
    4

    Question phpMyAdmin export.php: Missing parameter: (what|export_type) (FAQ 2.8)

    Hello!

    Recently cPanel was updated to WHM 11.28.39 and after that I noticed that operations like export and insert through phpMyAdmin generated an error page which says:

    export.php: Missing parameter: what (FAQ 2.8)
    export.php: Missing parameter: export_type (FAQ 2.8)

    After some searches I tried the solution proposed in http://forums.cpanel.net/f34/phpmyad...db-159865.html but it aparently didn't solve the problem.

    Some more testing later, I noticed I can execute the export in other databases, including other databases from this same user. I can also execute the export of this same problematic database using an administrative account.

    Also tried giving more permissions for the user in question, but that too didn't help.

    Then I downloaded a new copy of phpMyAdmin from it's site (the same 3.3.8 installed in cPanel), and installed it directly into the domain. In this install, I can do the export and inserts without a problem.

    Anyone have a clue as to why cPanel's phpMyAdmin is acting wild like this, and what can we do to solve it?

    Thanks in advance

    Arthur

  2. #2
    Registered Member
    Join Date
    Aug 2007
    Posts
    15

    Default re: phpMyAdmin export.php: Missing parameter: (what|export_type) (FAQ 2.8)

    I am having the same problem with Firefox 3.6.12 on 64bit win7. With the help of cpanelsource tech support we discovered the problem disappears when using IE8. I don't have a complete answer yet, but thought you might like to know a work around until a more satisfying answer can be found.

    I hope cpanel can roll out a fix for firefox soon!

  3. #3
    Registered User
    Join Date
    Nov 2010
    Posts
    4

    Default re: phpMyAdmin export.php: Missing parameter: (what|export_type) (FAQ 2.8)

    Thanks for your comment, coppershadow!

    Indeed, I tried using IE8 and it works normally. With firefox 3.6.12 on my linux pc it doesn't work. It is an easier workaround than installing phpMyAdmin somewhere. Let's hope a fix comes soon.

  4. #4
    cPanel Staff cPanelNick's Avatar
    Join Date
    Feb 2003
    Location
    Houston, TX
    Posts
    4,846

    Default re: phpMyAdmin export.php: Missing parameter: (what|export_type) (FAQ 2.8)

    By chance did you downgrade to STABLE after installing 11.28?

    This issue is being tracked with internal case # 44870.

    Thanks
    -Nick
    cPanel Inc.

    Need support? Submit a request here. Complimentary support is available to all license holders regardless of where you purchased your license.
    Need a complimentary support account? Create one here.

  5. #5
    Registered User
    Join Date
    Nov 2010
    Posts
    4

    Default re: phpMyAdmin export.php: Missing parameter: (what|export_type) (FAQ 2.8)

    Hi Nick,

    No, I didn't downgrade. It is set to RELEASE as it has been since install.

    Also, it seems this weekend version was automatically upgraded to 11.28.45, but no changes to this problem.

  6. #6
    Integration Developer cPanelDavidN's Avatar
    Join Date
    Dec 2009
    Location
    Houston, TX
    Posts
    570

    Default re: phpMyAdmin export.php: Missing parameter: (what|export_type) (FAQ 2.8)

    Hi Arthur,

    Do you have a support ticket? Please PM me so that I can assist our Tech Support.

    We've had a few similar cases reported, most were resolved by clearing all session cookies for the browser (either IE or Firefox). I'm sure you've tried this, but I thought I'd mention it just in case

    Regards,
    -DavidN
    David Neimeyer
    Integration Developer

    sdk.cpanel.net
    APIs: XML-API API1 & API2
    Check Out: Developer Downloads Integration Blog
    Need Support? Support Ticket Developer Forum Feature Requests

  7. #7
    Registered Member
    Join Date
    Jan 2009
    Posts
    8

    Default re: phpMyAdmin export.php: Missing parameter: (what|export_type) (FAQ 2.8)

    check the disk space. make sure to have some free space in /tmp.

    relogin to cpanel and use phpadmin to export the database.

    Let me know how it goes!!

  8. #8
    Registered User
    Join Date
    Nov 2010
    Posts
    4

    Default re: phpMyAdmin export.php: Missing parameter: (what|export_type) (FAQ 2.8)

    Hi anoop1285!

    /tmp has 2% utilization, so it doesn't seem to be the case.

    cPanelDavidN

    No, I didn't open a ticket yet. But guess what? I won't need one. It was really the pma cookies. I couldn't clear all cookies for other reasons, but after manually removing all pma* ones, it did export correctly.

    Thank you for the solution!

Similar Threads

  1. phpMyAdmin export error
    By never2far in forum cPanel & WHM Discussions
    Replies: 23
    Last Post: 06-13-2013, 07:19 PM
  2. phpMyAdmin can't export/import DB
    By sentono in forum Database Discussions
    Replies: 8
    Last Post: 12-17-2010, 01:44 PM
  3. Gzip export in phpmyadmin
    By web12 in forum cPanel & WHM Discussions
    Replies: 12
    Last Post: 02-11-2004, 05:29 PM
  4. Database compression export/import missing in phpmyadmin
    By F Brown in forum cPanel & WHM Discussions
    Replies: 2
    Last Post: 02-11-2004, 01:34 AM
  5. phpMyAdmin missing gzip compression for export
    By F Brown in forum cPanel & WHM Discussions
    Replies: 1
    Last Post: 02-11-2004, 01:33 AM
bargain