Results 1 to 5 of 5

Thread: can't send mails, help anyone?

  1. #1
    Registered Member
    Join Date
    May 2011
    Posts
    10

    Default can't send mails, help anyone?

    Hi.

    I got a small PHP script using phpmailer that sends a mail to a specific adress. On my old server, that worked. On the new one, it doesn't. The script reports no errors but simply that the mail has been sent successfully, but it never shows up at the recipient.

    Does anyone have any idea what might be configured incorrectly?

    I tried using the email troubleshooter in WHM. That one reported no problems either.

    I'd be very glad if anyone could help.

    Edit: Was checking some stuff in WHM, and found this:
    550 Access denied - Invalid HELO name (See RFC2821 4.1.1.1)
    Last edited by Fnorbel; 11-29-2011 at 05:09 AM.

  2. #2
    Registered Member
    Join Date
    Jan 2011
    Posts
    501
    cPanel/WHM Access Level

    Root Administrator

    Default Re: can't send mails, help anyone?

    Hello,

    Are there any errors in the error logs?

  3. #3
    Registered Member
    Join Date
    Nov 2011
    Posts
    421
    cPanel/WHM Access Level

    Root Administrator

    Default Re: can't send mails, help anyone?

    Hi,

    Check if your server's hostname is correctly setup. It should be FQDN pointing to server's primary IP address.
    Refer to
    Change Hostname
    Add an A Entry for Your Hostname
    Lifetime Linux Hosting | Linux Dedicated Servers

    ISPA Award Winner-2013 & 2014

  4. #4
    Registered Member
    Join Date
    May 2011
    Posts
    10

    Default Re: can't send mails, help anyone?

    Thanks, I'll have a look. Yep, the hostname was wrong.
    Last edited by Fnorbel; 11-30-2011 at 07:12 AM.

  5. #5
    cPanel Staff cPanelTristan's Avatar
    Join Date
    Oct 2010
    Location
    somewhere over the rainbow
    Posts
    7,609
    cPanel/WHM Access Level

    Root Administrator

    Default Re: can't send mails, help anyone?

    So, is the script working now?

    Also, for future reference, you can run this command to get more details from the exim log file:

    Code:
    exigrep user@domain.com /var/log/exim_mainlog
    You would replace user@domain.com with the email recipient name. Also, you can always try exinext as another command for any failed messages that are in queue still:

    Code:
    exinext user@domain.com
    cPResources: Support Options | More Support Options | Forums Search | cPanel.net Site Search | Mailing Lists(Alt) | Docs
    -- Tristan, Technical Analyst III, Forums Specialist, cPanel Tech Support

    Submit a ticket | Check an existing ticket

Similar Threads

  1. I can send but cannot receive e-mails
    By serlex in forum E-mail Discussions
    Replies: 9
    Last Post: 12-14-2009, 05:10 PM
  2. Replies: 1
    Last Post: 01-19-2008, 09:58 AM
  3. Exim does not send e-mails
    By EliteHosting in forum General Discussion
    Replies: 3
    Last Post: 04-04-2006, 08:59 AM
  4. Cant' send e-mails outside the server
    By wimp in forum General Discussion
    Replies: 0
    Last Post: 05-31-2004, 10:47 AM
  5. Cannot send mails
    By anish sidhan in forum General Discussion
    Replies: 0
    Last Post: 11-05-2003, 09:56 AM
bargain