Results 1 to 8 of 8

Thread: Webmail Login?

  1. #1
    Registered User
    Join Date
    Apr 2008
    Posts
    3

    Default Webmail Login?

    This is probably asked million times ... what is the settings, or php script to allow users to just enter their login name without the domain address via webmail interface? We currently disabled the popup login feature. (i.e. johndoe, not johndoe@johndoe.com) Is it possible with cpanel? We have upgraded to 11 just this week.

  2. #2
    Technical Product Specialist cPanelDavidG's Avatar
    Join Date
    Nov 2006
    Location
    Houston, TX
    Posts
    11,290
    cPanel/WHM Access Level

    Root Administrator

    Default

    Quote Originally Posted by nuveris View Post
    This is probably asked million times ... what is the settings, or php script to allow users to just enter their login name without the domain address via webmail interface? We currently disabled the popup login feature. (i.e. johndoe, not johndoe@johndoe.com) Is it possible with cpanel? We have upgraded to 11 just this week.
    As the same interface serves for all users on the server (not a single domain), this would not be possible via a setting nor should custom coding of the login interface to accommodate this be attempted on a server hosting multiple domains.

    An alternative would be to place a login script on a website where users can do this and you automatically append the domain as appropriate. Some quick modifications to our sample PHP script, cpanel-login.phps, should do the trick. You can grab a copy at: http://www.cpanel.net/cpanel-login.phps

  3. #3
    Registered User
    Join Date
    Apr 2008
    Posts
    3

    Default Thanks!!!

    I implemented the code, but having some problems. OK. I noticed that you remove the "#" to enable the type of login. From the top php script.

    #Webmail
    $protocol = 'http';
    $port = 2095;

    but after that I really don't know whatelse to do. I get this message on the address bar after i submit a login.

    http://{domain}.com//{domain}.com:2095/login/

  4. #4
    Technical Product Specialist cPanelDavidG's Avatar
    Join Date
    Nov 2006
    Location
    Houston, TX
    Posts
    11,290
    cPanel/WHM Access Level

    Root Administrator

    Default

    Quote Originally Posted by nuveris View Post
    I implemented the code, but having some problems. OK. I noticed that you remove the "#" to enable the type of login. From the top php script.

    #Webmail
    $protocol = 'http';
    $port = 2095;

    but after that I really don't know whatelse to do. I get this message on the address bar after i submit a login.

    http://{domain}.com//{domain}.com:2095/login/
    The # is an alternative way of denoting a comment in PHP. Be sure to also uncomment the protocol as well (above the port number) as well as make sure all other protocols and port numbers are commented.

    If you are unfamiliar with PHP, there are many tutorials on the internet that can assist you, including the official PHP documentation at php.net.

  5. #5
    Registered User
    Join Date
    Apr 2008
    Posts
    3

    Default Got it!

    I figured it out soon after my last comments. It login well with using the full email address and password. So I assume from your first comment there is no way to just have the username and password entered even with this PHP file you provided? My work around was just auto-fill the "username@domain.com" in the field until I figure it out myself.

  6. #6
    Registered Member
    Join Date
    Mar 2008
    Posts
    7

    Default

    This script works great for email login. But, if an incorrect user/pass is entered and submitted, you get taken to domain.com:2095/login. Is there a way to make it go back to this script.

  7. #7
    Technical Product Specialist cPanelDavidG's Avatar
    Join Date
    Nov 2006
    Location
    Houston, TX
    Posts
    11,290
    cPanel/WHM Access Level

    Root Administrator

    Default

    Quote Originally Posted by boy143878 View Post
    This script works great for email login. But, if an incorrect user/pass is entered and submitted, you get taken to domain.com:2095/login. Is there a way to make it go back to this script.
    That was a known bug. I still hear reports about it so I am unsure if the fix is still currently in EDGE and not yet propagated to the other builds.

  8. #8
    Technical Product Specialist cPanelDavidG's Avatar
    Join Date
    Nov 2006
    Location
    Houston, TX
    Posts
    11,290
    cPanel/WHM Access Level

    Root Administrator

    Default

    Quote Originally Posted by nuveris View Post
    I figured it out soon after my last comments. It login well with using the full email address and password. So I assume from your first comment there is no way to just have the username and password entered even with this PHP file you provided? My work around was just auto-fill the "username@domain.com" in the field until I figure it out myself.
    It can be done, but that is more a PHP programming issue than a cPanel/WHM API issue.

Similar Threads

  1. Login to /webmail works, clients login fails
    By itzhero in forum E-mail Discussions
    Replies: 7
    Last Post: 11-24-2011, 08:12 AM
  2. Webmail login page and customize webmail server installation
    By patelbhavin8008 in forum E-mail Discussions
    Replies: 2
    Last Post: 05-25-2011, 05:22 AM
  3. Slow login to webmail and sending mail through webmail ?
    By Hack in forum E-mail Discussions
    Replies: 7
    Last Post: 05-18-2011, 03:35 PM
  4. Replies: 0
    Last Post: 10-10-2010, 02:55 AM
  5. Showing mail quota in webmail or webmail login?
    By internetfab in forum General Discussion
    Replies: 2
    Last Post: 08-28-2007, 11:02 AM
bargain