Page 1 of 6 123 ... LastLast
Results 1 to 15 of 82

Thread: Domain redirecting to /cgi-sys/defaultwebpage.cgi

  1. #1
    Registered Member
    Join Date
    Sep 2003
    Location
    San Antonio
    Posts
    33

    Default Domain redirecting to /cgi-sys/defaultwebpage.cgi

    I removed an addon domain from an account and tried to re-add it to another account and now when i access the domain name it redirects me to domain.com/cgi-sys/defaultwebpage.cgi? Does anyone know how I can go about troubleshooting this? I've checked dns zone and it looks fine, I've also checked the vhost in httpd.conf and it seems ok too. What could be causing this?

  2. #2
    Registered Member sawbuck's Avatar
    Join Date
    Jan 2004
    Posts
    1,351
    cPanel/WHM Access Level

    Root Administrator

    Default

    Check the .htaccess file.

  3. #3
    Registered Member
    Join Date
    Sep 2003
    Location
    San Antonio
    Posts
    33

    Default

    Damn I didn't get an email notification sorry for the late reply. Yes i removed the htaccess file.

  4. #4
    Registered User
    Join Date
    Feb 2009
    Posts
    1

    Default

    I'm having the same issue. Does anyone have a resolution for this?

    Thanks!

  5. #5
    Registered Member sawbuck's Avatar
    Join Date
    Jan 2004
    Posts
    1,351
    cPanel/WHM Access Level

    Root Administrator

    Default

    Same question.

    Did you check the .htaccess file?

  6. #6
    Registered Member
    Join Date
    Sep 2003
    Location
    San Antonio
    Posts
    33

    Default

    So i just checked this domain a week later and its fixed now. That was just weird.

  7. #7
    cPanel Development cPanelKenneth's Avatar
    Join Date
    Apr 2006
    Posts
    4,270
    cPanel/WHM Access Level

    Root Administrator

    Default

    When the domain switched accounts, did the domain remain on the same IP address?
    Kenneth
    Development
    cPanel, Inc.

  8. #8
    Registered User
    Join Date
    Dec 2009
    Posts
    4

    Default

    I'm having the same issue. any ideas? It seems to be the web template
    I terminated my main account and re-added same domain with same IP
    this is not related to .htaccess

  9. #9
    Registered User
    Join Date
    Mar 2004
    Location
    Eindhoven
    Posts
    30

    Default

    Having the same issue; only this time with a brandnew domain which as not been configured on the server before. Will create a ticket at cPanel for it though. And in this case there was not change in IP; also the account it was used as an addon on is using the main-shared-ip.

  10. #10
    Registered Member
    Join Date
    May 2007
    Posts
    17

    Default

    Am having the same problem....new domain...new account on server....domain has resolved to server but is redirecting to http://domain/cgi-sys/defaultwebpage.cgi ?

  11. #11
    Registered Member
    Join Date
    Dec 2009
    Posts
    33

    Default odd

    hi

    very odd problem, i'm having it too

    i moved to a dedicated server today and the datacentre helping me set up did something to several domains and stopped it (i dont know what they did)

    I just set up a new reseller and nameservers, and new shared ip. The domain was already resolving to the ip and nameservers.

    But I get the default page thing. Now it must be getting to my server to show the default page so how can it be dns propagation?

    Yet through hidemyass dot com proxy ip it displays ok!

  12. #12
    Registered Member
    Join Date
    Aug 2003
    Posts
    78

    Default

    We have seen the same. New addon domains redirect to cgi-sys/defaultwebpage.cgi page. Even when we put an index(.html) file in their directory. Any solution for this?

  13. #13
    Registered Member
    Join Date
    Jan 2005
    Location
    Earth
    Posts
    1,052

    Default

    Change cPanel build to EDGE tree and run upcp forcefully.

  14. #14
    Registered Member
    Join Date
    Jan 2010
    Location
    Orlando, FL
    Posts
    64
    cPanel/WHM Access Level

    DataCenter Provider

    Default Same Problem!

    Has anyone gotten this figured out yet??

  15. #15
    Registered Member
    Join Date
    Jan 2010
    Location
    Orlando, FL
    Posts
    64
    cPanel/WHM Access Level

    DataCenter Provider

    Default I figured it out!

    I rarely post on forums, but nowadays since I've been working more and more with Linux based servers, and can't stand it when I'm looking for a solution and no one has posted the answer, I have decided to start posting every time I figure something out no matter where I originally looked!

    Okay, so here's how I resolved the problem:

    1) You will need to edit httpd.conf (I suggest using locate to find yours, since the paths on everyone's systems vary -- try "locate httpd.conf")

    2) You will likely find an entry like this:

    Code:
    <VirtualHost *:80>
        ServerName www.yourdomain.com
        DocumentRoot /usr/local/apache/htdocs
        ServerAdmin webmaster@yourdomain.com
        UserDir disable
    </VirtualHost>
    3) You'll need to change the above to show this instead:

    Code:
    <VirtualHost XXX.XX.XXX.XXX:80>
        ServerName www.yourdomain.com
        DocumentRoot /home/yourdom/public_html
        ServerAdmin webmaster@yourdomain.com
        UserDir disable
    </VirtualHost>
    2 Things Have Been Changed:

    1) Notice the XXX's -- these XXX's will need to be replaced by the IP address that this domain is hosted on (i.e. 123.45.67.89).

    2) Notice how the document root has been changed (you'll need to find the document root for your domain specifically, it's usually the first 7 letters of the domain name or username for the account.

    Now for the last step. . .either in WHM or in SSH restart apache (i.e. "service httpd restart") -- you *might* get error messages as shown below:

    [Wed Jan 06 00:20:07 2010] [warn] NameVirtualHost XXX.XX.XXX.XX:80 has no VirtualHosts
    [Wed Jan 06 00:20:07 2010] [warn] NameVirtualHost XXX.XX.XXX.XX:80 has no VirtualHosts
    [Wed Jan 06 00:20:07 2010] [warn] NameVirtualHost *:0 has no VirtualHosts
    [Wed Jan 06 00:20:07 2010] [warn] NameVirtualHost *:80 has no VirtualHosts

    However, these are just warnings, and Apache will still start.

    If you want to get rid of the error messages like I did later on, then you'll need to use WHM to define the VirtualHost template for your domains, since WHM writes to httpd.conf too.

    The next step (don't know why this was necessary, but it worked):

    CLEAR YOUR BROWSER'S CACHE

    Final Step:

    Create an .htaccess file in the directory that contains your index.html or index.php file, with the following SINGLE line:

    Code:
    DirectoryIndex index.html index.php
    BTW, if you created this file as root in SSH, you'll need to CHOWN the file to your web user (again first 7 letters of the domain name or username), and then CHGRP the file the same way to your web user, so that Apache can access it (kinda weird, since in Plesk, even if root owns the .htaccess file, apache can still access it, but not in cPanel for whatever reason).

    Reload the web page (i.e. www.yoursite.com). . .and you should be in business.

    If not, try going directly to a page on your server (i.e. index.html for example), and that will usually force your browser to refresh the content its pulling from the site.

    Anyway. . .I hope this helps, and I hope it was thorough enough -- if not, just shoot me a message, and I'll try to help ya out!

    - Eric Gillette

Page 1 of 6 123 ... LastLast

Similar Threads

  1. Domain always redirecting to /cgi-sys/defaultwebpage.cgi
    By Spetsnaz in forum cPanel & WHM Discussions
    Replies: 7
    Last Post: 09-11-2012, 03:27 PM
  2. Port 443 redirecting to /cgi-sys/defaultwebpage.cgi
    By RodrigoBaldasso in forum cPanel & WHM Discussions
    Replies: 2
    Last Post: 02-07-2012, 10:08 AM
  3. domain redirecting to cgi-sys/defaultwebpage.cgi please help
    By mody_coder in forum cPanel & WHM Discussions
    Replies: 1
    Last Post: 01-28-2012, 11:58 PM
  4. Parked domain redirecting to /cgi-sys/defaultwebpage.cgi
    By GoWilkes in forum cPanel & WHM Discussions
    Replies: 10
    Last Post: 09-13-2011, 01:12 PM
  5. Domain Redirecting to domain/cgi-sys/defaultwebpage.cgi
    By furkamania in forum cPanel & WHM Discussions
    Replies: 3
    Last Post: 08-09-2010, 06:06 PM
bargain