Results 1 to 3 of 3

Thread: external mail server not working

  1. #1
    Registered Member
    Join Date
    Apr 2003
    Location
    Racine, WI
    Posts
    244

    Default external mail server not working

    We've got a customer who tried to change his MX record to point to an IP address. First there was a problem because it shows up as x.x.x.x.domain.com. instead of just the IP. I changed that manually and it still doesn't work. I've got an A record for mail.domain.com for their server and an MX record for their server. When you try to ping mail.domain.com it gives you our server's IP address, not his mail server. All mail gets returned as well.

    What am I doing wrong?

    cPanel.net Support Ticket Number:
    Ben McClure
    andHosting.com

  2. #2
    Registered Member
    Join Date
    Aug 2002
    Posts
    1,052

    Default

    Make sure the zone file looks like this:
    Code:
    @    14400   IN      SOA     ns1.domain.com. admin.domain.com. (
                            2003081201     ; serial, todays date + 1
                            7200           ; refresh, seconds
                            7200           ; retry, seconds
                            1209600        ; expire, seconds
                            3600 )         ; minimum, seconds
    
    customer-domain.com. 14400 IN NS ns1.domain.com.
    customer-domain.com. 14400 IN NS ns2.domain.com.
    customer-domain.com. 14400 IN A  ip.ip.ip.ip
    
    localhost.customer-domain.com.   14400    IN A       127.0.0.1
    
    customer-domain.com. 14400 IN MX 0 mail.customer-domain.com.
    
    mail    14400        IN A        ip.ip.ip.ip
    www     14400        IN CNAME    customer-domain.com.
    ftp     14400        IN A        ip.ip.ip.ip
    Pay special attention to the periods after domain names & hostnames.

    cPanel.net Support Ticket Number:

    The rest of those who have gone before us cannot steady the unrest of those to follow.

  3. #3
    Registered Member
    Join Date
    Apr 2003
    Location
    Racine, WI
    Posts
    244

    Default

    Thank you, this was figured out, somehow it kept showing up as ip.ip.ip.ip.domain. which obviously is wrong...

    We ended up manually setting the MX and A records for mail to the IP and it works fine.

    However, the customer was unable to set his MX record through CPanel, we had to do it manually. Why would this be? Thanks.

    cPanel.net Support Ticket Number:
    Ben McClure
    andHosting.com

Similar Threads

  1. Outbound Email Working / Cant Receive Mail From External Server
    By theProject in forum E-mail Discussions
    Replies: 6
    Last Post: 03-01-2013, 01:13 AM
  2. SPF dns record for external mail server or mail server on dedicated IP
    By MironJ in forum Feature Requests for cPanel & WHM
    Replies: 3
    Last Post: 05-15-2012, 03:27 AM
  3. external mail server and php mail function
    By yoseman in forum E-mail Discussions
    Replies: 1
    Last Post: 05-04-2012, 01:30 PM
  4. External mail server
    By labahost in forum E-mail Discussions
    Replies: 9
    Last Post: 10-29-2007, 02:41 PM
  5. External Mail Server
    By oscillate in forum cPanel & WHM Discussions
    Replies: 2
    Last Post: 04-02-2006, 04:48 PM
bargain