Results 1 to 3 of 3

Thread: How can I disable ProFTP?

  1. #1
    Registered Member trakwebster's Avatar
    Join Date
    Jan 2003
    Posts
    145

    Default How can I disable ProFTP?

    I don't need proftp, so for security reasons I attempted to disable it, only to fail in several different ways. I have reported this as a bug to cpanel, but would also be grateful if anybody here knows the answer ...

    Although WHM has a 'Services Manager' in the 'Server' area, the checkbox for ProFTP is -- as far as I can tell -- broken. If you uncheck it, it will turn off proftp, which I can confirm with 'ps -aux | grep ftp'.

    However, if you reboot, proftp starts running again. And if you don't reboot, apparently every five minutes, cpanel monitors proftp, and if cpanel finds it not running, starts it up again!

    I tried a couple of alternatives, which also failed --

    NVSYSV program does not offer any access to turning off the ftp service.

    xinetd.conf and xinet.d directory have no references to ftp.

    I tried removing the proftpd file from /etc/rc.d/init.d folder. This does work, but generates a complaining message from cpanel every five minutes.

    So (1) cpanel folks please fix the broken proftpd checkbox in 'Service Manager'; and

    (2) If anyone here knows how I can disable proftpd (without generating 288 cpanel emails daily), please let me know. I would be grateful for any assistance.

    cPanel.net Support Ticket Number: 16734
    -- Arthur Cronos from Voltos
    =================================================
    The Bloggard, Un Hombre Muy Blogisto -- http://www.bloggard.com
    Your loch ness monster, your yeti, your bigfoot. Bah! I've seen worse.
    =================================================

  2. #2
    Registered Member
    Join Date
    Apr 2003
    Posts
    241

    Default

    Have you tried deleting proftp from /etc/chkserv.d if its there ? (then restarting chkservd although not sure if this is strictly needed)

    cPanel.net Support Ticket Number:

  3. #3
    Registered Member trakwebster's Avatar
    Join Date
    Jan 2003
    Posts
    145

    Default Wow!

    Wow!

    I've never seen such quick response. I got an email immediately from Darren at cpanel, who advised me to remove the proftpd file from /etc/chkservd.d/ and to restart the chkservd daemon.

    Restarting chkservd seems to have no documentation, but 'chkservd restart' produced no complaint, and it appears that proftpd is no longer running!

    Hopefully, that's it!

    Thanks, cpanel and Darren, for the amazingly quick response!

    cPanel.net Support Ticket Number:
    -- Arthur Cronos from Voltos
    =================================================
    The Bloggard, Un Hombre Muy Blogisto -- http://www.bloggard.com
    Your loch ness monster, your yeti, your bigfoot. Bah! I've seen worse.
    =================================================

Similar Threads

  1. proftp error
    By stevo in forum General Discussion
    Replies: 1
    Last Post: 10-10-2004, 05:17 AM
  2. HOWTO disable ProFTP on cpanel boxes ...
    By trakwebster in forum General Discussion
    Replies: 1
    Last Post: 06-29-2003, 02:37 PM
  3. HELP!! PROFTP
    By totalufo in forum General Discussion
    Replies: 9
    Last Post: 05-29-2003, 05:33 AM
  4. proftp
    By mrweirdo in forum General Discussion
    Replies: 0
    Last Post: 06-30-2002, 08:19 PM
  5. proftp down
    By haze in forum General Discussion
    Replies: 1
    Last Post: 03-20-2002, 11:44 PM
bargain