Results 1 to 6 of 6

Thread: Install libXpm help

  1. #1
    Registered Member
    Join Date
    Jul 2004
    Posts
    5

    Default Install libXpm help

    Hi,

    I'm trying to recompile PHP w/ GD2 installed, but I'm getting the following error in easyapache:

    configure php-4.3.9...(--with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-mcrypt --enable-magic-quotes --with-mysql --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --enable-versioning --with-zlib)...............Done
    configure: error: libXpm.(a|so) not found.

    How can I get libXpm installed? I already tried re-installing the XFree86-libs RPM in WHM.

    Usiing Fedore Core 1 w/ WHM/Cpanel

    I've downloaded libXpm-4.3.99.903-2.i686.rpm, but I don't know the correct way to install this.

    Please help.

    Thanks.

  2. #2
    Registered Member linux-image's Avatar
    Join Date
    Jun 2004
    Location
    India
    Posts
    1,190
    cPanel/WHM Access Level

    Root Administrator

    Default

    do an upcp and then try.

  3. #3
    Registered Member
    Join Date
    Jul 2004
    Posts
    5

    Default

    Still says the same thing...

  4. #4
    Registered Member linux-image's Avatar
    Join Date
    Jun 2004
    Location
    India
    Posts
    1,190
    cPanel/WHM Access Level

    Root Administrator

    Default

    install XFree86-devel-4.3.0-42.

    available at: http://tuxdesk.com/download/XFree86-....0-42.i386.rpm

    that will install the libXpm.

    let me know if the issue is still in hand.

  5. #5
    Registered Member
    Join Date
    Jul 2004
    Posts
    5

    Default

    Okay well the lipXpm has been installed successfully, but now I'm getting this earror when I ran easyApache again:

    make php-4.3.9........................................................................................................................................Done
    make: *** [sapi/cli/php] Error 1
    make php-4.3.9...(install).....Done
    make: *** [sapi/cli/php] Error 1
    /etc/rc.d/init.d/httpd start: httpd started
    configure php-4.3.9...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-mcrypt --enable-magic-quotes --with-mysql --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --enable-versioning --with-zlib)........................Done
    make php-4.3.9...(clean)....Done
    make php-4.3.9.....................................................................................................Done
    make: *** [sapi/cgi/php] Error 1
    make php-4.3.9...(install).....Done
    make: *** [sapi/cgi/php] Error 1

    What can I do now?

    Thanks

  6. #6
    Registered Member linux-image's Avatar
    Join Date
    Jun 2004
    Location
    India
    Posts
    1,190
    cPanel/WHM Access Level

    Root Administrator

    Default

    It seems you don't have pdflib (from http://www.pdflib.com/) installed.

    try without "-with-pdflib" or install it

    btw; please get me on IM; the address is on my signature.

Similar Threads

  1. unable to view libjpeg , libpng, libXpm modules in phpinfo.php
    By prashantp786j in forum cPanel & WHM Discussions
    Replies: 4
    Last Post: 07-30-2013, 11:30 AM
  2. Erro in Install (Bad file descriptor at ./install line 650)
    By CleberDantas in forum cPanel & WHM Discussions
    Replies: 11
    Last Post: 08-06-2007, 09:57 AM
  3. libxpm urgent
    By njoyhost in forum cPanel & WHM Discussions
    Replies: 0
    Last Post: 07-18-2007, 11:21 PM
  4. No Match for argument: libXpm-dev
    By Tagor in forum cPanel & WHM Discussions
    Replies: 7
    Last Post: 01-01-2006, 03:08 PM
  5. If you are running fedora and you run into "libXpm.(a|so) not found" error
    By Roy@ENHOST in forum cPanel & WHM Discussions
    Replies: 2
    Last Post: 10-20-2005, 10:48 AM
bargain