Results 1 to 5 of 5

Thread: PuTTY Fatal Error, Network error: Connection timed out

  1. #1
    Registered Member
    Join Date
    Jun 2007
    Posts
    25

    Default PuTTY Fatal Error, Network error: Connection timed out

    Hello,

    I followed a very helpful info from "A Beginner's Guide to Securing Your Server" topic.

    After I installed the firewall and changed the ssh port # from 22 to my choice, I kept disconnected from ssh after a few minutes of idle. However, I was able to log back into ssh.

    So in order to increase the ssh session time out, I modified /etc/ssh/sshd_config (with AllowTcpForwarding YES, ClientAliveInterval 120 and ServerAliveInterval 300) as advised elsewhere in the forum.

    After a minute, I went ahead and rebooted my server via ssh becasue I found the server load became quite high in WHM.

    After the server rebooted, I was able to log back into the WHM and restarted the services, but unfortunately I am NOT able to log into back to ssh anymore. I keep getting “PuTTY Fatal Error, Network error: Connection timed out” error in a little pop up window.

    My server is in data center. I use Linksys router at home but it was never been an issue with using ssh or anything such as VPN to other server and so on.

    I believe this issue caused by my miss modification to sshd_config file. Or, may be something else. I don’t know how to remove all keepalive setting that I put as I mentioned above.

    Did you ever have that similar issue? How did you resolve it?

    Please advise me.


    Thanks.

  2. #2
    Registered Member
    Join Date
    Jun 2007
    Posts
    25

    Default

    I just tried ssh again using someone else’ computer but still no lucks. I got errors “PuTTY Fatal Error, Network error: Connection refused

    Is there a way to fix or reinstall sshd_config file that I modified, via WHM. Is there any alternative way to fix this problem?

    Please advise me.


    Thanks.

  3. #3
    Registered Member This forum account has been confirmed by cPanel staff to represent a vendor. chirpy's Avatar
    Join Date
    Jun 2002
    Location
    Go on, have a guess
    Posts
    13,499

    Default

    You can have SSH run up with an empty configuration file (usually on port 22) by browsing to:

    Code:
    http://11.22.33.44:2086/scripts2/doautofixer?autofix=safesshrestart
    If you need to flush iptables, you can also:

    Code:
    http://11.22.33.44:2086/scripts2/doautofixer?autofix=iptablesflush
    Jonathan Michaelson

    cPanel Server Configuration, Security and Antivirus/AntiSpam Services
    http://www.configserver.com

  4. #4
    Registered Member
    Join Date
    Jun 2007
    Posts
    25

    Default

    Thank you for the response.

    I just tried as you advised and I am now able to use ssh but with default port #22 only.

    I still can see my ports configuration settings in conf.apf file (I insall the firewall as I mentioned above posts). However, I am NOT able to use that new ssh port. Do you know why?

    Thanks.

  5. #5
    Registered Member
    Join Date
    Jun 2007
    Posts
    25

    Default

    I haven't changed a thing since my last post but I am now UNABLE to ssh to the server again. I have downloaded the whm explorer but don't know how to use it correctly. Do I have to do the iptable flashing again or is there any other alternative way to fix this issue for good?

    Please advise me.

    Thanks.
    Last edited by cwuser; 06-30-2007 at 07:59 PM.

Similar Threads

  1. Replies: 2
    Last Post: 12-23-2013, 12:24 PM
  2. Replies: 2
    Last Post: 07-18-2011, 06:19 AM
  3. Cpanel Fatal Timed Out Error
    By jisha in forum General Discussion
    Replies: 0
    Last Post: 05-15-2007, 02:49 PM
  4. Replies: 57
    Last Post: 11-05-2005, 08:16 AM
  5. spamd connection timed out error
    By anup123 in forum General Discussion
    Replies: 3
    Last Post: 09-11-2005, 06:33 PM
bargain