Results 1 to 4 of 4

Thread: suexec issues (I searched forums and found nothing useful)

  1. #1
    Registered Member
    Join Date
    Aug 2003
    Location
    Tucson,AZ
    Posts
    77

    Default suexec issues (I searched forums and found nothing useful)

    After recompiling apache and php for new module support I found that the script aliases on httpd.conf like:

    ScriptAlias /webmail /usr/local/cpanel/base/wredirect.cgi

    and such don't work. suexec log says:

    [2004-07-07 14:26:45]: error: target uid/gid (32003/504) mismatch with directory (0/0) or program (0/10) or trusted user (0/10)

    Not sure why all of a sudden it's not allowed access to /usr/local/cpanel/base. It appears that during the upgrade suexec didn't get seeded with correct doc_root and other information to run properly.

    Doing easyapache I thought I saw mention of 'patching suexec'. Does cpanel hack it to allow it to function in such a way that it's originally not supposed to?

    Any ideas?

    bigj

  2. #2
    Registered Member
    Join Date
    Aug 2003
    Location
    Tucson,AZ
    Posts
    77

    Default

    Update:

    It appears WHM and easyapache don't actually update anything. I noticed this when I looked at phpinfo(). I had enabled curl, curl SSL and openssl support and it actuallly never recompiles it with these new feature. No errors either.

    Could this be a more widespread problem that effects recompiling apache via these two methods also? I have read that other users have had similar issues but I haven't seen a posted fix for it.

    bigj

  3. #3
    Registered Member
    Join Date
    May 2003
    Posts
    73

    Default

    Are you compiling the PSPELL module? In the actual SSH it will say what caused the compile to fail.

  4. #4
    Registered Member
    Join Date
    Aug 2003
    Location
    Tucson,AZ
    Posts
    77

    Default

    No I'm not compiling pspell. When I run it from the CLI I do get errors right at the end that says this:

    /usr/include/openssl/ssl.h:909: syntax error before "KSSL_CTX"
    /usr/include/openssl/ssl.h:931: syntax error before '}' token
    make: *** [ext/zlib/zlib.lo] Error 1

    then it finishes up with Frontpage stuff and restarts apache. Looking at the apache binaries they have been updated. Looking at the php stuff it's never been touched. Looking at my phpinfo() page it also shows that it hasn't been update since 12:43 today (7/6). This is even after I just tried and supposedly rebuilt it. I'm assuming that since the ssl stuff failed all of the php stuff failed.

    This still doesnt' answer why suexec isn't allowing access to /usr/local/cpanel/base

    bigj

Similar Threads

  1. CGI Path Not Found When Using SUEXEC
    By vince512 in forum General Discussion
    Replies: 4
    Last Post: 07-12-2009, 03:05 PM
  2. Drive Space Warning...I have searched
    By bigpy2003 in forum General Discussion
    Replies: 4
    Last Post: 01-24-2006, 11:13 PM
  3. cpanel redirect.cgi - SuExec issues
    By tgibobby in forum General Discussion
    Replies: 3
    Last Post: 10-02-2005, 09:19 PM
  4. searched, seen, and still wondering
    By WeMasterz5 in forum General Discussion
    Replies: 7
    Last Post: 08-02-2003, 09:05 PM
  5. Mailman/SuExec issues resolved?
    By UnkleMunky in forum General Discussion
    Replies: 1
    Last Post: 01-19-2003, 02:34 PM
bargain