Results 1 to 10 of 10

Thread: www.domain.com/cpanel error

  1. #1
    Registered User
    Join Date
    May 2005
    Posts
    1

    Default www.domain.com/cpanel error

    I cant get into /cpanel, /whm, or /webmail..

    here are some errors i found in the logs

    [Sun Jun 11 00:58:02 2006] [error] [client 70.31.76.95] (13)Permission denied: getgrgid: invalid groupid 1007
    [Sun Jun 11 00:58:02 2006] [error] (13)Permission denied: exec of /usr/local/cpanel/cgi-sys/redirect.cgi failed
    [Sun Jun 11 00:58:02 2006] [error] [client 70.31.76.95] Premature end of script headers: /usr/local/cpanel/cgi-sys/redirect.cgi

  2. #2
    Registered Member
    Join Date
    Jan 2006
    Location
    India
    Posts
    31

    Default

    Hi,

    Check the permission and ownership of /usr/local/cpanel/cgi-sys/redirect.cgi


    Thanks

    Regards
    Sanju Abraham

    www.mycutelife.net
    Last edited by sanjuabrahamk; 08-07-2007 at 06:05 PM.

  3. #3
    Registered User
    Join Date
    May 2005
    Posts
    2

    Default Please be more specific

    Quote Originally Posted by sanjuabrahamk
    Hi,

    Check the permission and ownership of /usr/local/cpanel/cgi-sys/redirect.cgi


    Thanks

    Regards
    Sanju
    And what would the correct permissions and ownership be?

  4. #4
    Registered Member brianoz's Avatar
    Join Date
    Mar 2004
    Location
    Melbourne, Australia
    Posts
    1,154
    cPanel Access Level

    Root Administrator

    Default

    # ll -L /usr/local/cpanel/cgi-sys/redirect.cgi
    -rwxr-xr-x 1 root wheel 915 Nov 21 2004 /usr/local/cpanel/cgi-sys/redirect.cgi*

  5. #5
    Registered Member
    Join Date
    Jul 2005
    Posts
    12

    Default

    what is the httpd.conf include line for that file? apache lost it during a config rewrite (as cpanel/whm always messes up in some way...)

  6. #6
    Registered Member brianoz's Avatar
    Join Date
    Mar 2004
    Location
    Melbourne, Australia
    Posts
    1,154
    cPanel Access Level

    Root Administrator

    Default

    Code:
    ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi

  7. #7
    Registered Member
    Join Date
    Jul 2005
    Posts
    12

    Default

    Thanks. easyapache always misses this out (well, almost always)

  8. #8
    Registered Member brianoz's Avatar
    Join Date
    Mar 2004
    Location
    Melbourne, Australia
    Posts
    1,154
    cPanel Access Level

    Root Administrator

    Default

    Want a tip?
    Code:
    cp /etc/httpd/conf/httpd.conf /etc/httpd/conf/httpd.conf.ok

  9. #9
    Registered User
    Join Date
    May 2007
    Posts
    3

    Default )Permission denied: exec of /usr/local/cpanel/cgi-sys/redirect.cgi failed

    make sure that all the files in /usr/local/cpanel/cgi-sys/*.cgi have 755 permission,
    also the files /usr/local/cpanel/base/*.cgi should be under group wheel.

    In /etc/httpd/conf/httpd.conf file check following correctly.
    覧覧覧覧覧覧覧覧覧覧覧覧覧覧覧覧
    ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/webmail/(.*) /usr/local/cpanel/cgi-sys/wredirect.cgi
    覧覧覧覧覧覧覧覧覧覧覧覧覧覧覧覧
    Also try
    /scripts/updatenow
    /scripts/fixeverything
    /scripts/upcp 貿orce

    If that doesn稚 even work for you then in httpd.conf change this line
    RLimitMEM 23178922
    and replaced it with
    RLimitMEM 157286400

    Also some times it may happen because of phpsuexec. So you can try turning it off by going to 摘nable/Disable SuExec under 鉄erver Setup in WHM.

    ========
    Make sure that the permission of /usr/bin/perl is 755
    ========

    Regards,

    Hari
    Logicsupport.com

  10. #10
    Registered User
    Join Date
    Sep 2006
    Posts
    1

    Default

    thanks that fixed my issue after enabling su_exec

    it makes sense

Similar Threads

  1. www. domain points to default domain, without www. works?
    By Liam W in forum General Discussion
    Replies: 3
    Last Post: 07-10-2012, 10:01 PM
  2. Redirect WWW to non WWW, for primary domain, and parked domain
    By basketmen in forum General Discussion
    Replies: 1
    Last Post: 10-26-2011, 09:52 AM
  3. Push on cpanel the www.domain.com to domain.com
    By ASTRAPI in forum General Discussion
    Replies: 3
    Last Post: 04-11-2011, 06:17 PM
  4. Adding www. to domain name returns server not found error
    By phoenix2gee in forum General Discussion
    Replies: 2
    Last Post: 10-10-2009, 11:46 PM
  5. Replies: 2
    Last Post: 07-19-2006, 08:07 AM
bargain