1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

acces phpmyadmin asking username and password

Discussion in 'Database Discussions' started by gamgam, Dec 10, 2010.

  1. gamgam

    gamgam New Member

    Joined:
    Apr 7, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    usually if i acces phpmyadmin from cpanel, it always directly to phpmyadmin page, but suddenly if i acces phpmyadmin it asking username and password ..

    how to fix it, i just want to like usually..

    please advise.

    thx before
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    12,118
    Likes Received:
    31
    Trophy Points:
    48
    Location:
    Pennsylvania
    The easiest answer is to clear your cache, close all browsers and then give it another try from the start. Also be sure you're not logging into a normal cPanel account as root or reseller.
     
  3. cPanelDavidN

    cPanelDavidN Integration Developer
    Staff Member

    Joined:
    Dec 17, 2009
    Messages:
    570
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    If that doesn't work, then it's likely your account's MySQL password has gotten out of sync with your cPanel account password. Under normal circumstances those passwords are the same, however, the way that phpMyAdmin was loaded in previous versions (cPanel versions before 11.28) it would ensure that the password was synced before loading the application. In 11.28 we removed that auto-syncing functionality and added the login form. In this way, if you're MySQL password is different for a reason, we don't overwrite it, and you can still log into phpMyAdmin.

    If you can put your cPanel username and password into the phpMyAdmin login form and successfully authenticate, then the problem is most certainly just cache related, as InfoPro suggests. This will be the case most of the time.

    Regards,
    -DavidN

    Reference Notes
    - CHANGLOG: Case 43447
    - Release Notes: Changed to phpMyAdmin Authentication
     
  4. bsasninja

    bsasninja Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    But its a way to avoid this or every time you log to phpmyadmin will ask you the username/password?

    I could log in typing the database username and password.
     
  5. cPanelJared

    cPanelJared cPanel Staff
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,835
    Likes Received:
    12
    Trophy Points:
    38
    Location:
    Houston, TX
    If the cPanel user password and MySQL password are not the same, you can try resetting the account password using Main >> Account Functions >> Password Modification. This function will attempt to reset the cPanel user password for the system and MySQL. This should result in the system password and MySQL password again being in sync, preventing the phpMyAdmin log-in page.

    If you are able to log into phpMyAdmin using the existing cPanel username and password, then clearing the browser cache should help. If it does not, please submit a ticket so that we may investigate the problem directly on your server and offer more specific advice.
     
  6. MaraBlue

    MaraBlue Member

    Joined:
    May 3, 2005
    Messages:
    335
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Carmichael, CA
    I've never set a different password for MySQL than for my (own personal) cPanel account, and even after the upgrade to 11.28 on what used to be known as the RELEASE tree, I could always automatically go to PHPMyAdmin from within cPanel. With last night's upgrade to 11.28.87 this is changed.

    My cPanel username and password are not working in the PHPMyAdmin login form.

    EDIT: And as for the annoying "stock suggestion" of clearing your browser cache... #1, I have cache disabled in my main browser, and #2 I also tried logging in from a browser I have never accessed cPanel from. Same login problem.
     
    #6 MaraBlue, Mar 22, 2011
    Last edited: Mar 22, 2011
  7. MaraBlue

    MaraBlue Member

    Joined:
    May 3, 2005
    Messages:
    335
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Carmichael, CA
    And yes, I'm logged in as the user, not root.

    EDIT: Changing the cPanel password, then changing it back, worked. Of course by now I've forgotten why I was trying to login to PHPMyAdmin in the first place...
     
    #7 MaraBlue, Mar 22, 2011
    Last edited: Mar 22, 2011
  8. 4u123

    4u123 Member

    Joined:
    Jan 2, 2006
    Messages:
    741
    Likes Received:
    1
    Trophy Points:
    18
    Can I ask - under what circumstance would the user's mysql password be different from the cpanel password? I'm not aware of any option they may have of changing it.
     
  9. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,318
    Likes Received:
    7
    Trophy Points:
    38
    This used to be a manual operation performed by a system admin. Typically this was/is for users who use their main cPanel account for the MySQL access credentials when configuring something like wordpress. Making the passwords distinct prevented an exploit in something like wordpress from giving the perp access to the cPanel account.
     
  10. ckh

    ckh Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Phoenix, AZ
    I used WHM's transfer to transfer 2 sites and ran into the phpMyAdmin login problem. Changing the cPanel password worked for both.

    However... I'm also receiving the login form when I try to access phpMyAdmin from WHM. Tried changing the root password and that didn't do it. How would I go about getting rid of the login form from WHM?
     
  11. cPanelTristan

    cPanelTristan Active Member
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,621
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    Hello ckh,

    Could you try running the following script to see the results:

    Code:
    /usr/local/cpanel/bin/updatephpmyadmin --force
    If this does not work, please see if you can even get into MySQL command line:

    Code:
    mysql
    mysqladmin proc
    If both return an error about root@localhost, please post the error message. This would indicate an issue with MySQL functioning properly for the root user to connect with the /root/.my.cnf password set (please do not change the root password manually in the /root/.my.cnf file at any time, since this does not change it in MySQL itself).

    Thanks!
     
  12. ckh

    ckh Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Phoenix, AZ
    Odd, I had already ran that and it didn't have any affect. Tried it today and it all seems well now. Thanks!
     

Share This Page