1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BoxTrapper spam verification delayed 24 hours causes more spam

Discussion in 'E-mail Discussions' started by openaccess, Jul 5, 2012.

  1. openaccess

    openaccess Member

    Joined:
    Jan 22, 2006
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    I have a mailbox with BoxTrapper set up. It is working fairly well. The problem is that it sends verification messages out to spammers with potentially forged mailboxes or unresponsive mail servers. The user reports that they are getting 10+ spam emails a day with the following content:

    -------------------------
    Code:
    From: Mail Delivery System [mailto:xxx@mydomain]
    Sent: Wednesday, July 04, 2012 7:56 PM
    To: <Mailbox>
    Subject: Warning: message 1Sm5oy-0008NX-Rt delayed 24 hours
    
    This message was created automatically by mail delivery software.
    A message that you sent has not yet been delivered to one or more of its
    recipients after more than 24 hours on the queue on <MyDomain>.
    
    The message identifier is: 1Sm5oy-0008NX-Rt
    The subject of the message is: Your email requires verification
    verify#U3XizwFbZzZndfOII3vC1-1341332364)
    The date of the message is: Tue, 03 Jul 2012 09:19:24 -0700
    
    The address to which the message has not yet been delivered is:
    
    alyana@asp.iloveyougolf.com
    Delay reason: SMTP error from remote mail server after initial
    connection:
    host asp.iloveyougolf.com [69.22.146.26]: 421 asp.iloveyougolf.com out
    of connection slots
    
    No action is required on your part. Delivery attempts will continue for some
    time, and this warning may be repeated at intervals if the message remains
    undelivered. Eventually the mail delivery software will give up, and when
    that happens, the message will be returned to you.
    
    --------------------------

    How can I disable these emails to the user? They do not need them and are asking me to turn them off, even if for legitimate email.
     
  2. openaccess

    openaccess Member

    Joined:
    Jan 22, 2006
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Solution #1:
    Create user or account level filter to discard messages. Set the rule to match "Subject" and "matches regex" and use the following string (without quotes): "Warning: message .* delayed .* hours"

    Solution #2:
    Use the Exim Advanced Configuration Editor
    "Add Additional Configuration Setting" for "delay_warning = 0" just above SECTION: BEGINACL.
    This is server wide; it cannot be applied to individual accounts, as far as I know. One option for a specific account is to move them to their own server.

    Exim Specification - 11. Main configuration

    Code:
    delay_warning
    
    Type: time list
    Default: 24h
    
    When a message is delayed, Exim sends a warning message to the sender at intervals specified by this option. If it is set to a zero, no warnings are sent. The data is a colon-separated list of times after which to send warning messages. Up to 10 times may be given. If a message has been on the queue for longer than the last time, the last interval between the times is used to compute subsequent warning times. For example, with
    
    delay_warning = 4h:8h:24h
    
    the first message is sent after 4 hours, the second after 8 hours, and subsequent ones every 16 hours thereafter. To stop warnings after a given time, set a huge subsequent time. 
    
     
  3. MaraBlue

    MaraBlue Member

    Joined:
    May 3, 2005
    Messages:
    335
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Carmichael, CA
    Apparently setting delay_warning to 0 is no longer allowed. I *think* I found a work-around, however. I set it to '10d', where an bounce message still in the queue is set to be discarded after '7d'.
     

Share This Page