1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

can't send mails, help anyone?

Discussion in 'E-mail Discussions' started by Fnorbel, Nov 29, 2011.

  1. Fnorbel

    Fnorbel New Member

    Joined:
    May 6, 2011
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hi.

    I got a small PHP script using phpmailer that sends a mail to a specific adress. On my old server, that worked. On the new one, it doesn't. The script reports no errors but simply that the mail has been sent successfully, but it never shows up at the recipient.

    Does anyone have any idea what might be configured incorrectly?

    I tried using the email troubleshooter in WHM. That one reported no problems either.

    I'd be very glad if anyone could help.

    Edit: Was checking some stuff in WHM, and found this:
    550 Access denied - Invalid HELO name (See RFC2821 4.1.1.1)
     
    #1 Fnorbel, Nov 29, 2011
    Last edited: Nov 29, 2011
  2. LinuxTechie

    LinuxTechie Member

    Joined:
    Jan 22, 2011
    Messages:
    501
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    Are there any errors in the error logs?
     
  3. storminternet

    storminternet Member

    Joined:
    Nov 2, 2011
    Messages:
    431
    Likes Received:
    0
    Trophy Points:
    16
  4. Fnorbel

    Fnorbel New Member

    Joined:
    May 6, 2011
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Thanks, I'll have a look. Yep, the hostname was wrong.
     
    #4 Fnorbel, Nov 30, 2011
    Last edited: Nov 30, 2011
  5. cPanelTristan

    cPanelTristan Active Member
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,621
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    So, is the script working now?

    Also, for future reference, you can run this command to get more details from the exim log file:

    Code:
    exigrep user@domain.com /var/log/exim_mainlog
    You would replace user@domain.com with the email recipient name. Also, you can always try exinext as another command for any failed messages that are in queue still:

    Code:
    exinext user@domain.com
     

Share This Page