1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Connection to IMAP server failed"

Discussion in 'E-mail Discussions' started by psarema.gr, Oct 15, 2008.

  1. psarema.gr

    psarema.gr New Member

    Joined:
    May 28, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Athens Greece
    Hello,

    Since today I (and my clients) get this message when I try to connect to my webmail account

    "Connection to IMAP server failed" with both Horde and Roundcube

    I restarted cpanel but same problem again.
    I tried to follow some sollutions (not exactly for the same problem but similar) with no luck, like the one posted in

    http://forums.cpanel.net/showthread.php?t=86609&highlight=webmail+login+failed

    Can you please advise me what to do?
     
  2. Scott Greczkows

    Joined:
    Feb 5, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    I have also been having this problem since yesterday.

    I am running the latest current version.
     
  3. anilg

    anilg New Member

    Joined:
    Oct 15, 2008
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    india
    logs

    Hey guy's
    both can you pelase send a logs regarding your issues ?

    let em check after this....
     
  4. Scott Greczkows

    Joined:
    Feb 5, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    I am not sure what logs to send nor where to send them.

    Let me know and I will happily post them. :)
     
  5. laith3

    laith3 New Member

    Joined:
    Nov 5, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Webmail Broken

    Imap logs should be located in /var/log/maillog/

    I'm having the same issue with not being able to connect to Imap server. All webmail (Horde, SqirrelMail, and RoundCube) seems to be broken.

    Horde shows "Login failed because your username or password was entered incorrectly.",

    SquirrelMail shows "Warning: fsockopen() [function.fsockopen]: unable to connect to localhost:143 (Connection refused) in /usr/local/cpanel/base/3rdparty/squirrelmail/plugins/login_auth/functions.php on line 129"

    RoundCube shows "Connection to Imap server failed".

    When webmail was working a few days ago, Imap logs were showing in /var/log/maillog/, but now Imap does not seem to be logging anymore.

    I was able to fix webmail initially by updating CPanel - /scripts/upcp –force
    But it seemed to break again shortly after that. I've noticed a lot of discussion here about this problem, but no solution, so I don't expect a reply. Just wanted to share my experience with webmail. Thanks.
     
  6. sirotex

    sirotex Member

    Joined:
    Jul 10, 2008
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    I ran into this problem a few days ago.

    You can easily fix it by going to WHM > Service Configuration > IMAP Configuration. And enabling IMAP.

    It is because IMAP has been upgraded within the whm update.
     
  7. laith3

    laith3 New Member

    Joined:
    Nov 5, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hmm... that setting doesn't exist on my system. Maybe there's something else I need to enable. This is a fresh install of CPanel on a VPS running CentOS 5.2. WHM shows version information (top right) as:
    cPanel 11.24.0-C30898 - WHM 11.24.0 - X 3.9
    CENTOS 5.2 i686 on virtuozzo

    I do see the setting you're referring to on one of our old servers (not VPS) at
    Main >> Service Configuration >> IMAP Configuration.

    I've tried enabling either mail server with name results.
    Main >> Service Configuration >> Mailserver Selection (Courier and Dovecot).

    ----

    For some reason, webmail started working again today. Hmm... maybe WHM/CPanel did an auto-update overnight. I'll have to check to logs. Well, everything is working perfectly on my new WHM/CPanel installation, so I'm a happy camper :)
     
    #7 laith3, Nov 10, 2008
    Last edited: Nov 11, 2008
  8. laith3

    laith3 New Member

    Joined:
    Nov 5, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hmm... the webmail problem started all over again. No updates have been made.

    Horde shows "Login failed because your username or password was entered incorrectly.",

    SquirrelMail shows "Warning: fsockopen() [function.fsockopen]: unable to connect to localhost:143 (Connection refused) in /usr/local/cpanel/base/3rdparty/squirrelmail/plugins/login_auth/functions.php on line 129"

    RoundCube shows "Connection to Imap server failed".

    I have noticed that occasionally CPanel and WHM will say in the header "VPS Optimized 2", and sometimes just "VPS Optimized", indicating different versions.
     
  9. nickp666

    nickp666 Member

    Joined:
    Jan 28, 2005
    Messages:
    770
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    /dev/null
    If you are seeing from squirrel:

    check in /etc/hosts to see if there is a line:
    Code:
    127.0.0.1 localhost
    
    if its not there, add it and webmail will magically work again :)
     
  10. sirotex

    sirotex Member

    Joined:
    Jul 10, 2008
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    That is nothing to do with it... The problem is IMAP isnt Enabled, you will have to go and fish around in WHM for IMAP configuration editor :)

    Which in the 11.24 cPanel version is now named 'Mailserver Configuration'
     
    #10 sirotex, Nov 14, 2008
    Last edited: Nov 14, 2008
  11. duranduran

    duranduran Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    Same problem here (and i have the 127.0.0.1 localhost in my /etc/hosts as well).

    ERROR: Connection dropped by IMAP server.

    Any fix ?
     
  12. rmackay

    rmackay Member

    Joined:
    Nov 26, 2002
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Did this ever get fixed for you? I am seeing this problem now as well.
     
  13. WireNine

    WireNine Member

    Joined:
    Aug 14, 2006
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    This issue seems to be randomly spreading across servers.
     
  14. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,288
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Houston, TX
    This issue only affects Horde and Roundcube? What about Squirrelmail? Are you able to telnet to port 143? What about use IMAP using an IMAP client on your workstation?
     
  15. Snowman30

    Snowman30 Member

    Joined:
    Apr 7, 2002
    Messages:
    686
    Likes Received:
    0
    Trophy Points:
    16
    we have the same problem that everyone else is reporting

    telnet to 143 says connection refused

    ive tried almost everythign i can think of to correct this
     
  16. achieverzain

    achieverzain New Member

    Joined:
    May 18, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks

    Thanks that did helped me to resolve my issue.
     
  17. marcopferreira

    marcopferreira New Member

    Joined:
    Oct 28, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    thanks

    had the same problem... what worked for me was the addition of the missing "127.0.0.1 localhost" line to the /etc/hosts file.

    But I wonder what made it go away in the first place?!?!?
     
  18. krillin

    krillin New Member

    Joined:
    Jan 14, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello, I have some problems with SSL or IMAP or POP3...
    On my mobile, I create new IMAP or POP3 connection (for both is the same problem), incoming server security is ok, but for outgoing server I must to setup PORT: 465 and SECURITY: SSL (accept all certificates) - then work fine.
    But when change that and choose for PORT: 587 and SECuRITY: nothing - my outgoing mail server dont work.

    How do I configure WHM so it does not require more setup SSL for outgoing mail server.

    Thanks in advanced.
     
    #18 krillin, Jan 14, 2012
    Last edited: Jan 14, 2012
  19. ruzbehraja

    ruzbehraja Member

    Joined:
    May 19, 2011
    Messages:
    333
    Likes Received:
    0
    Trophy Points:
    16
    Please do not post multiple times regarding the same issue, it will not increase the probability of a reply.
     

Share This Page