1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

error 500 bug (cpanel/whm & sites not working)

Discussion in 'General Discussion' started by jacksony, Feb 17, 2006.

Thread Status:
Not open for further replies.
  1. jacksony

    jacksony Member

    Joined:
    Nov 30, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    hi recently i encountered a strange error 500 problem which cause my clients to display error 500 error when they try to access their cpanel and even cause their websites to display 'error 500'.

    I have to restart vps using the vps control panel to fix it. May I know is it cpanel for this sudden error? will they be fix for it so that there will not be sudden occurance again?

    thank you.
     
  2. hclloveh

    hclloveh New Member

    Joined:
    Aug 19, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Can't login to cpanel: No response from subprocess with exit signal: 255

    Hi,

    When I try to creat a new hosting account on my WHM, this account shows "MISSING" on column "IP Address" from hosting account's list.

    Also when I try to login into this account, it shows:

    Internal Server Error 500
    No response from subprocess with exit signal: 255
    cpsrvd/11.32.2.25 Server at xxx.xxx.xxx.xxx

    My etc/fstab file

    Code:
    none /dev/pts/ devpts rw 1 1
    When trying to creat a hosting account, it created, but including an error:

    Code:
    safe_userchgid: chown: /home/teahostn/etc: Permission denied at /usr/local/cpanel/Cpanel/SafetyBits.pm line 93.
    Cpanel::SafetyBits::safe_userchgid(539, 12, '/home/teahostn/etc') called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 855
    Whostmgr::Accounts::Create::_wwwacct('plan', 'hostlv1', 'maxpark', 'unlimited', 'max_defer_fail_percentage', 'unlimited', 'hasshell', 'n', ...) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 1859
    Whostmgr::Accounts::Create::__createaccount('customip', '--Auto Assign--', 'plan', 'hostlv1', 'language', 'en', 'maxpark', 'unlimited', ...) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 1909
    Whostmgr::Accounts::Create::_createaccount('customip', '--Auto Assign--', 'plan', 'hostlv1', 'language', 'en', 'maxpark', 'unlimited', ...) called at whostmgr/bin/whostmgr5 line 565
    main::wwwacct() called at whostmgr/bin/whostmgr5 line 214
    Any suggest?

    I tried /scripts/rebuildhttpdconf, but still nothing was happended.
     
  3. Eric

    Eric Administrator

    Joined:
    Nov 25, 2007
    Messages:
    673
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Texas
    Re: Can't login to cpanel: No response from subprocess with exit signal: 25

    Howdy,

    Please open a ticket. We need to take a look at this.

    Thanks!
     
  4. souzafo

    souzafo New Member

    Joined:
    Mar 24, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Rio de Janeiro, Brazil
    Error 500 when logging into cPanel

    After a reboot my server now display the attached message when access WHM.

    And I'm not able to log in as root.

    Here the log:
    -- {Server Identifying information removed by moderator for security reasons}
    Internal Server Error: "GET /cpsess6291786712/ HTTP/1.1" 500 No response from subprocess (whostmgr (cpanel)) with exit signal: 0
     

    Attached Files:

  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,453
    Likes Received:
    0
    Trophy Points:
    36
    Re: Error 500 when logging into cPanel

    Please submit a ticket using the link in my signature.
     
  6. LasseTK

    LasseTK Member

    Joined:
    Apr 15, 2005
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Re: Error 500 when logging into cPanel

    I am having the same issue after the upgrade to the new cPanel release. It would be great if you provided the solution here on the forum so that we do not have to log a request.:mad:

    - - - Updated - - -

    I fixed the issue with the following command line:

    /etc/rc.d/init.d/cpanel restart

    That got everything to work again. I have now changed to the STABLE tier instead. Hoping that you will have this fixed before it moves to the STABLE tier.
     
  7. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,453
    Likes Received:
    0
    Trophy Points:
    36
    Re: Error 500 when logging into cPanel

    It might just simply be the update being incomplete and still in progress. We can't determine the cause without access to the server.
     
  8. hostingcontrol

    hostingcontrol New Member

    Joined:
    Dec 9, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Re: Error 500 when logging into cPanel

    We also had the same error 500 problem (on 25-11-2012 version 11.34.0.9 release), this in combination with update time-outs.
    Our solution:
    /etc/rc.d/init.d/cpanel restart

    /scripts/upcp -force
    and
    /etc/rd.d/init.d/cpanel restart
     
  9. Thijssss

    Thijssss New Member

    Joined:
    Nov 20, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Re: Error 500 when logging into cPanel

    Strange, one of our servers ran in to this exact same problem last night.
    A restart of the cpanel services using "/etc/init.d/cpanel restart" solved it.

    I am running the STABLE with updates set to manual. (CLOUDLINUX 6.3 x86_64 – WHM 11.34.0 (build 9))
    It does seem to do some checks every night (I looked in the tar.gz):

    [2012-11-29 04:29:54 +0100] info [gather-update-logs] File /usr/local/cpanel/logs/update_analysis/2012-11-29T03:29:47Z.tar.gz has been sent successfully to updatelogdrop.cpanel.net.

    And then it goes wrong, but without a timestamp:

    Internal Server Error: "GET /cpsess132579018/frontend/x3/sql/index.html HTTP/1.1" 500 No response from subprocess ( (cpanel)) with exit signal: 0
    ...
    cpsrvd [2506] Shutting down due to SIGTERM
    -- RESTART MARKER (PID 717951 at 1354184220)--
     
  10. diegorxmx

    diegorxmx New Member

    Joined:
    Oct 9, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Internal Server Error 500 - No response from subprocess (/usr/local/cpanel…

    Hello, have a good day.

    I have a problem with my WHM server, currently I have installed various plugins from "ConfigServer" such as: ConfigServer Security Firewall, Mail ConfigServer Manage, ConfigServer Mail Queues etc.

    They worked pretty well yesterday and today in the morning, and had long been working since my server is online, but now that you upgrade your WHM / cPanel stopped working, throwing Next message every time I open a plugin from the plugins area WHM.

    "Internal Server Error

    500

    No response from subprocess (/ usr / local / cpanel / whostmgr / docroot / cgi / addon_RKHUNTER.cgi) with exit signal: 255

    -------------------------------------------------- ------------------------------
    cpsrvd/11.34.0.9 Server at [server name] "

    The funny thing is that they are the only plugins that stopped working, I have also ModSec Control, RVSkin Manager, Xtra Utlimate, etc, only two of my plugins work, others do not.

    Try doing (and elsewhere recommend) a / scripts / upcp - force
    but did not work ... try it when I throw this message:

    => Log opened from /scripts/upcp at Tue Dec 4 15:29:18 2012
    [20121204.152918] Detected cron = 0 (Terminal detected)
    => Log closed Tue Dec 4 15:29:18 2012
    [20121204.152918] Running hooks Standardized
    [20121204.152918] mtime on upcp is 1338874032 (Tue June 5 00:27:12 2012)
    [20121204.152918] E Running `/ usr / local / cpanel / scripts / updatenow - upcp - log = / var/cpanel/updatelogs/update.1354656558.log - force` failed, exited with code 65280
    => Log closed Tue Dec 4 15:29:18 2012
    root @ server [~] # /scripts/upcp --force
    [20121204.152955] Detected cron = 0 (Terminal detected)

    Completely unaware that this happening, I would greatly appreciate that support telling me I'm doing wrong or have not done.

    No more for now, I leave you with a warm greeting.

    Diego.
     
  11. ttremain

    ttremain Member

    Joined:
    Feb 16, 2003
    Messages:
    202
    Likes Received:
    0
    Trophy Points:
    16
    Re: Internal Server Error 500 - No response from subprocess (/usr/local/cpa

    Same here. Worked on 5 servers, but not this one. I assume there are multiple update servers, via some DNS round robin, and this one server is overloaded or crashed.



    root@fg01 [~]# /scripts/upcp --force
    [20121204.153117] Detected cron=0 (Terminal detected)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /scripts/upcp at Tue Dec 4 15:31:17 2012
    [20121204.153117] Detected cron=0 (Terminal detected)
    => Log closed Tue Dec 4 15:31:17 2012
    [20121204.153117] Running Standardized hooks
    [20121204.153117] mtime on upcp is 1338882257 (Tue Jun 5 00:44:17 2012)
    [20121204.153117] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1354663877.log --force` failed, exited with code 65280
    => Log closed Tue Dec 4 15:31:17 2012

    --------------------------
    Internal Server Error

    500

    No response from subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/live_upcp2.cgi) with exit signal: 255

    cpsrvd/11.34.0.9 Server at 173.224.120.212

    - - - Updated - - -

    Also this arrived via email:

    Cpanel update failure in upcp

    Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1354663877.log --force` failed, exited with code 65280
     
  12. sahostking

    sahostking Member

    Joined:
    May 15, 2012
    Messages:
    238
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cape Town, South Africa
    Re: Internal Server Error 500 - No response from subprocess (/usr/local/cpa

    I have exact same problem aswell :(
     
  13. sahostking

    sahostking Member

    Joined:
    May 15, 2012
    Messages:
    238
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cape Town, South Africa
    Re: Can't login to cpanel: No response from subprocess with exit signal: 25

    I have exact same problem aswell :(
     
  14. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,453
    Likes Received:
    0
    Trophy Points:
    36
    Re: Internal Server Error 500 - No response from subprocess (/usr/local/cpa

    Try

    Code:
    /usr/local/cpanel/scripts/perlinstaller --force Storable
    /usr/local/cpanel/scripts/upcp
    
    If that doesn't solve it please open a ticket using the link in my signature. If you post the ticket # here, I will make sure to get it escalated for you.
     
  15. nospa

    nospa Member

    Joined:
    Apr 23, 2012
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    16
    Re: Can't login to cpanel: No response from subprocess with exit signal: 25

    Any resolution?
     
  16. syndicated

    syndicated New Member

    Joined:
    Jun 1, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Re: Error 500 when logging into cPanel

    Yeah mine too, I restarted it and SEEMS ok for now
     
  17. Thiago Enrique

    Thiago Enrique New Member

    Joined:
    Dec 10, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Internal Server Error 500 - No response from subprocess with exit signal: 0

    Internal Server Error

    500

    No response from subprocess ( (cpanel)) with exit signal: 0
    cpsrvd/11.34.0.11 Server at xxx.xx.xxx.xx

    =========================================================

    Internal Server Error

    500

    No response from subprocess (webmail (cpanel)) with exit signal: 0
    cpsrvd/11.34.0.11 Server at xxxxx.xxxxxxx.xxx


    Procedimentos já realizados porém sem sucesso:

    service cpanel restart

    /etc/init.d/cpanel restart

    /scripts/upcp -force
     
  18. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,453
    Likes Received:
    0
    Trophy Points:
    36
    A 500 error just means the cpanel or whostmgr binaries failed to execute for some undetermined reason.

    We have tracked down the problem that can be resolved by restarting cpsrvd. It will be fully propgated within 24 hours on all affected systems (no update needed).

    If you are still experiencing this problem its likely not related to the what has been posted to this thread. I am going to close it out to prevent anyone from going down the wrong path.

    If you get a 500 error, please post a new thread and include the last bits of the error_log or use the link in my signature to open a ticket.
     
Thread Status:
Not open for further replies.

Share This Page