1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

External mail server

Discussion in 'E-mail Discussions' started by labahost, Jun 27, 2007.

  1. labahost

    labahost Member

    Joined:
    May 4, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    On a CPanel server, I have one account where mx records are configured to route all the e-mails to external mail server. Everything works great, except when the e-mail is from another account on the same CPanel server, it doesn't reach external mail server, I think it goes to e-mail box on CPanel server.
    Is there a way to fix it? (How to send e-mails from the CPanel server to external mail server?)
     
    #1 labahost, Jun 27, 2007
    Last edited: Jun 27, 2007
  2. NiN

    NiN New Member

    Joined:
    Apr 30, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Braga, Portugal
    Remove the domains from your /etc/localdomains
     
  3. verdon

    verdon Member

    Joined:
    Nov 1, 2003
    Messages:
    793
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Northern Ontario, Canada
    ... and put it in your /etc/remotedomains
     
  4. labahost

    labahost Member

    Joined:
    May 4, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    thank you, it worked (but only after exim restart)
     
  5. host4all

    host4all New Member

    Joined:
    Apr 9, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    We have to do this from time to time and we always do it in the shell. Does someone know if there is a WHM option for this?
     
  6. MediaHound

    MediaHound New Member

    Joined:
    May 1, 2004
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Florida
    Bump for you host4all - same question here.
    Changing the mx record is something built in to and allowed by cPanel but it causes another problem that the cPanel or at least the WHM should be able to fix.
    I have some accounts littered with mail generated by the website on that domain on the server. With third party mail becoming more and more common, such as google apps for your domain, this should be a big priority for the WHM guys to fix / redesign.

    Plus it will prevent the bigger headache of lost emails!
     
  7. mtindor

    mtindor Active Member

    Joined:
    Sep 14, 2004
    Messages:
    1,182
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    inside a catfish
    It's already fixed. If you properly set your MX to a remote MX server now, you'll have the option to still allow the server to accept mail for the domain locally or NOT. Just select not to do so.

    If your mail for a domain is done by another MX remote from your server, make sure that the domain is NOT in /etc/localdomains and IS in /etc/remotedomains. Then, when your website on the server sends out mail to an email address within the domain, it will be sent to the remote MX.

    Mike
     
  8. mtindor

    mtindor Active Member

    Joined:
    Sep 14, 2004
    Messages:
    1,182
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    inside a catfish
    No, but in the customer's Cpanel it can be done - under 'MX Entry'. Just set the MX to a remote MX and do not checkmark the box that says Always accept mail locally even if the primary mx does not point to this server

    This will effectively remove the domain from /etc/localdomains and add it to /etc/remotedomains.

    Mike
     
  9. MediaHound

    MediaHound New Member

    Joined:
    May 1, 2004
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Florida
    Thanks mtindor, I was unaware this was resolved already.
    None of my servers' installations have that option.
    I've disabled auto updates and since I did that life on the surface is much better.
     
  10. Wonderm00n

    Wonderm00n New Member

    Joined:
    May 4, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    This really isn't working that well...

    Example...

    - The MX MUST be a FQDN and not an IP
    - My client does not have other domain, only "myclientdomain.com"
    - A new "mail1.myclientdomain.com" A record to a external IP was created
    - MX was setup to "mail1.myclientdomain.com"
    - The email still gets delivered on the local server, even if the FQDN on the MX points to an not local IP
     

Share This Page