1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with home page.

Discussion in 'General Discussion' started by Traver33, Mar 23, 2006.

  1. Traver33

    Traver33 New Member

    Joined:
    Mar 23, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I created a html file, I used ftp to upload it to the server. When I look at my index.html file it doesnt show any of my pictures. Also how do I get my html file to show up as my home page.
    Thanks

    Trav
     
  2. cpanelinfoseeker

    Joined:
    Oct 25, 2002
    Messages:
    323
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    NE Illinois
    Make sure you uploaded the index.html to your public_html folder. You must alsoupload all you pictures that are to be displayed to the correct directory (the directory you are coding in your index.html).
    If it is in the correct place and another page is showing look in the directory for another index.??? and delete the incorrect index page.

    Ron
     
  3. Traver33

    Traver33 New Member

    Joined:
    Mar 23, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply. I had to upload the index.html to my public_html like you said.:cool:

    Thanks
     
  4. omega00

    omega00 New Member

    Joined:
    Mar 21, 2006
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sunshine Coast, QLD, Australia
    wrong index

    I am currently running a 15 day test system of cpanel on FreeBSD 5.4,
    and for some reason cannot view any of the index's I put in the user area.

    i have a subdomain http://test.domain.com and can ftp files over, or add them in manually.
    but when I point to the site, I only get the default cpanel page.

    I have tried accessing the actuall user page http://test.domain.com/~user and if I do that, I am imediatley presented with the correct page. But other than that *scratches head*

    any ideas?

    I have also checked the area manually (through cpanel) and cannot find any other index files listed.. is there a config file I have to change??
     
  5. madaboutlinux

    madaboutlinux Active Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    You will have to check the apache configuration file ie. httpd.conf in /usr/local/apache/conf/. Check the DocumentRoot in VirtualHost entry for that domain.
     
  6. omega00

    omega00 New Member

    Joined:
    Mar 21, 2006
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sunshine Coast, QLD, Australia
    checked that, and its pointing to the right place '/home/username/public_html'
    ..
    any more ideas? both accounts that aren't working are subdomains
    for example: http://iamsubdomain.maindomain.com.au

    its fine if you point it at the actual username eg .com.au/~userneame
    and brings up the correct page, but just the same ol cpanel 'This page has not been configured yet'
     
  7. omega00

    omega00 New Member

    Joined:
    Mar 21, 2006
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sunshine Coast, QLD, Australia
    Index MIA

    Still nothing, can anybody shed some light on this for me?
     
  8. Murtaza_t

    Murtaza_t Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    A little tweak in your httpd.conf would solve it as I dont see any other reason for this to happen, but then it is very difficult to know what is the exact problem from here.

    I would suggest you to to get help from cPanel support or someone your trust on.
     
  9. omega00

    omega00 New Member

    Joined:
    Mar 21, 2006
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sunshine Coast, QLD, Australia
    Httpd.conf

    <Location /whm-server-status>
    SetHandler server-status
    Order deny,allow
    Deny from all
    Allow from 127.0.0.1
    </Location>
    ExtendedStatus On


    <VirtualHost xxx.xxx.xxx.xx>
    BytesLog domlogs/thebigserver.xx.xx.xxx-bytes_log
    ServerName thebigserver.xx.xx.xxx
    DocumentRoot /usr/local/apache/htdocs
    </VirtualHost>

    NameVirtualHost xx.xx.xx.xxx:80

    <VirtualHost xx.xx.xx.xxx>
    ServerAlias beer.blah.com
    ServerAdmin webmaster@beer.blah.com
    DocumentRoot /home/userbeer/public_html
    BytesLog domlogs/beer.blah.com-bytes_log
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/userbeer/:/usr/lib/php:/usr/local/lib/php:/tmp
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_value open_basedir "/home/userbeer/:/usr/lib/php:/usr/local/lib/php:/tmp
    </IfModule>
    ServerName beer.blah.com

    User userbeer
    Group userbeer
    CustomLog /usr/local/apache/domlogs/beer.blah.com combined
    ScriptAlias /cgi-bin/ /home/userbeer/public_html/cgi-bin/
    </VirtualHost>


    <VirtualHost xx.xx.xx.xxx>
    ServerAlias blah1.blah.com
    ServerAdmin webmaster@blah1.blah.com
    DocumentRoot /home/userblah/public_html
    BytesLog domlogs/blah1.blah.com-bytes_log
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/userblah/:/usr/lib/php:/usr/local/lib/php:/tmp
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_value open_basedir "/home/userblah/:/usr/lib/php:/usr/local/lib/php:/tmp
    </IfModule>
    ServerName blah1.blah.com

    User userblah
    Group userblah
    CustomLog /usr/local/apache/domlogs/blah1.blah.com combined
    ScriptAlias /cgi-bin/ /home/bjohns/public_html/cgi-bin/
    </VirtualHost>

    There are the settings for virtual hosts.. 2 users at the moment. Neither one showing anything other than cPanel index.
     
  10. Murtaza_t

    Murtaza_t Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Well if beer.blah.com and blah1.blah.com are your subdomains then the DocumentRoot is not correct, it should be :

    DocumentRoot /home/userbeer/public_html/beer
    DocumentRoot /home/userblah/public_html/blah1 repectively.
     

Share This Page