1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How can I disable ProFTP?

Discussion in 'General Discussion' started by trakwebster, Jun 26, 2003.

  1. trakwebster

    trakwebster Member

    Joined:
    Jan 29, 2003
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    I don't need proftp, so for security reasons I attempted to disable it, only to fail in several different ways. I have reported this as a bug to cpanel, but would also be grateful if anybody here knows the answer ...

    Although WHM has a 'Services Manager' in the 'Server' area, the checkbox for ProFTP is -- as far as I can tell -- broken. If you uncheck it, it will turn off proftp, which I can confirm with 'ps -aux | grep ftp'.

    However, if you reboot, proftp starts running again. And if you don't reboot, apparently every five minutes, cpanel monitors proftp, and if cpanel finds it not running, starts it up again!

    I tried a couple of alternatives, which also failed --

    NVSYSV program does not offer any access to turning off the ftp service.

    xinetd.conf and xinet.d directory have no references to ftp.

    I tried removing the proftpd file from /etc/rc.d/init.d folder. This does work, but generates a complaining message from cpanel every five minutes.

    So (1) cpanel folks please fix the broken proftpd checkbox in 'Service Manager'; and

    (2) If anyone here knows how I can disable proftpd (without generating 288 cpanel emails daily), please let me know. I would be grateful for any assistance.

    cPanel.net Support Ticket Number: 16734
     
  2. howard

    howard Member

    Joined:
    Apr 20, 2003
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    Have you tried deleting proftp from /etc/chkserv.d if its there ? (then restarting chkservd although not sure if this is strictly needed)

    cPanel.net Support Ticket Number:
     
  3. trakwebster

    trakwebster Member

    Joined:
    Jan 29, 2003
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    Wow!

    Wow!

    I've never seen such quick response. I got an email immediately from Darren at cpanel, who advised me to remove the proftpd file from /etc/chkservd.d/ and to restart the chkservd daemon.

    Restarting chkservd seems to have no documentation, but 'chkservd restart' produced no complaint, and it appears that proftpd is no longer running!

    Hopefully, that's it!

    Thanks, cpanel and Darren, for the amazingly quick response!

    cPanel.net Support Ticket Number:
     

Share This Page