1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to disable automatic "empty trash" function?

Discussion in 'General Discussion' started by mariokrupik, Sep 8, 2008.

  1. mariokrupik

    mariokrupik New Member

    Joined:
    Apr 25, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    it is really anoying as all my emails which are in trash, will get erased automatically after 7 Days.
    It`s very often that I had some Mails, where I thought I won`t need them anymore, throw them in Trash, and then find out that you would still need it.
    But it`s gone.

    Is there anyway I can change this?
    I even contacted the Administrator, but he didn`t know a solution.

    thanks,
    Mario
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    12,122
    Likes Received:
    33
    Trophy Points:
    48
    Location:
    Pennsylvania
    You don't mention what email app you're using. Either way, I think you're asking about a setting. Have you checked yours?
     
  3. mariokrupik

    mariokrupik New Member

    Joined:
    Apr 25, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    *push*

    Is there Nobody, who has the same Problem?
     
  4. mariokrupik

    mariokrupik New Member

    Joined:
    Apr 25, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi Infopro,

    It`s definetly not a Problem of an Email client Program, as I disabled all of my Email Programs and only used Webmail for a short period of time.
    But then it still happened that all mails in trash, which are older then 7 Days (of the Date when they got erased) are erased completely.

    So I contacted my Host, and he told me that this is a cpanel behavior, and he doesn`t have any influence on it.
    He told me that he send a ticket to cpanel, and they told him that there is no way to change this.

    Now I wanted to know if this is really a cpanel Problem, or if the Host maybe installed a Script which does this, to not run out of Space?

    Any help again is appreciated.

    Mario
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    12,122
    Likes Received:
    33
    Trophy Points:
    48
    Location:
    Pennsylvania
  6. mariokrupik

    mariokrupik New Member

    Joined:
    Apr 25, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    This is the Info I get in my WHM:

    cPanel 11.24.4-C33868 - WHM 11.24.2 - X 3.9
    CENTOS 5.2 x86_64 on standard

    ------

    So is this not a usual Cpanel behavior, right?
    So if you use IMAP and delete any Mails, they shouldn`t get automatically erased within 7 Days.

    I will sign up with a different cpanel host, and see if this is a cpanel behavior or not.

    Mario
     
  7. mariokrupik

    mariokrupik New Member

    Joined:
    Apr 25, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    So,

    to finally check if this is a cpanel behavior or not, I bought another webhosting Account at a total different hoster "resellerzoom.com", but Mails are disappearing the Same way after 7 Days in Trash.

    So is there any Cpanel Developer Active in these Forums, who may know if this can be changed by the Administrator of the Host or not?

    thanks,
    Mario
     
  8. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,318
    Likes Received:
    7
    Trophy Points:
    38
    This is possible by modifying the courier configuration. We don't expose the option for doing this in the Courier Configuration interface in WHM but your system admin can still do this by modifying the appropriate configuration file directly.
     
  9. grindlay

    grindlay New Member

    Joined:
    Dec 8, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Edinburgh, Scotland
    Aware that this is default behaviour for Courier but where is the configuration file to change it ?
    Answer:

    /usr/lib/courier-imap/etc/imapd

    line ~320

    IMAP_EMPTYTRASH=Trash:7

    Set this to your preferred value in days, or disable.
    This affects mail server-wide.
     
    #9 grindlay, Mar 26, 2009
    Last edited: Mar 26, 2009

Share This Page