1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

huge cpu usage by exim and mailnull, please help...

Discussion in 'E-mail Discussions' started by DWHS.net, Jul 24, 2003.

  1. DWHS.net

    DWHS.net Active Member

    Joined:
    Jul 28, 2002
    Messages:
    1,478
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    Hello,

    After the upgrade to cpanel 7 exim and mailnull are out of control.

    Sometimes reaching 50.00

    Here is the current process's running way to high.

    mailnull 29.22 1.06 0.0
    Top Process %CPU 19.0 /usr/sbin/exim -t -oem -oi -f <> -E19faJX-0005Ry-Vv
    Top Process %CPU 11.0 /usr/sbin/exim -t -oem -oi -f <> -E19faON-0005zA-09
    Top Process %CPU 1.6 /usr/sbin/exim -Mc 19faT4-0006Xb-UL
    root 14.77 3.10 1.8
    Top Process %CPU 14.0 /usr/sbin/exim -Mc 19faOM-0005z8-MF
    Top Process %CPU 9.0 /usr/sbin/exim -Mc 19faJX-0005Rs-Bx
    Top Process %CPU 6.5 /usr/sbin/exim -Mc 19faEh-0004wJ-RX

    I don't knoe much about exim so any help would be great..

    Also I have disabled exim in the service manager and the loads still continue.

    I just ran: /usr/local/cpanel/bin/convertmailman2

    And: /scripts/fixeverything

    I cleaned out the mail queue.

    While posting this I just got another exim error in another server:

    mailman 18.69 6.50 0.0
    Top Process %CPU 18.7 qrunner /usr/local/cpanel/3rdparty/mailman/bin/qrunner --runnerOutgoingRunner:0:1 -s

    Should I switch to release on these servers?


    Thanks,

    Charles

    cPanel.net Support Ticket Number:
     
  2. sexy_guy

    sexy_guy Member

    Joined:
    Mar 19, 2003
    Messages:
    857
    Likes Received:
    0
    Trophy Points:
    16
    50? I feel sorry for you. May that Taz guy can help you sort out your huge loads with a bit of his hair color. :D

    cPanel.net Support Ticket Number:
     
  3. DWHS.net

    DWHS.net Active Member

    Joined:
    Jul 28, 2002
    Messages:
    1,478
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    I pray so :(


    Man.... this is crazyness..

    cPanel.net Support Ticket Number:
     
  4. DWHS.net

    DWHS.net Active Member

    Joined:
    Jul 28, 2002
    Messages:
    1,478
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    It just hit 161.00 cpu???

    What's up the new mail? This bytes

    cPanel.net Support Ticket Number:
     
  5. DWHS.net

    DWHS.net Active Member

    Joined:
    Jul 28, 2002
    Messages:
    1,478
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    What is this and why is running huge loads on normal running servers?

    qrunner /usr/local/cpanel/3rdparty/mailman/bin/qrunner --runnerOutgoingRunner:0:1 -e

    Better yet how do I disable it?

    O.K. I stopped every service to calm the server down then enabled one by one and they seem to be o.k. for now.

    cPanel.net Support Ticket Number:
     
    #5 DWHS.net, Jul 24, 2003
    Last edited: Jul 24, 2003
  6. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,453
    Likes Received:
    0
    Trophy Points:
    36
    Mailman probably has the wrong hostname set in its config so it can't deliver its outgoing queue. If you put in a ticket we can check this out for you.

    cPanel.net Support Ticket Number:
     
  7. DWHS.net

    DWHS.net Active Member

    Joined:
    Jul 28, 2002
    Messages:
    1,478
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    O.K. thank,

    cPanel.net Support Ticket Number:
     
  8. jackal

    jackal Member

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    Having same problem what is the location name of config file please?

    cPanel.net Support Ticket Number:
     
  9. alterahosting1

    alterahosting1 New Member

    Joined:
    Jul 24, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Having the same problems as well. Any information would be appreciated.

    cPanel.net Support Ticket Number:
     
  10. butch

    butch Member

    Joined:
    Jun 23, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    these are the processes that i see:

    Where is the location of the config file?

    cPanel.net Support Ticket Number:
     
  11. vovikIII

    vovikIII New Member

    Joined:
    Sep 9, 2002
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Thank you, Nick

    /scripts/fixmailman

    cPanel.net Support Ticket Number: ---
     
  12. DWHS.net

    DWHS.net Active Member

    Joined:
    Jul 28, 2002
    Messages:
    1,478
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    Wow, that helped alot... Verry cool,

    I now only have this to work on this:

    Top Process %CPU 18.0 /usr/sbin/sendmail -FCronDaemon -i -odi -oem root
    Top Process %CPU 16.0 /usr/sbin/exim -v -Mrm 19f1YZ-0006uj-5r
    Top Process %CPU 15.0 /usr/sbin/exim -v -Mrm 19f21c-0007MT-9z

    Any thoughts ? sorry I am not good with exim...

    cPanel.net Support Ticket Number:
     
  13. rhood

    rhood Member

    Joined:
    Feb 15, 2003
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    We now have the same issue with several of our servers.

    Is there a fix yet?

    Example:
    23418 mailnull 9 0 2348 2348 1780 S 0.9 0.4 0:00 /usr/sbin/exim -bd -q1h
    23459 mailnull 9 0 2348 2348 1780 S 0.9 0.4 0:00 /usr/sbin/exim -bd -q1h
    23473 mailnull 9 0 2348 2348 1780 S 0.9 0.4 0:00 /usr/sbin/exim -bd -q1h
    23475 mailnull 9 0 2348 2348 1780 S 0.9 0.4 0:00 /usr/sbin/exim -bd -q1h
    23429 mailnull 9 0 2348 2348 1780 S 0.7 0.4 0:00 /usr/sbin/exim -bd -q1h
    23432 mailnull 9 0 2348 2348 1780 S 0.7 0.4 0:00 /usr/sbin/exim -bd -q1h
    23463 mailnull 9 0 2348 2348 1780 S 0.7 0.4 0:00 /usr/sbin/exim -bd -q1h
    23470 mailnull 9 0 2348 2348 1780 S 0.7 0.4 0:00 /usr/sbin/exim -bd -q1h
    23476 mailnull 9 0 2348 2348 1780 S 0.7 0.4 0:00 /usr/sbin/exim -bd -q1h
    23477 mailnull 9 0 2348 2348 1780 S 0.7 0.4 0:00 /usr/sbin/exim -bd -q1h
    23479 mailnull 9 0 2348 2348 1780 S 0.7 0.4 0:00 /usr/sbin/exim -bd -q1h
     
  14. DWHS.net

    DWHS.net Active Member

    Joined:
    Jul 28, 2002
    Messages:
    1,478
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    I checked my exim folders input and msglog and both had about 4-8000 emails in it, all the same.

    They said address not found,

    I think this is a problem with the new exim creating a endless loop some where.

    But I don't think anyone will know but cpanel how to fix it but they just suggest to clean out the input and msglog folders, but the problem still exists.

    cPanel.net Support Ticket Number:
     
  15. cheapo

    cheapo New Member

    Joined:
    Sep 6, 2002
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here

    The 2 servers that have that version of cpanel are having the same problem. Can i just roll back the last cpanel upgrade? If so, how?

    cPanel.net Support Ticket Number: 20177
     
  16. tAzMaNiAc

    tAzMaNiAc Member

    Joined:
    Feb 16, 2003
    Messages:
    567
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sachse, TX
    Did you open some of those mail queue files and see whats in them.. ?

    Also did you check logs for exim??

    exim_mainlog
    exim_rejectlog
    exim_paniclog

    in /var/log?

    Brenden

    cPanel.net Support Ticket Number:
     
  17. worldcops

    worldcops New Member

    Joined:
    Aug 29, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Re: Thank you, Nick

    The script to FIX Mailman worked, but what about th EXIM Failed Problem?

    Thank you.

    cPanel.net Support Ticket Number:
     
  18. dynaweb

    dynaweb Member

    Joined:
    May 14, 2003
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Oregon
    Same problem here

    Same problem here. I have WHM 8.5.4 and its been acting up for almost 4 days now. MANY mailnull processes.

    Server Status Alerts:
    Server Load 321.55 (1 cpu) and WHM takes about 5 mins to load a page! (if at all) Takes about 15 mins+ to su to root in SSH so it is EXTREMELY difficult to attempt to do anything as far as troubleshooting.

    I will try the /scripts/fixmailman in a few mins when I get a chance.....

    .... 20 mins later STILL trying to get to SU root! ....
    .... 30 mins later finally in su .. runnung script ...

    Openning WHM took over 2 minutes.

    Server Status Alerts:
    exim (exim-4.24-30_cpanel_stmpcontrol_antivirus_rewrite_mailman2) failed
    Server Load 54.63 (1 cpu)

    Hmmm. I guess I need to restart Exim.
    Exim restarted

    Server Status Alerts:
    exim (exim-4.24-30_cpanel_stmpcontrol_antivirus_rewrite_mailman2) failed
    Server Load 67.58 (1 cpu)

    Hmmm. Gracefull server reboot...
    Openning WHM took only 7 seconds!

    Server Status Alerts:
    Server Load 33.99 (1 cpu)


    Server Status Alerts:
    apache (1.3.28 (Unix)) failed
    bind (9.2.1) failed
    Server Load 10.43 (1 cpu)

    (Life sux)

    Show Current CPU Usage:
    (littered with mailnulls still)

    Ran Exim tidy scripts:
    /usr/sbin/exim_tidydb -t 1d /var/spool/exim retry
    /usr/sbin/exim_tidydb -t 1d /var/spool/exim reject
    /usr/sbin/exim_tidydb -t 1d /var/spool/exim wait-remote_smtp

    Killed all processes owned by mailnull

    Server Status Alerts:
    Server Load 6.08 (1 cpu)
    (no other alerts)


    Well.. Good enough for government work.. Im getting a drink :)
     
  19. rweiss

    rweiss Member

    Joined:
    Aug 31, 2002
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Same problem here. Seeing crazy system load due to Exim. Any fixes?

    Thanks,
    Russ
     
  20. cse

    cse New Member

    Joined:
    Apr 28, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Nothing yet???

    Seems a lot of us are having this problem, and need a mega fix.

    My server load is outta control..... and too many smtp processes, causing checking e-mail to no longer work.

    Help!!
     

Share This Page