1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I can't send mail to yahoo

Discussion in 'E-mail Discussions' started by filth80, Dec 17, 2009.

  1. filth80

    filth80 Member

    Joined:
    Dec 11, 2009
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    I have a big problem with sending mail to yahoo.I can receive from yahoo but cannot send.I receive no error, email appears on "sent' in squirrel, but yahoo never receive it.I tried with changing smtp port to 26 and 587, SPF is ok, firewall off....I don't have any problem with gmail,hotmail etc, mail sens and receives instantly.Please anyone who has an answer to help me!!Thank you very much.
     
  2. JawadArshad

    JawadArshad Member

    Joined:
    Apr 8, 2008
    Messages:
    444
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    PK
    Check exim logs for any possible errors.
     
  3. filth80

    filth80 Member

    Joined:
    Dec 11, 2009
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    This is the last part from the exim_mainlog.This appears when i try to send mail from office@mydomain.com. Sorry because i didn't replace domain name and users, but i thought someone can understand better like this.Waiting for help.Thank you.
     
    #3 filth80, Dec 17, 2009
    Last edited: Dec 17, 2009
  4. filth80

    filth80 Member

    Joined:
    Dec 11, 2009
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    This is what i get:

    Later edit: Now i get this:

    The ideea is that I receive this error reffering to the SERVER ip and I am sending mail from an account that has a different ip.I'm really stuck.....
     
    #5 filth80, Dec 17, 2009
    Last edited: Dec 17, 2009
  5. JawadArshad

    JawadArshad Member

    Joined:
    Apr 8, 2008
    Messages:
    444
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    PK
    This link explains why your emails are being rejected by yahoo and also has the best mail practice recommendations to avoid such errors.
     
  6. filth80

    filth80 Member

    Joined:
    Dec 11, 2009
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    This link doesn't help.I don't send spam mails.I don't even have clients yet.I plan to start my hosting and this is the last problem which is stopping me.I sent mails from my new created mail like office@mydomain.com to my account@yahoo.com only to see if it works.
     
  7. markb14391

    markb14391 Member

    Joined:
    Jun 9, 2008
    Messages:
    300
    Likes Received:
    0
    Trophy Points:
    16
    You're missing the point. That link tells what Yahoo is doing, why they're doing it, and (I believe) how to stop it. Even if this is a new server and you haven't sent out a single e-mail, whomever had that IP address before you might have been a spammer. To solve this, you (or your data center) will have to contact Yahoo in the manner that they recommend.

    Regarding the server IP issue, by default cPanel sends e-mail from any domain through the main IP of your server...unless you change that.

    BTW, in a case like this, the hung messages are probably in your mail queue (visible in WHM), in case you need to see which messages are affected. And, as others mentioned, the log is your friend.

    Although you might not think so, you already have all the information you need to fix this.
     
  8. filth80

    filth80 Member

    Joined:
    Dec 11, 2009
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    I completed the form for yahoo and sent to them.Reffering to log, I don't know how to handle the errors from logs.
     
  9. GoWilkes

    GoWilkes Member

    Joined:
    Sep 26, 2006
    Messages:
    341
    Likes Received:
    1
    Trophy Points:
    18
    Good luck. I have had the same dedicated server for several years, have never sent any bulk email or spam, but recently it appears that most of my emails are rejected by Yahoo, too (unless the recipient has me whitelisted).

    The only solution I've found so far is to set up a Gmail account (which you can use in your Outlook), then use that account to send emails to Yahoo recipients. It's not perfect because it shows "GoWilkes (sent on behalf of whatever", which looks very unprofessional, but it works.

    I've noticed that a lot of websites list that they no longer accept emails from Yahoo accounts because of this. If Yahoo doesn't get their act together, they're going to find themselves out of the email game.
     
  10. filth80

    filth80 Member

    Joined:
    Dec 11, 2009
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Let me understand: if my clients have domains on other ip than the primary one(the one of the server), when they send an email this goes to the internet thru the server ip address?This means that :
    1. I must set reverse DNS on the server ip too?
    2. If I set rDNS to the server ip, I must put rDNS for any other new ip in use for the clients to send mails?

    Thank you.
     
  11. markb14391

    markb14391 Member

    Joined:
    Jun 9, 2008
    Messages:
    300
    Likes Received:
    0
    Trophy Points:
    16
    1) Yes.
    2) Depends on whether you change the default setting and have e-mail sent out from the clients' IP address. In that case, yes, you should set up rDNS for each IP that mail will be going out from. However, depending on your needs, there is nothing wrong with having all e-mail go out from the server's main IP address.

    It's all really a lot easier than it sounds.
     
  12. filth80

    filth80 Member

    Joined:
    Dec 11, 2009
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Then all my above troubles should resolve, because until now I didn't have reverse DNS on my server's ip.I thought that the mail is sending from domain's ip by default and I told to the guy at the datacenter to rDNS my domain's ip.
     
    #13 filth80, Dec 18, 2009
    Last edited: Dec 18, 2009

Share This Page