1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Permission Denied in File Manager

Discussion in 'General Discussion' started by chelle40, Oct 9, 2012.

  1. chelle40

    chelle40 New Member

    Joined:
    Oct 9, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to save changes to a file in File Manager in the public_html\shop\css\ directory. I highlight the file and click edit, make my changes and click save and get permission denied. When I right-click on the file and click change permissions, it says user has write access. I don't understand why I am unable to edit this file.

    Thank you
     
  2. pwhjenny

    pwhjenny Member

    Joined:
    Aug 31, 2012
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Perhaps attribute is set to the file. You need to check with the host orelse if you have shell access you can use following command to remove attribute.

    chattr -i filename
     
  3. chelle40

    chelle40 New Member

    Joined:
    Oct 9, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Am I going about updating files correctly? From cpanel, I click on "Files" under File Manager and then I choose web root (public_html). Once File Manager window opens, I find the file I want to edit, click on it and click "Edit" at the top, I leave the character encoding option with "utf-8" and then when my file opens, I make my changes and then click "Save Changes". Does it matter if you click "Use Code Editor" or just plain "Edit"?

    I also tried another avenue - From File manager, I downloaded the file I wanted to edit, made the changes, and then uploaded it back. First, I tried using the same name and checked the overwrite box. It said it completed but then when I closed the window and was back to the list of files in that directory, the file was unchanged. I then tried uploading the file with a slightly different name, it said it completed but when I went back to the list of files it was not there. Am I doing something wrong or does it have to do with the attributes?

    I don't have shell access so I will have to ask my host.

    Thanks
     
  4. cPanelTristan

    cPanelTristan Active Member
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,621
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    You are doing everything the right way. The only thing that makes sense is either:

    1) The file is set to immutable (chattr +i) and needs to be changed as previously suggested to make it mutable again (chattr -i)
    2) The file is owned by root or a user other than yourself
    3) The file's permissions are 000 or lower than you have write access to change

    You'll need to ask your host to check the file to see why this is happening.
     

Share This Page