1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with Roundcube (sending) SMTP error: Authentication failure: STARTTLS failed

Discussion in 'E-mail Discussions' started by sirbrent, Jan 30, 2009.

  1. sirbrent

    sirbrent Member

    Joined:
    Sep 30, 2008
    Messages:
    98
    Likes Received:
    1
    Trophy Points:
    8
    hello,

    roubecube is the only webmail app enabled for my clients.
    it was working like a dream (with the default configuration created by cpanel team), but today when i upgraded to the most recent CURRENT tree, and roundcube was updated to .2-stable, users are no longer able to send email. after composing their emails and clicking send they are faced with the "sending..." notification for about 2 min, and nothing happens.

    The Roundcube error log shows this every time a user tries to send an email:

    Code:
    [30-Jan-2009 14:07:11] Invalid response code received from server (421): 
    [30-Jan-2009 14:07:11] Invalid response code received from server (-1): 
    [30-Jan-2009 14:07:34 -0800] SMTP Error: SMTP error: Authentication failure: STARTTLS failed (Code: ) in /usr/local/cpanel/base/3rdparty/roundcube/program/steps/mail/func.inc on line 1248 (POST /3rdparty/roundcube/index.php?_task=mail&_action=send)
    [30-Jan-2009 14:10:29] STARTTLS failed (): 
    
    I am hoping someone can help before i trouble the support team with a ticket.
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,452
    Likes Received:
    0
    Trophy Points:
    36
    It is a bug in PHP's latest Net-SMTP module.

    We will be patching it an sending out a new CURRENT very soon. The internal case number is #20266
     
  3. sirbrent

    sirbrent Member

    Joined:
    Sep 30, 2008
    Messages:
    98
    Likes Received:
    1
    Trophy Points:
    8
    A quick update. I was playing around with the roundcube configuration (usr/local/cpanel/base/3rdparty/roundcube/config/main.inc.php) and noticed a workaround until the module is patched/updated. This workaround normally shouldnt work, but seems to work with the current problem in the module.

    normally there is a series of lines which should read like this:

    Code:
    // SMTP username (if required) if you use %u as the username RoundCube
    // will use the current username for login
    $rcmail_config['smtp_user'] = '%u';
    for now Roundcube seems to work properly if you change it to this:

    Code:
    // SMTP username (if required) if you use %u as the username RoundCube
    // will use the current username for login
    $rcmail_config['smtp_user'] = '';
    
     
  4. Tina

    Tina Member

    Joined:
    Jan 27, 2003
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Just wanted to say

    Me too!

    Clients are upset. Please let us know when we should do an update.

    Thanks!
     
  5. Tina

    Tina Member

    Joined:
    Jan 27, 2003
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Hi Brent,

    I tried your fix and the mail sends successfully -- shows completed in exim_mainlog and is copied to sent mail folder -- but roundcube responds, unknown server error.

    This fix doesn't expose any vulnerabilities in the application or the server?

    Thanks for posting.

    Tina
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    12,118
    Likes Received:
    31
    Trophy Points:
    48
    Location:
    Pennsylvania
    In C33795 this is still an issue. Horde works fine.
     
  7. Serra

    Serra Member

    Joined:
    Oct 27, 2005
    Messages:
    190
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Florida
    Changing '%u' to '' seems to have worked on my system as a temporary fix for C33795. I'm not seeing any error messages.


    Edit: Something else appears to be involved. C33795 works on one server and not another.
     
    #7 Serra, Jan 31, 2009
    Last edited: Jan 31, 2009
  8. Chew

    Chew Member

    Joined:
    Dec 31, 2003
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Maryland
    Is there any update on this issue? Or should I try the workaround?
     
  9. shenzy

    shenzy Member

    Joined:
    Apr 27, 2008
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Thanks sirbrent, your solution work fine for me.
     
  10. FearlessG1

    FearlessG1 Member

    Joined:
    May 5, 2006
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    i to am having this problem, any update on the status of the fix. I tried the above fix but it did not work for me.
     
  11. davidferguson

    davidferguson New Member

    Joined:
    Nov 1, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    London, UK
    Any update on fixing this issue?
     
  12. rgpayne

    rgpayne New Member

    Joined:
    Feb 25, 2003
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Texas
  13. wmiles

    wmiles New Member

    Joined:
    Sep 6, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
  14. FearlessG1

    FearlessG1 Member

    Joined:
    May 5, 2006
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    hmm, i followed that post and changed from the 0, to 1 (allow) but after restarting csf, I am still having the same problem.
     
  15. wmiles

    wmiles New Member

    Joined:
    Sep 6, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Worked for me, although i did log out of webmail and clear my temps
     
  16. ocoth.au

    ocoth.au New Member

    Joined:
    Jan 30, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Newcastle, New South Wales, Australia
    Problem occurred on our server too. sirbrent's fix worked immediately without any need to log in/out or touch anything else (I was logged in, with an email ready to go, then made the change, then went back to the session and sent the email and it worked!).

    Looking forward to a permanent fix.

    Many thanks,

    Tom
     
  17. Sinewy

    Sinewy Member

    Joined:
    May 15, 2004
    Messages:
    370
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney, Australia
    Still not properly fixed in CURRENT. Anyone else still having the issue?
     
  18. FearlessG1

    FearlessG1 Member

    Joined:
    May 5, 2006
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    I am still having this problem.......
     
  19. WebJIVE

    WebJIVE Member

    Joined:
    Sep 30, 2007
    Messages:
    53
    Likes Received:
    1
    Trophy Points:
    8
    worked like a charm.. thx..
     
  20. SuperBaby

    SuperBaby Member

    Joined:
    Nov 27, 2003
    Messages:
    309
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Malaysia
    If you are using CSF, remember to check the SMTP_BLOCK and SMTP_ALLOWLOCAL settings under config. This will enable/disable local webmail sending. If SMTP_BLOCK is set to "1", you should set SMTP_ALLOWLOCAL to "1" too.
     
    #20 SuperBaby, Feb 22, 2009
    Last edited: Feb 22, 2009

Share This Page