Results 1 to 8 of 8

Thread: Apache Failed ! mod_ssl Cannot open SSLSessionCache DBM file logs/ssl_scache

  1. #1
    Registered Member vishal's Avatar
    Join Date
    Jan 2003
    Location
    India
    Posts
    343

    Question Apache Failed ! mod_ssl Cannot open SSLSessionCache DBM file logs/ssl_scache

    Hello,

    WHM 6.2.0
    Cpanel 6.4.0-S16
    RedHat 7.3
    Apache Core 1.3.27
    mod_log_bytes 1.2
    mod_bwlimited 1.0
    PHP 4.3.1
    FrontPage 5.0.2.2510
    mod_ssl 2.8.12
    OpenSSL 0.9.6b

    Apache Failed last night due to

    [Tue May 6 01:19:21 2003] [notice] Apache/1.3.27 (Unix) mod_log_bytes/1.2 mod_bwlimited/1.0 PHP/4.3.1 FrontPa
    ge/5.0.2.2510 mod_ssl/2.8.12 OpenSSL/0.9.6b configured -- resuming normal operations
    [Tue May 6 01:19:21 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Tue May 6 01:19:21 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Tue May 6 01:19:22 2003] [crit] (98)Address already in use: make_sock: could not bind to port 443
    [Tue May 6 01:20:01 2003] [error] mod_ssl: Cannot open SSLSessionCache DBM file `/usr/local/apache/logs/ssl_s
    cache' for status retrival (System error follows)
    [Tue May 6 01:20:01 2003] [error] System: No such file or directory (errno: 2)
    [Tue May 6 01:25:00 2003] [error] mod_ssl: Cannot open SSLSessionCache DBM file `/usr/local/apache/logs/ssl_s
    cache' for status retrival (System error follows)
    [Tue May 6 01:25:00 2003] [error] System: No such file or directory (errno: 2)
    [Tue May 6 01:29:19 2003] [notice] SIGUSR1 received. Doing graceful restart

    I googled and searched from the modssl.org site. It says that Cannot open SSLSessionCache DBM file `/usr/local/apache/logs/ssl_scache

    That's true bcoz the file itself does not exists on the server.
    Now after a Reboot Apache is fine Now!

    My question is why did this happen ? Apache was running fine from 20+ days and then it failed!

    Why apache needed the file Yesterday Only?
    I checked /usr/local/apache/logs

    -rw------- 1 nobody root 0 May 6 06:35 ssl_scache.dir
    -rw------- 1 nobody root 0 May 6 06:35 ssl_scache.pag

    Right now i have these two files.

    Anyways!
    Do i need to create this file and what should i chmod and chown to ?

    Regards,
    rh_linuxion

    It is very simple to be Happy but it is very difficult to be Simple.

  2. #2
    Registered Member casey's Avatar
    Join Date
    Jan 2003
    Location
    If there is trouble, it will find me
    Posts
    2,333

    Default

    Dude, I had the exact same problem two nights ago. I have a cron job to start apache every 10 minutes, and strangely enough restarting apache got rid of the error. It hasn't shown up since, but I would like to know what happened, since the server was down for 8 minutes.

  3. #3
    Registered Member vishal's Avatar
    Join Date
    Jan 2003
    Location
    India
    Posts
    343

    Default

    Originally posted by casey
    Dude, I had the exact same problem two nights ago. I have a cron job to start apache every 10 minutes
    Yes a Restart solved this prob. Can u post the cron here.

    Regards,
    rh_linuxion

    It is very simple to be Happy but it is very difficult to be Simple.

  4. #4
    Registered Member casey's Avatar
    Join Date
    Jan 2003
    Location
    If there is trouble, it will find me
    Posts
    2,333

    Default

    This is compliments of hostcp3:



    lynx -cookies -dump -auth=root:your_root_password_here http://your_main_server_ip_here:2086/scripts/reshttpd


    all the above on one line in your Control panel cron manager.

    Minute Hour Day Month Weekday

    */10 * * * *

  5. #5
    Registered Member vishal's Avatar
    Join Date
    Jan 2003
    Location
    India
    Posts
    343

    Default

    Originally posted by casey
    This is compliments of hostcp3:



    lynx -cookies -dump -auth=root:your_root_password_here http://your_main_server_ip_here:2086/scripts/reshttpd


    all the above on one line in your Control panel cron manager.

    Minute Hour Day Month Weekday

    */10 * * * *
    Thanks!!
    rh_linuxion

    It is very simple to be Happy but it is very difficult to be Simple.

  6. #6
    Registered Member cPanel Partner NOC Badge
    Join Date
    Apr 2002
    Posts
    686
    cPanel/WHM Access Level

    DataCenter Provider

    Default

    I know this is an old thread but i cant find much in relation to this issue.

    I am having the same errors in the apache log and my apache keeps restarting and no sites seem to load.

    ive tried 3 easyapache updates and whats been suggested but still no luck

    any other suggestions???

  7. #7
    Registered Member
    Join Date
    Jul 2003
    Posts
    55

    Default

    Quote Originally Posted by Snowman30
    I know this is an old thread but i cant find much in relation to this issue.

    I am having the same errors in the apache log and my apache keeps restarting and no sites seem to load.

    ive tried 3 easyapache updates and whats been suggested but still no luck

    any other suggestions???
    Instead of putting your root password on the drive in plan text, why not just add:

    service httpd restart
    to a crontab instead?

  8. #8
    Registered Member rpmws's Avatar
    Join Date
    Aug 2001
    Location
    back woods of NC, USA
    Posts
    1,854

    Default

    Quote Originally Posted by jdstallings
    Instead of putting your root password on the drive in plan text, why not just add:



    to a crontab instead?
    or

    /scripts/restartsrv_httpd

    also if cpservd is down ..this method will work. it doesn't rely on doing things through a lynx web browser and cpservd server and it doesn't require a login like that.
    Last edited by rpmws; 09-03-2006 at 10:38 AM.
    Just keeping my "eye" on things....
    R. Paul Mathews
    RPMWS - diehard cPanel Nutcase

Similar Threads

  1. Replies: 5
    Last Post: 11-17-2010, 06:15 PM
  2. tweakcphulk Failed to open sshd configuration file for reading
    By jacampbe in forum New User Questions
    Replies: 0
    Last Post: 08-09-2010, 03:17 AM
  3. mm_create - failed to open semaphore file
    By handsonhosting in forum cPanel & WHM Discussions
    Replies: 4
    Last Post: 07-17-2009, 07:19 AM
  4. open of auto-whitelist file failed
    By lisatutt in forum E-mail Discussions
    Replies: 0
    Last Post: 08-23-2008, 03:17 PM
  5. ] mod_ssl: Child could not open SSLMutex lockfile
    By ozzi4648 in forum cPanel & WHM Discussions
    Replies: 3
    Last Post: 03-22-2003, 07:45 AM
bargain