perl

  1. U

    Downgrade perl 5.8.1 to 5.6.1

    On a new server I have perl 5.8.1 installed. How can I downgrade to perl 5.6.1? I've searched all over (here, RS, google) and found no specific instructions...Thanks. cPanel.net Support Ticket Number: 28825
  2. M

    Perl 5.8.1 Installed modules reveal they are still Updated: perl v5.6.1

    After we upgrade to Perl 5.8.1 users who click on INSTALLED PERL MODULES still see Updated: perl v5.6.1 in the help docs when they click on the module for more information!!!!!!!!!!!
  3. D

    MIME Perl

    I would like to know where is the perl script for the Mime module. Where I can find the Perl scripts for Hotlink operations. I'm building my own theme, but cpanel is not documented yet. Can someone help me ?
  4. J

    CHMOD FTP Perl

    I have been having a few problems with write access when using cgi/php when I FTP up I am writing to the system as the cpanel user (station), however the web server accesses the server as user 'nobody'. The user 'Nobody' does not have rights to write to 'station's directories or files. I...
  5. X

    Perl F'd up after last stable update

    Seems one of my clients had no issues with this script: http://www.movabletype.org But they sent me an e-mail today saying they are getting the following errors now when trying to log in to their admin panel. Now I posted this over at their forums located here...
  6. M

    WHM mod perl, imagemagick, etc.

    I have a question or two, First I installed JDk on my server and did the steps to enable it for my sites, but it doesnt work. Then I also installed mod perl in WHM and it doesnt work and isnt listed in the httpd.conf file, but shows in WHM as being installed. Then I also installed...
  7. A

    New Box - Mod Perl not installing

    I get a bunch of this on the compile. I am using easyapache - redhat 9 and selected php / mcrypt / mod_perl / and gd - this is a brand new box. Help :) I need to install a mod_perl script so I can use a handler rc/modules/perl/Server.c:147: undefined reference to `Perl_Gthr_key_ptr'...
  8. S

    Important: How To "restart" Perl

    Hi, perl-scripts are not compiled on my server anymore... a few hours before I had a serverload of 7,1 and from then I get the following errors: Can't locate object method "new" via package "MD5" (perhaps you forgot to load "MD5"?) at /usr/lib/perl5/5.6.1/CPAN.pm line 4212. (Installing...
  9. J

    Addon scripts and MAJOR perl problems

    Last night after doing cpanel does its update none of the addon scripts install right, and there are many perl errors all over the place, here's the output of what happens when you try to install a new PHP-Nuke installation for example: PHP-Nuke Setup ERROR at line 1: Unknown command '\_'...
  10. M

    Problems With Perl

    We updated our servers yesterday to OpenSSL 0.9.7c with no problems reported until today. Our two rackshack servers we have 17 in total have started playing up and have lost perl functionally /scripts/md5crypt Can't locate Digest/MD5.pm in @INC (@INC contains: /usr/lib/perl5/5.6.1/i386-lin...
  11. A

    Perl 5.8 problem

    Hi , I upgraded my perl 5.6 to Perl 5.8 and now a LOT of my scripts are breaking, how do i go back to perl 5.6 ? Would apprecaite a really quick answer here ! Lots of people going mad :) Thanks ! cPanel.net Support Ticket Number:
  12. P

    Should this be disabled perl threading enabled?

    When I upgraded cpanel from an old 6.x version to a newer version I noticed this comment: You are using a perl configured with threading enabled. *** You should be aware that using multiple threads is *** not recommended for production environments. Is it recommended to disable this and...
  13. N

    up2date perl?

    when running up2date he is getting perl 5.6.1 and other perl things perl-5.6.1-36.1.73.i386.rpm perl-CGI-2.752-36.1.73.i386 perl-CPAN-1.59_54-36.1.73.i perl-DB_File-1.75-36.1.73.i perl-NDBM_File-1.75-36.1.73 may i install it? cPanel.net Support...
  14. S

    up2date updates Perl and messes up Spamassasin

    Hi I ran up2date today, and it updates Perl. Following that, the error pops up: Shutting down exim: [ OK ] Shutting down antirelayd: [ OK ] Shutting down spamd: [FAILED]...
  15. F

    edit accounts using perl Accounting module

    Hi, I'm currently busy implementing the perl Cpanel::Accounting module, because i'm a reseller and i want my clients to create packages too (So i'm a reseller and i can have resellers :D) One problem, i want to have my resellers to be able to edit accounts they created, but the perl module...
  16. T

    perl module

    perl module Cpanel::Accounting is not available in "install perl module" list to install. How can it be installed? cPanel.net Support Ticket Number:
  17. E

    perl scripts wont run

    Hi, I just created a new domain and uploaded a basic perl script to the cgi-bin. When I ran the script the server came up with 500 internal server error. (yes I did upload the script in ascii and chmod to 755 - its just a basic script and theres nothing wrong with it). I uploaded...
  18. B

    logs and perl for user under jailshell

    can someone tell me where the apache access and error logs are located for a jailshelled user? Also, does cpanel allow users to add perl modules? You probably woudn't want the to add modules for the entire server, but it would be nice if cpanel allowed users to install a perl module for...
  19. B

    cpanel reports wrong perl version

    My users are seeing in there cpanel control (under Info > Versions& Paths) that the current version of perl is 5.008. I know the actual version is 5.8 as I wrote a script that runs the command `perl -v` and outputs it to the browser. Is there a fix? Also the "info" link next to the...
  20. E

    Installed Perl Modules No listed in cPanel

    How do I install a perl module that cPanel can't find or that it lists. Please help I have several I need to install. And consider me an idiot when you give instructions - please. cPanel.net Support Ticket Number: