perl

  1. sahostking

    Perl Thread support

    Hi, How do I install Perl threaded support on Cpanel? Very nervous on following other articles I'm finding on the net. I want to know if there is a recommended way of doing this within cpanel itself,etc. Thanks
  2. A

    Perl not updating (11.32.2.15) [checkperlmodules] IO::Interactive::Tiny

    [Fixed] Perl not updating (11.32.2) [checkperlmodules] IO:Interactive:Tiny This has been fixed, view the post here For the past few days I've been getting this e-mail: Subject: Subject: [checkperlmodules] The perl module IO::Interactive::Tiny could not be installed. This module is...
  3. J

    Perl problems - Cpanel not working

    CentOS 6.2, installed 64-bit. I was having a problem getting Logwatch working on the server as perl could not recognize that a dependency was installed. Additionally I was having problems getting GD to install correctly using Cpanel's easyapache. Threads at Cpanel.net suggested a possible fix...
  4. V

    Massive Perl issues from previous maintainer

    I'm not sure who set up the server that I've been tasked with refreshing, but the Perl modules are all messed up. I've spent several hours reading up on fixes for Perl problems with relation to cPanel and though I've tried everything I can find, I haven't come across anything that fixes this...
  5. L

    perl problems module DateTime could not be installed

    With reference to this thread about this error : http://forums.cpanel.net/f5/perl-problems-module-datetime-could-not-installed-142689.html I tried to run /scripts/perlinstaller --force DateTime and # /scripts/perlinstaller --force List::MoreUtils only find out that the servers time...
  6. nitaish

    perl modules in shared hosting server

    One of my customers having shared hosting account with us in Cpanel server wants the following perl modules to be installed. Date-Calc-5.4 File-Tail-0.99.3 lzo-1.08 Number-Format-1.52 chartdir_perl_linux MIME::Lite MIME::Base64 Authen::ASL LWP::UserAgent DBI-1.607 CGI.pm-3.42...
  7. S

    [checkperlmodules]‎ The perl module GD::Graph could not be installed.

    This module is required by cPanel, and the system may not function correctly until it is installed, and functional. Below is the results of the auto-install attempt: Test Run ============== Can't load '/usr/local/lib/perl5/site_perl/5.8.8/i686-linux/auto/GD/GD.so' for module GD...
  8. M

    problem with perl module

    Hello I want to install nagios plugins on my cpanel, following a guide i have installed net::snmp perl module, but when i try to install i keep getting an error that the net::snmp is not installed, but its installed! Tried to update the module but i get the same problem. Any ideas of...
  9. F

    Perl Modules

    I need the following modules to either mytop, mtop, or innotop. perl(DBD::mysql) perl(Term::ReadKey) perl(DBI) When I run yum search, I find the following, but I don't see anything that stands out as being the one that I really need. Of course ReadKey doesn't even show up. Thanks! Frank...
  10. bspiller

    [checkperlmodules] The perl module NetAddr::IP could not be installed

    Today I received the following email. We never received this email before so not sure what the deal is. Help would be appreciated. This module is required by cPanel, and the system may not function correctly until it is installed, and functional. Below is the results of the auto-install...
  11. PPNSteve

    HELP! Quick question re: perl modules

    Where are the installed perl modules located in the file system? I have a need to patch one of them..
  12. T

    Core Dump Files saying error in Perl

    I've read a number of posts about core.#### files being generated and ways to turn them off. I'm hopeing someone can help me figure out why the files are being created in the first place. Using gdb, I was able to read the following error: Core was generated by `perl -McPanelUserConfig...
  13. S

    checkperlmodules The perl module Net::LDAP could not be installed

    I've receive several emails with the subject as below [checkperlmodules] The perl module Net::LDAP could not be installed Email content May i know how can i fix this? Thanks.
  14. M

    [checkperlmodules] The perl module Mysql could not be installed.

    hi, i'm new here. sorry if my question too noob. for some issues, i'm upgrading my perl 5.8.8 to perl 5.14. i can manually install all related perl module without problem. but i'm keep on getting notification Mysql.pm fail to install by checkperlmodules ([checkperlmodules] The perl...
  15. T

    Perl Dependency in yum

    We wanted to update our memcached via yum and ran into a Perl Dependency issue. We know you set to exclude perl in yum for a good reason but is there a way to update perl using cpanel so we could update our memcached? The perls memcached need updated are perl-AnyEvent...
  16. natong

    Help! all perl scripts on the server began error Premature end of script headers

    All perl scripts on the server began erroring with /usr/local/apache/logs/error_log containing Premature end of script headers. WHM 11.30.1 (build 4) I didn't touch anything.
  17. S

    Re: Prevent perl script read /etc/named.conf

    how to protect /etc/named.conf so PHP script can't read it?
  18. A

    Problem installing perl modules

    Hi all, I'm having problems installing any perl module via cpanel. It always outputting this error Testing connection speed...(using fast method)...Done Ping:4 (ticks) Testing connection speed to mirrors.servercentral.net using pureperl...(14025.00 bytes/s)...Done Ping:4 (ticks) Testing...
  19. B

    remove perl

    hello i want remove perl script on my server via SSH perl make security problem however i disable perl but hackers add Options FollowSymLinks MultiViews Indexes ExecCGI AddType application/x-httpd-cgi .izri AddHandler cgi-script .pl AddHandler cgi-script .pl to httaccess perl work...
  20. M

    [checkperlmodules] The perl module IO::Compress::Gzip could not be installed

    This module is required by cPanel, and the system may not function correctly until it is installed, and functional. Below is the results of the auto-install attempt: Test Run ============== Compress::Raw::Zlib version 2.037 required--this is only version 2.035 at...