11.25.0-current Updates (Any Issues)

D-Litz

Active Member
Feb 4, 2009
35
0
56
cPanel Access Level
Root Administrator
Looking at updating at least five servers to 11.25.0-current.

We have a mix of RedHat 5 32bit / Centos 5 32/64bit servers...

running Fantastico, RVSkins, logview, a few of Chirpys scripts...

All are current running cPanel 11.24.5-C39633 - WHM 11.24.2 - X 3.9

Would like to see if anybody has had any issues with the update?
 

bvierra

Well-Known Member
Jul 28, 2006
55
1
158
Southern California
using it on my test server here, no issues I have seen that have not been addressed already.
 

Infopro

Well-Known Member
May 20, 2003
17,112
513
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
Looking at updating at least five servers to 11.25.0-current.

We have a mix of RedHat 5 32bit / Centos 5 32/64bit servers...

running Fantastico, RVSkins, logview, a few of Chirpys scripts...

All are current running cPanel 11.24.5-C39633 - WHM 11.24.2 - X 3.9

Would like to see if anybody has had any issues with the update?
Fantastico, *.chirpy, work. logview does not work at all in IE8, somewhat in FF. Fonts in WHM are all too large here in IE8. Turning on security tokens adds to your work in WHM in some areas asking for password a second time to get to a page.

I also noticed last night using File Manager on a users account that there doesn't seem to be a scrollbar while moving thru directories. I was able to get done with what I needed to do using the arrow keys, and didn't get back yet to check other browsers for this issue.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
458
cPanel Access Level
Root Administrator
Fantastico, *.chirpy, work. logview does not work at all in IE8, somewhat in FF. Fonts in WHM are all too large here in IE8. Turning on security tokens adds to your work in WHM in some areas asking for password a second time to get to a page.

I also noticed last night using File Manager on a users account that there doesn't seem to be a scrollbar while moving thru directories. I was able to get done with what I needed to do using the arrow keys, and didn't get back yet to check other browsers for this issue.
The Font issue should be fixed in 11.25.0-CURRENT_4025. If it's not, Infopro would you send me a screen shot, please?

Security tokens improve the security of the product. They will cause problems with third party applications that are not updated to work with Security tokens enabled.
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
208
cPanel Access Level
DataCenter Provider
Fantastico, *.chirpy, work. logview does not work at all in IE8, somewhat in FF. Fonts in WHM are all too large here in IE8. Turning on security tokens adds to your work in WHM in some areas asking for password a second time to get to a page.

I also noticed last night using File Manager on a users account that there doesn't seem to be a scrollbar while moving thru directories. I was able to get done with what I needed to do using the arrow keys, and didn't get back yet to check other browsers for this issue.
Could you post a screenshot of the file manager or open a ticket with the screenshot if there are sensitive file names?

Thanks
 

Infopro

Well-Known Member
May 20, 2003
17,112
513
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
The Font issue should be fixed in 11.25.0-CURRENT_4025. If it's not, Infopro would you send me a screen shot, please?

Security tokens improve the security of the product. They will cause problems with third party applications that are not updated to work with Security tokens enabled.
On the main WHM page with all the nice new icons (40255) those fonts below the icons are good, across the top (Home News Changelog etc) they're big, and the left menu they're big. In IE8, fonts set to Medium in browser. If I set fonts to smaller, top and left side come more in line with the main page of icons fonts.

My accounts, root and a reseller (In IE8 only) are stuck on the Tweak Settings page for some reason still. On login I am asked for password again due to the security tokens not being set yet in browser.

Requested page: /scripts2/tweaksettings
Error message: security token missing

All issues in IE8, for me, fonts, tokens, and login to Tweak Settings page are non issues it seems in firefox.

Could you post a screenshot of the file manager or open a ticket with the screenshot if there are sensitive file names?

Thanks
Not sure what/if something changed but I read a post by you here last evening about the Apache restarts being handled a bit better so I upgraded right after reading that. Looking at the File Manager now there is a scroll bar, all is well there with that. I'm not sure if that problem yesterday was on my end or not, but it works now, IE8 and FF.
 

msasek

Member
Nov 28, 2001
18
0
301
Problem with webmail clients

When using cpanel with a remote database server, webmail fails after upgrading to 11.25.0-C40255 with the following error:

A fatal error has occurred
DB Error: connect failed
Details have been logged for the administrator.
Any ideas on how to fix?
 

D-Litz

Active Member
Feb 4, 2009
35
0
56
cPanel Access Level
Root Administrator
I did run into some of the same issues. After upgrading one server I received this error via email.

Subject: [checkperlmodules] The perl module Encode::Detect::Detector could not be installed.


Code:
This module is required by cPanel, and the system may not function correctly until it is installed, and functional.  Below is the results of the auto-install attempt:

Test Run
==============
Can't locate Encode/Detect/Detector.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.7/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.6/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.7/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.6/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at - line 1.
BEGIN failed--compilation aborted at - line 1.


Installer Run
==============
commit: wrote /usr/lib/perl5/5.8.8/CPAN/Config.pm
CPAN: Storable loaded ok
Going to read /home/.cpan/Metadata
  Database was generated on Tue, 13 Oct 2009 23:27:03 GMT
Running install for module Encode::Detect::Detector
Running make for J/JG/JGMYERS/Encode-Detect-1.01.tar.gz
CPAN: Digest::MD5 loaded ok
CPAN: Compress::Zlib loaded ok
Checksum for /home/.cpan/sources/authors/id/J/JG/JGMYERS/Encode-Detect-1.01.tar.gz ok
Scanning cache /home/.cpan/build for sizes
Encode-Detect-1.01/
Encode-Detect-1.01/t/
Encode-Detect-1.01/t/base.t
Encode-Detect-1.01/t/encoding.t
Encode-Detect-1.01/MANIFEST
Encode-Detect-1.01/Detector.pm
Encode-Detect-1.01/Changes
Encode-Detect-1.01/Makefile.PL
Encode-Detect-1.01/src/
Encode-Detect-1.01/src/nsBig5Prober.h
Encode-Detect-1.01/src/nsUniversalDetector.h
Encode-Detect-1.01/src/GB2312Freq.tab
Encode-Detect-1.01/src/CharDistribution.h
Encode-Detect-1.01/src/JpCntx.h
Encode-Detect-1.01/src/LangBulgarianModel.cpp
Encode-Detect-1.01/src/LangGreekModel.cpp
Encode-Detect-1.01/src/nsCharSetProber.cpp
Encode-Detect-1.01/src/EUCTWFreq.tab
Encode-Detect-1.01/src/nsGB2312Prober.cpp
Encode-Detect-1.01/src/nsPkgInt.h
Encode-Detect-1.01/src/JISFreq.tab
Encode-Detect-1.01/src/nsEUCJPProber.h
Encode-Detect-1.01/src/EUCKRFreq.tab
Encode-Detect-1.01/src/nsEUCJPProber.cpp
Encode-Detect-1.01/src/nsSJISProber.cpp
Encode-Detect-1.01/src/nsUTF8Prober.cpp
Encode-Detect-1.01/src/nsEUCTWProber.cpp
Encode-Detect-1.01/src/nsSJISProber.h
Encode-Detect-1.01/src/nsLatin1Prober.cpp
Encode-Detect-1.01/src/nsMBCSSM.cpp
Encode-Detect-1.01/src/nsSBCharSetProber.h
Encode-Detect-1.01/src/nsLatin1Prober.h
Encode-Detect-1.01/src/nsEscSM.cpp
Encode-Detect-1.01/src/nsCharSetProber.h
Encode-Detect-1.01/src/nsBig5Prober.cpp
Encode-Detect-1.01/src/CharDistribution.cpp
Encode-Detect-1.01/src/Big5Freq.tab
Encode-Detect-1.01/src/nsEscCharsetProber.h
Encode-Detect-1.01/src/nsUniversalDetector.cpp
Encode-Detect-1.01/src/nsSBCSGroupProber.h
Encode-Detect-1.01/src/nsEscCharsetProber.cpp
Encode-Detect-1.01/src/nsMBCSGroupProber.cpp
Encode-Detect-1.01/src/nsSBCSGroupProber.cpp
Encode-Detect-1.01/src/JpCntx.cpp
Encode-Detect-1.01/src/nsEUCTWProber.h
Encode-Detect-1.01/src/nsHebrewProber.cpp
Encode-Detect-1.01/src/LangHungarianModel.cpp
Encode-Detect-1.01/src/nsEUCKRProber.cpp
Encode-Detect-1.01/src/nsCodingStateMachine.h
Encode-Detect-1.01/src/nsGB2312Prober.h
Encode-Detect-1.01/src/nsEUCKRProber.h
Encode-Detect-1.01/src/nsMBCSGroupProber.h
Encode-Detect-1.01/src/LangHebrewModel.cpp
Encode-Detect-1.01/src/nsUTF8Prober.h
Encode-Detect-1.01/src/LangCyrillicModel.cpp
Encode-Detect-1.01/src/nsHebrewProber.h
Encode-Detect-1.01/src/nsSBCharSetProber.cpp
Encode-Detect-1.01/src/LangThaiModel.cpp
Encode-Detect-1.01/include/
Encode-Detect-1.01/include/prmem.h
Encode-Detect-1.01/include/nscore.h
Encode-Detect-1.01/LICENSE
Encode-Detect-1.01/Build.PL
Encode-Detect-1.01/typemap
Encode-Detect-1.01/META.yml
Encode-Detect-1.01/Detect.pm
Encode-Detect-1.01/Detector.xs
Removing previously used /home/.cpan/build/Encode-Detect-1.01


  CPAN.pm: Going to build J/JG/JGMYERS/Encode-Detect-1.01.tar.gz


# running Build.PL --otherldflags -L/usr/lib64 --config ldflags=-L/usr/lib64 --extralibdir /usr/lib64
/usr/bin/perl Build.PL --otherldflags -L/usr/lib64 --config ldflags=-L/usr/lib64 --extralibdir /usr/lib64
Checking whether your kit is complete...
Looks good


Warning: this distribution contains XS files, but Module::Build is not configured with C_support.  Please install ExtUtils::CBuilder to enable C_support.
Checking prerequisites...
 - ERROR: ExtUtils::CBuilder is not installed


ERRORS/WARNINGS FOUND IN PREREQUISITES.  You may wish to install the versions
of the modules indicated above before proceeding with this installation


Creating new 'Build' script for 'Encode-Detect' version '1.01'
---- Unsatisfied dependencies detected during [J/JG/JGMYERS/Encode-Detect-1.01.tar.gz] -----
    ExtUtils::CBuilder
Shall I follow them and prepend them to the queue
of modules we are processing right now? [yes] 
Running make install
  Delayed until after prerequisites
Running install for module ExtUtils::CBuilder
Running make for D/DA/DAGOLDEN/ExtUtils-CBuilder-0.260301.tar.gz
y




Checksum mismatch for distribution file. Please investigate.


Distribution id = D/DA/DAGOLDEN/ExtUtils-CBuilder-0.260301.tar.gz
    CPAN_USERID  DAGOLDEN (David Golden <[email protected]>)
    CALLED_FOR   ExtUtils::CBuilder
    CONTAINSMODS ExtUtils::CBuilder::Platform::os2 ExtUtils::CBuilder::Platform::aix ExtUtils::CBuilder::Platform::dec_osf ExtUtils::CBuilder::Platform::Unix ExtUtils::CBuilder::Platform::VMS ExtUtils::CBuilder::Platform::darwin ExtUtils::CBuilder::Platform::cygwin ExtUtils::CBuilder::Base ExtUtils::CBuilder::Platform::Windows ExtUtils::CBuilder
    MD5_STATUS   
    force_update 1
    incommandcolor 1
    localfile    /home/.cpan/sources/authors/id/D/DA/DAGOLDEN/ExtUtils-CBuilder-0.260301.tar.gz


I'd recommend removing
/home/.cpan/sources/authors/id/D/DA/DAGOLDEN/ExtUtils-CBuilder-0.260301.tar
.gz. Its MD5
checksum is incorrect. Maybe you have configured your 'urllist' with
a bad URL. Please check this array with 'o conf urllist', and
retry.

Not to sure what that was all about, so after the first upgrade, I ran it again and did not receive that error again.

My RVSkin module was all jacked up, according to the RVSkin forum, there is a fix.

Logview does not work in IE8 or IE7, it sorta works in Firefox, the format is all broken up.

Fantastico takes a good 10 seconds or more to load.

So far that's all on this one server...We have a handful more to do, but I think I'll hold off until some of these issues are worked out.
 
Last edited by a moderator:

msasek

Member
Nov 28, 2001
18
0
301
I wanted to post an update regarding the remote mysql host problem.

The issue was with the following configuration file:
/usr/local/cpanel/base/horde/config/conf.php

Specifically the update to the conf.php file was being botched with a syntax error for the $conf['sql']['hostspec']='' setting.

Instead of being formatted on one line, the second quote was on the second line along with the semicolon. Additionally, the server name within the quotes was incorrect, as it was preceded by host=

It looked like this:

Code:
$conf['sql']['hostspec'] = 'host=servername
';
It needs to be this:
Code:
$conf['sql']['hostspec'] = 'servername';

If you are running a remote mysql server and your webmail stops working, this may be the problem.
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
After upgrading one server I received this error via email.
Subject: [checkperlmodules] The perl module Encode::Detect::Detector could not be installed.
If you see this again, please try the following command (via root SSH access) to attempt an automated repair; if it still doesn't work please submit a ticket and we will be able to correct this for you:
Code:
# /scripts/autorepair encodedetectfix
My RVSkin module was all jacked up, according to the RVSkin forum, there is a fix.
Please see the following links for RVSkin update information regarding cPanel/WHM v11.25; RVSkin should just need to be updated to the latest version:
cPanel/WHM 11.25 Announced Today - RV Products Forums
RVSkin :: Change Log
RVSkin :: Installation
 

D-Litz

Active Member
Feb 4, 2009
35
0
56
cPanel Access Level
Root Administrator
If you see this again, please try the following command (via root SSH access) to attempt an automated repair; if it still doesn't work please submit a ticket and we will be able to correct this for you:
Code:
# /scripts/autorepair encodedetectfix
Is there an easy way to check to see if it currently functioning properly before running that command?
 
Last edited by a moderator:

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
Is there an easy way to check to see if it currently functioning properly before running that command?
The following command may be used to check if it's already installed:
Code:
# /scripts/perlmods -l | grep -a Encode::Detect
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
458
cPanel Access Level
Root Administrator
On the main WHM page with all the nice new icons (40255) those fonts below the icons are good, across the top (Home News Changelog etc) they're big, and the left menu they're big. In IE8, fonts set to Medium in browser. If I set fonts to smaller, top and left side come more in line with the main page of icons fonts.
I no longer see large labels in the left navigation menu. However I now see that the labels in the top menu ( Home, News, etc ) are larger than the others. My fonts are also set to Medium in IE 8 .

Are you running Vista, XP or Windows 7?

What is your display resolution?

infopro said:
My accounts, root and a reseller (In IE8 only) are stuck on the Tweak Settings page for some reason still. On login I am asked for password again due to the security tokens not being set yet in browser.

Requested page: /scripts2/tweaksettings
Error message: security token missing
I think we need to do some coordinated testing on this. Please open a support ticket - ATTN: cpanelkenneth



Thank you.
 

Infopro

Well-Known Member
May 20, 2003
17,112
513
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
I no longer see large labels in the left navigation menu. However I now see that the labels in the top menu ( Home, News, etc ) are larger than the others. My fonts are also set to Medium in IE 8 .

Are you running Vista, XP or Windows 7?

What is your display resolution?
Running XP here, 1024x768.

When you first open WHM, then check your font size to see medium, select smaller and you'll note the left menu does go down one size (more precisly, the spaces between lines of text). IMO, that's the size it should be throughout, less space.

(see attachment for both views)

I think we need to do some coordinated testing on this. Please open a support ticket - ATTN: cpanelkenneth



Thank you.
2 of my rigs here does this. Another does not that I just tested but had not tested with previously. Sorry to bother with something that's apparently on my end somewhere. I think I'll work to track this one down myself and report back to you what I find out instead of bothering the team with a ticket.

Thanks Ken.
 

Attachments