Well-Known Member
Nov 10, 2007
Warburg, AB, Canada
cPanel Access Level
Root Administrator
I had IPv6 working in 11.34. It was a bit of a patch solution until 11.36 came out (which is supposed to support IPv6) but it worked. I had to manually input the "Listen [::]:80" and "Listen [::]:443" lines into httpd.conf and added the <VirtualHost> and NameVirtualHost lines into the post-virtual host include section in WHM.

It wasn't perfect, but it worked. Now that I've updated to, however, it's broken. The old <virtualhost> sections do nothing and when I copy the new ones from the httpd.conf file and add the appropriate IPv6 lines to the <VirtualHost lines, I get some weird results.

Sometimes, visiting a site will work. Sometimes it will show the page, but not load the CSS files. Sometimes it will load nothing except the Apache configuration success page as if you're visiting the a brand new installation. It's very unpredictable. The whole time, though, the IPv4 sites are working fine. It's only visiting with an IPv6 connection that screws it up and only since updating to

Any ideas how to fix this?