The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

11.38 update now outgoing dkim is not working

Discussion in 'E-mail Discussions' started by dualxeon64, Jun 14, 2013.

  1. dualxeon64

    dualxeon64 Member

    Joined:
    Jun 9, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I was on 11.36 and and after this update I setup exim.conf with the proper changes for dkim with my outgoing mail but now when I put those changes in, The mail stops sending and exim freaks out and will not restart. I used a copy that I had made of the working exim.conf so I would not have to mess with this stuff again.

    Also had to make some changes since I was using the pipe method to resolve sending issues.

    remote_smtp:
    driver = smtp
    dkim_selector = default
    dkim_canon = relaxed
    dkim_private_key = /usr/local/cpanel/etc/exim/dkim.key
    dkim_domain = mydomain.com
    interface = ${if exists {/etc/mailips}{${lookup{$sender_address_domain}lsearch*{/etc/mailips}{$value}{}}}{}}
    helo_data = ${if exists {/etc/mailhelo}{${lookup{$sender_address_domain}lsearch*{/etc/mailhelo}{$value}{$primary_hostname}}}{$primary_hostname}
     
    #1 dualxeon64, Jun 14, 2013
    Last edited: Jun 14, 2013
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you explain the nature of your custom configuration? For instance, is there a specific reason you do not want to use the native support for DKIM that is already included in cPanel?

    cPanel - DKIM

    Thank you.
     
  3. dualxeon64

    dualxeon64 Member

    Joined:
    Jun 9, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Where is the native support for dkim in the outgoing mail. The only way I have known to be able to do this is to modify the exim.conf and put the keys that are generated into the dns configuration. The DKIM in tweak settings only checks DKIM for incoming email.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. dualxeon64

    dualxeon64 Member

    Joined:
    Jun 9, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    What am I missing here? I have tried this stuff it only sets up incoming. Is there a special command that I am not seeing.


    For DKIM, the directive is used to determine whether a key needs to be generated and installed when adding domains to an existing cPanel account. The values can be set via one of the following methods:

    During account creation
    Using the Modify an Account interface in WHM
    Using the Email Authentication interface in cPanel


    DKIM

    DKIM (DomainKeys Identified Mail) is a means of verifying incoming email. It ensures that incoming messages are unmodified and from the sender from whom they claim to be. This feature works to prevent incoming spam messages.
    Status: Enabled & Active (DNS Check Passed)



    This is for incoming I went threw everything at that page it only sets for the incoming. I do not care about the incoming just the out going.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Right, per the documentation:

    It's not saying that the specific option is for incoming email, it's defining what DKIM actually is. DKIM is enabled on a per-account basis. You can browse to the following option in the cPanel of the account:

    "Email Authentication"

    From there, you can choose to enable DKIM for the account. Or, you can enable it through the command line:

    Code:
    /usr/local/cpanel/bin/dkim_keys_install username
    Could you let us know what test you are using that shows DKIM as not being enabled for outgoing email after you enable it using either of these methods?

    Thank you.
     
  7. dualxeon64

    dualxeon64 Member

    Joined:
    Jun 9, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I am using check-auth@verifier.port25.com I have also sent to gmail.com and then I check the original message and it shows the SPF pass but there is no DKIM present



    The Port25 Solutions, Inc. team

    ==========================================================
    Summary of Results
    ==========================================================
    SPF check: pass
    DomainKeys check: neutral
    DKIM check: neutral
    Sender-ID check: pass
    SpamAssassin check: ham



    DKIM check details:
    ----------------------------------------------------------
    Result: neutral (message not signed)
    ID(s) verified:

    NOTE: DKIM checking has been performed based on the latest DKIM specs
    (RFC 4871 or draft-ietf-dkim-base-10) and verification may fail for
    older versions. If you are using Port25's PowerMTA, you need to use
    version 3.2r11 or later to get a compatible version of DKIM.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Have you fully disabled your previous custom Exim configuration values for DKIM, or tried resetting the Exim configuration to default? Also, are you using any other custom Exim modifications or utilizing a smart host?

    Thank you.
     
  9. dualxeon64

    dualxeon64 Member

    Joined:
    Jun 9, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    After the update it removed the custom settings. I set those in February and it was working perfect until the 11.38 update. Now if I put the custom code it will not send so I have it set to its default while I try to get this resolved.
     
  10. dualxeon64

    dualxeon64 Member

    Joined:
    Jun 9, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Ok after testing more I have found out that it is the email client that we are using. I have already opened a ticket with them to see why it is not responding with the dkim sig. Thank you for your help. I will post what caused the issue and how it was fixed.
     
Loading...

Share This Page