The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[165945] Latest WHM update broke Outlook connectivity to Office 365

Discussion in 'E-mail Discussions' started by lavinrac, Feb 15, 2015.

  1. lavinrac

    lavinrac Registered

    Joined:
    Feb 15, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    After the latest update my Outlook client could no longer access shared folders and accounts that utilize mapi. I had been trying to troubleshoot and found when trying to create a new Outlook profile it was pointing to my domain name and not the Office 365 server. I verified all my domain and DNS settings were correct. Now Microsoft has posted this message:

    I can not disable IMAP and SMTP globally on my server as other accounts need them, does anyone have any other possible solutions?
     
  2. lavinrac

    lavinrac Registered

    Joined:
    Feb 15, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: Latest WHM update broke Outlook connectivity to Office 365

    I also want to add that I have the followoing options disabled on my server:
    • Proxy subdomain creation [?]
    • Thunderbird and Outlook autodiscover and autoconfig support (enables proxy subdomain and SRV record creation)

    And that I have manually checked to be sure there are not any incorrect entries in the DNS zone file.
     
  3. dmaher803

    dmaher803 Registered

    Joined:
    Feb 16, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lexington, South Carolina, Uni
    cPanel Access Level:
    Reseller Owner
    EMail Autodiscover Nightmare

    A few weeks ago I noticed our on-premise Exchange setup wasn't properly autodiscovering. When Outlook attempts to autodiscover it tries "domain.com", then "autodiscover.domain.com" and finally it'll check for SRV records. Ours is set up on autodiscover.domain.com since domain.com is our web site. The problem arose when domain.com started responding to autodiscover requests. After a bit of research I found that our VPS host enabled Autodiscover on our CPanel. So I went under Tweaks/Domains and disabled it, but it still responds to autodiscover requests (even after a week, so it isn't DNS propagation). There are no records in the DNS at the cpanel host nor on our DNS that would point autodiscover to cpanel, but it still goes there and it still attempts to serve up autodiscover. I need to know how to get rid of this completely. I can't have domain.com repsonding to autodiscover requests at all. Is there a way to just delete the xml file?
     
  4. lavinrac

    lavinrac Registered

    Joined:
    Feb 15, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: EMail Autodiscover Nightmare

    I am having a similar issue only with Office 365. My issue started after the latest WHM update. You can read what I found in the thread I opened: /http://forums.cpanel.net/f43/latest-whm-update-broke-outlook-connectivity-office-365-a-454422.html

    I hope someone can provide insight and/or a fix.
     
  5. dmaher803

    dmaher803 Registered

    Joined:
    Feb 16, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lexington, South Carolina, Uni
    cPanel Access Level:
    Reseller Owner
    Re: EMail Autodiscover Nightmare

    That is/was pretty much my exact problem. Oddly enough, this morning everything seems to work. After a few days of issues it seems to have magically disappeared. Maybe my cpanel host ran a patch that I wasn't notified about. I'll have to look into it further.
     
  6. dbh1

    dbh1 Registered

    Joined:
    Sep 12, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Re: Latest WHM update broke Outlook connectivity to Office 365

    I am having the same issue. Also note that microsoft's remote connectivity analyzer says the site is set up properly.

    I can temporarily get autodiscover to work by shutting down the whole server while I am setting up a new outlook client, but that certainly isn't scale-able.


    This is a major problem. I presume that cPanel will point the finger at microsoft as microsoft is clearly pointing the finger at cpanel. But, at the end of the day, MSFT is bigger and less nimble so, ideally, cPanel will help us work around this.

    In my case I am hosting DNS at Cloudflare. Right at the cloudflare level i have autodiscover.domain.tld pointing to autodiscover.outlook.com and MX set to domain-tld.mail.protection.outlook.com. Of course the A record of domain.tld itself is pointing to the IP address of the WHM server.

    It appears that somehow Outlook's autodiscover tool is pulling the ip address of domain.tld instead of autodiscover.domain.tld first before failing back to autodiscover.domain.tld (like when I shutdown the server).

    Clearly something on the WHM server is answering something being sent to it. I assume the short-term fix is trying to find a way to turn off whatever that is on a per account basis. I also cannot shut down imap and pop for all accounts. But I could for 1 cpanel account if I had to.
     
  7. dbh1

    dbh1 Registered

    Joined:
    Sep 12, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Re: EMail Autodiscover Nightmare

    @dmaher803, what version are you using? I am on WHM v11.48.0.12 which is the current release and still having the issue. I believe there is a newer bleeding edge version. Is that what you are using?
     
  8. OWSam

    OWSam Registered

    Joined:
    Feb 18, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: Latest WHM update broke Outlook connectivity to Office 365

    We are also having the same issue.

    I have been dealing with Microsoft support on this, and they are working on a temp fix to force Outlook to bypass the WHM autodiscover by way of an XML file installed locally.

    We are on 11.47.9999.150

    - - - Updated - - -

    Also they have triple checked that our DNS settings are setup correctly.
     
  9. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Re: Latest WHM update broke Outlook connectivity to Office 365

    We issued a fix in 11.47.9999.150 that should have resolved the problem. Could you tell me which settings for Proxy Subdomains, and Auto Discovery, that are enabled or disabled in Tweak Settings?

    Thank you.
     
  10. lavinrac

    lavinrac Registered

    Joined:
    Feb 15, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: Latest WHM update broke Outlook connectivity to Office 365

    Kenneth, any ETA on when the fix will be released as stable?

    I have updated my server to the test/edge release of 11.47.9999.150 and it looks to have fixed the problem. I did have to setup my Outlook profile again as the mapi connections were still broken in the original one, but fixed when created new.
     
  11. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    510
    Likes Received:
    66
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Re: Latest WHM update broke Outlook connectivity to Office 365

    Hi,

    Case 165945 has already been merged with 11.48.0, and is currently in QA. While I can't give an exact ETA, I'd imagine this fix will be out this week or early next week.
     
  12. dbh1

    dbh1 Registered

    Joined:
    Sep 12, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Re: Latest WHM update broke Outlook connectivity to Office 365

    I would like to thank cPanel for being on top of this. I put a support request in last night and it Melanie of cPanel logged in and fixed it within a few hours. I assume the fix will hold until the next stable release comes out, but I presume they incorporated the same into the bleeding edge release for those that don't want to mess with this themselves.

    For everyone's info, cPanel said the issue was with the following script alias in the apache configuration:
    cPs# grep -i 'scriptalias.*autodiscover' /usr/local/apache/conf/httpd.conf ScriptAliasMatch ^/autodiscover/autodiscover.xml /usr/local/cpanel/cgi-sys/autodiscover.cgi
    ScriptAliasMatch ^/Autodiscover/Autodiscover.xml /usr/local/cpanel/cgi-sys/autodiscover.cgi

    Note that after this is fixed, for some outlook clients you will need to go into the windows registry and clean out the autodiscover information else it won't know to really try again. I would back up the registry first then poke around current user/software/Microsoft/office/__/outlook/autodiscover. You may be able to delete the Redirectserver key there or it may be something else. I forget. Then consider a reboot. And then re-try.

    Good luck all!

    Thanks Melanie!!!!!
     
  13. OWSam

    OWSam Registered

    Joined:
    Feb 18, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: Latest WHM update broke Outlook connectivity to Office 365

    Actually my mistake, we are on 11.48.0.12


    I will try the fix posted by Melanie
     
  14. StreetSurfer

    StreetSurfer Registered

    Joined:
    Sep 12, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: Latest WHM update broke Outlook connectivity to Office 365

    We're on 11.48.0.12 as "release" and somehow borked all 365 customers... I found ScriptAliasMatch ^/autodiscover/autodiscover.xml /usr/local/cpanel/cgi-sys/autodiscover.cgi in httpd conf = where do I go from here?
     
  15. Mindlash

    Mindlash Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    The following steps fixed my problem (local website, cloudflare, remote Office365)

    1) Open /usr/local/apache/conf/httpd.conf

    2) Find and comment/remove these two lines (you may only have one as I did):
    ScriptAliasMatch ^/autodiscover/autodiscover.xml /usr/local/cpanel/cgi-sys/autodiscover.cgi
    ScriptAliasMatch ^/Autodiscover/Autodiscover.xml /usr/local/cpanel/cgi-sys/autodiscover.cgi​

    3) Run: /usr/local/cpanel/bin/apache_conf_distiller --update

    4) Run: service httpd restart

    This is the full reply from cPanel on the issue, Please read it before performing the steps above.


     
  16. joako

    joako Well-Known Member

    Joined:
    Aug 7, 2003
    Messages:
    97
    Likes Received:
    2
    Trophy Points:
    8
    Still broken... any plans to fix?
     
  17. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The case referenced in this thread has already been implemented. Could you elaborate on the specific problem you are experiencing at this time?

    Thank you.
     
Loading...

Share This Page