The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2 x Perl Modules consistently failing install after upgrade

Discussion in 'General Discussion' started by encryption, Jun 29, 2007.

  1. encryption

    encryption Well-Known Member

    Joined:
    Jun 24, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Ever since my server upgraded to CP11, there have been 2 perl modules that refuse to update and I get an email everyday from the server telling me the following.

    Any ideas how I could go about fixing this ?

    Cheers
     
  2. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    /usr/local/cpanel/bin/checkperlmodules --force
     
  3. encryption

    encryption Well-Known Member

    Joined:
    Jun 24, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    did that already and tried it again now and those are the only 2 which fail. This is the error

     
  4. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    Sounds like you need a new CPAN mirror ...

    Usually when you get that message, it means the archives are corrupt at
    the download site where your server is connecting to for updates.
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The following might resolve the issue (type carefully):

    rm -Rfv /home/.cpan /home/.cpcpan
    /usr/local/cpanel/bin/checkperlmodules


    If not, posting the full perl module install output might help.
     
  6. encryption

    encryption Well-Known Member

    Joined:
    Jun 24, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for all the responses,

    2 modules were not working and I kept getting the following 2 errors via email

    At the bottom of the email, it had the following

    so I did
    rm /home/.cpan/sources/authors/id/D/DL/DLAND/Crypt-SSLeay-0.55.tar.gz.

    and ran

    /usr/local/cpanel/bin/checkperlmodules --force

    all is well.


    Btw Chirpy, gotta thank you for CSF / LFD. Best piece of software I installed on my servers. Thanks for making it a free distribution.
     
Loading...

Share This Page