The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

:2082 works but /cpanel does not

Discussion in 'General Discussion' started by lazydayz, Aug 2, 2006.

  1. lazydayz

    lazydayz Member

    Joined:
    Jun 12, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
  2. 365DOL

    365DOL Member

    Joined:
    Oct 13, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    None of the URL is working at my end.
     
  3. lazydayz

    lazydayz Member

    Joined:
    Jun 12, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
  4. myusername

    myusername Well-Known Member
    PartnerNOC

    Joined:
    Mar 6, 2003
    Messages:
    691
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    chown -R us.*yourbase*
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    add a trailing slash like domain.com/cpanel/

    If that doesn't do it you might have a browser hijacker installed if port 2082 works fine.
     
  5. elleryjh

    elleryjh Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    The code that makes that redirect work is in /usr/local/apache/conf/httpd.conf.

    Specifically:
    Code:
    ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    Make sure that's still in httpd.conf somewhere.
     
  6. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    and make sure apache is up and the "domain" you are using is pointing towards the IP that apache is binding to. On a new box ..this could bite you. I would hope you knew if apaceh was down ..but had to ask. apache doesn't serve cpanel ..but it redirects you to it on 2082/83
     
  7. -jdk-

    -jdk- Well-Known Member

    Joined:
    Aug 28, 2005
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    There is a setting in your config inside WHM to direct /cpanel /whm /webmail requests to the proper port. This is likely unchecked.
     
  8. Messiah

    Messiah Member
    PartnerNOC

    Joined:
    Jul 5, 2006
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Also, there's a setting in Tweak Settings in WHM that will make /cpanel, /whm, /webmail, etc always redirect to secure ports. If you have this set, then /cpanel will redirect to :2083, which relies on stunnel. Make sure stunnel is functioning properly in this case. Most likely it's just the ScriptAlias lines. You can test to see if it's stunnel by manually typing https://domain:2083.
     
Loading...

Share This Page