The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

403 errors

Discussion in 'Data Protection' started by Drumrocker365, Jul 6, 2014.

  1. Drumrocker365

    Drumrocker365 Well-Known Member

    Joined:
    Apr 15, 2014
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hey guys,

    On my forums site, I uploaded a bunch of new files via root account. Rather than using slow WinSCP to set each file permission individually (to my site's account owner and group), I used SSH. I typed "cd /home/mytechforums" then "chown -R mytechforums:mytechforums public_html" This then screwed with my permissions somehow and I get 403 forbidden when trying to access the site. Please help!
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    I can see you have root access so I will suggest you please check the Apache error logs to find out the exact cause of this 403 issues. Also update here so that we will check that for you.
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    public_html should be mytechforums:nobody

    You may be ok to just fix that and get the forums working again.

    You really shouldn't run commands via SSH if you're unsure of what they do. You can wipe out the entire server with a simple typo in a one line command.

    Assuming no other issues with the "bunch of new files" you were uploading, if you had them in a single zip file, uploaded that via cPanel File Manager, extracted/unpacked on the server, and moved them to where you want them from there, you probably could have avoided using any commands at all.

    BTW, chown is for setting owner, not permissions. If you were logged in as the user, chown shouldn't have been needed. If your FTP client is not configured to properly set permissions on upload, you should go thru your FTP client settings and change that.
    /http://winscp.net/eng/docs/ui_transfer_custom

    GL!
     
  4. Drumrocker365

    Drumrocker365 Well-Known Member

    Joined:
    Apr 15, 2014
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    I tried changing settings to mytechforums:nobody and now I get a 500 error.
     
  5. cPanelPeter

    cPanelPeter Technical Analyst III
    Staff Member

    Joined:
    Sep 23, 2013
    Messages:
    569
    Likes Received:
    15
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Please check the log file:

    Code:
    /usr/local/apache/logs/error_log
    
    as you view the website to see what errors it is returning.
     
  6. Drumrocker365

    Drumrocker365 Well-Known Member

    Joined:
    Apr 15, 2014
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    I decided to go ahead and backup everything, terminate the account, re-make the account, and restore the data. That did the trick.
     
Loading...

Share This Page