SOLVED 403 Forbidden Error With addon Domain

Sounak

Registered
Dec 29, 2017
2
0
1
Kolkata
cPanel Access Level
Website Owner
Hello,

I am using cPanel through HostGator's hosting service. My Domain is on GoDaddy.com

Now lets say I have the primary domain as abc.com, I have put the name servers on GoDaddy and it works fine. I added another Addodn domain say xyz.com, and also put the same name servers on GoDaddy, But when i open xyz.com, i get an error of 403:Forbidden. I have asked Hostgator help and they said this is the only way. Please help me out peeps.

Document root of ADON DOMAIN : /public_html/xyz.com

Error from the cPanel :-
[Fri Dec 29 14:07:57 2017] [error] [client xx.xxx.xxx.xxx] Directory index forbidden by Options directive: /home/xxxxxx/public_html/xyz.com/

PS: The primary domain works fine
 

24x7server

Well-Known Member
Apr 17, 2013
1,894
91
78
India
cPanel Access Level
Root Administrator
[Fri Dec 29 14:07:57 2017] [error] [client xx.xxx.xxx.xxx] Directory index forbidden by Options directive: /home/xxxxxx/public_html/xyz.com/
-> It appears that you do not have index page in the document root that is the reason it is asking for directory listing as per the error you gave. You can either enable the directory listing for this domain or you can create an index page in this document root and then browse the website to check if it is accessible..
 

Sounak

Registered
Dec 29, 2017
2
0
1
Kolkata
cPanel Access Level
Website Owner
do you any web pages uploaded to the addon domain yet ? try uploading a test html page and then browse the addon domain.
your quote really helped me to dig into it, the problem was that there was no web pages there, I had installed wordpress but it went inside another directory wp, so the address was xyz.com/wp

thank you very much fir your support . Helped me a lot.

-> It appears that you do not have index page in the document root that is the reason it is asking for directory listing as per the error you gave. You can either enable the directory listing for this domain or you can create an index page in this document root and then browse the website to check if it is accessible..
thank you for the suggestion, it helped, I had installed wordpress but on further checking it came that it went inside a directory of its own called wp, thus the website was xyz.com/wp, corrected it and now it all works fine :)
 
Last edited by a moderator: