The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

403 forbidden error

Discussion in 'General Discussion' started by Secret Agent, Oct 8, 2005.

  1. Secret Agent

    Secret Agent Guest

    I am getting this error on one account:

    Forbidden
    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


    I did the following...

    removed htaccess file
    /scripts/fixcommonproblems
    /scripts/enablefileprotect
    /scripts/fixquotas
    chmod 755 /home/patri3/public_html
    service httpd restart

    The site is still not working. Any ideas?

    cpanel current
    centos 4.1
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Well, looking in the apache error log would be the first place to look. After checking that and following any errors and fixing them, you could try:

    /scripts/chownpublichtmls
     
  3. Secret Agent

    Secret Agent Guest

    Apache error log shows this:

    [Sat Oct 8 16:11:38 2005] [crit] [client xxx.x91.184.128] (13)Permission denied: /home/patri3/public_html/epicureandigest/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is reada$

    Strange because the htaccess was deleted (comes back by itself) and is default 0644, yet I edited it and it is empty as well.

    I ran that script as well.

    Any ideas?
     
  4. Secret Agent

    Secret Agent Guest

    I'm getting the same now for the two addon domains

    [Sat Oct 8 21:49:50 2005] [crit] [client xxx.194.6.74] (13)Permission denied: /home/patri3/public_html/poetry/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

    There is no .htaccess files in their directories and the directories are default chmodded 750.

    What could it be? I'm so lost on this.
     
  5. Secret Agent

    Secret Agent Guest

    Just to let you know...chmodded the directories to 755 from cpanel's default 750 fixed it
     
  6. EMS

    EMS BANNED

    Joined:
    May 10, 2003
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    0
    Had this probl today - noticed that the /home/USERDIR was set to 744 instead of 711

    wierd !
     
Loading...

Share This Page