Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

451 Email Problem

Discussion in 'E-mail Discussion' started by tseabaugh, Nov 21, 2007.

  1. tseabaugh

    tseabaugh Member

    Joined:
    May 6, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    I just set up appriver spam filtering for a customer. I have 4 other customers on this server using appriver. When the forwarding begins, the messages are rejected saying authentication is required. Authentication is NOT required for SMTP Traffic.

    In WHM, I processed a "Fix mailbox permissions". All accounts on the server showed a reset, but the one in question was missing from the list! Have I lost a setting somewhere for this account and the server is not recognizing it properly?

    A friend said there may be a valias problem. Any help?
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,344
    Likes Received:
    58
    Trophy Points:
    178
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    You're server doesn't believe it is the final mail exchanger.

    The domain you are providing mail for (the domain whose mail is scrubbed by Appriver) should:

    1. exist in /etc/localdomains
    2. NOT exist in /etc/remotedomains

    If you log into the /cpanel interface of the domain in questoin, then click on MX record - there is an option there that says:

    Always accept mail locally even if the primary mx does not point to this server.


    This option should be checkmarked.

    HOWEVER - NOTE: If you have multiple MX's set up by manually editing the DNS zone file for that domain, don't bother trying to change the setting via Cpanel. Instead:

    1. edit /etc/localdomains - make sure the domain exists there
    2. edit /etc/remotedomains - make sure the domain does NOT exist there
    3. /scripts/restartsrv_exim for good measure (although it shouldn't be needed)

    Mike
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tseabaugh

    tseabaugh Member

    Joined:
    May 6, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    That's it!

    localdomains did not contain the domain. It was recently transferred from another server and apparently did not populate. Thanks for the help!
     
  4. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,344
    Likes Received:
    58
    Trophy Points:
    178
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    You're welcome. Glad it worked for ya!

    mike
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice