The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

451 error problem

Discussion in 'E-mail Discussions' started by upsforum, Aug 1, 2013.

  1. upsforum

    upsforum Well-Known Member

    Joined:
    Jul 27, 2005
    Messages:
    446
    Likes Received:
    0
    Trophy Points:
    16
    I have an account maked with a sub domain name on my vps, the subdomain is landing.maindomain.com, maindomain.com is active on another server (that I don't can .

    I configured email account noreply@landing.maindomain.com on my vps and I send messages with phpmailer but exim return 451 error:

    this is the log


    LOG: MAIN
    cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1V48hu-0002zm-EY
    delivering 1V48hu-0002zm-EY
    Connecting to mailx.insigno.net [151.12.107.22]:25 from 79.143.187.230 ... connected
    SMTP<< 220 mailx.insigno.net ESMTP Exim 4.69 Thu, 01 Aug 2013 10:38:29 +0200
    SMTP>> EHLO vps5.myhostname.net
    SMTP<< 250-mailx.insigno.net Hello vps5.myhostname.net [79.143.187.230]
    250-SIZE 52428800
    250-PIPELINING
    250 HELP
    SMTP>> MAIL FROM:<noreply@landing.maindomain.com> SIZE=2637
    SMTP>> RCPT TO:<management @ -----. com>
    SMTP>> DATA
    SMTP<< 250 OK
    SMTP<< 451 Temporary local problem - please try later
    LOG: MAIN
    SMTP error from remote mail server after RCPT TO:<management@ -----. com>: host mailx.insigno.net [151.12.107.22]: 451 Temporary local problem - please try later
    SMTP<< 503-All RCPT commands were rejected with this error:
    503-Temporary local problem - please try later
    503 Valid RCPT command must precede DATA
    SMTP>> QUIT
    LOG: MAIN
    == management@ -----. com R=lookuphost T=remote_smtp defer (-44): SMTP error from remote mail server after RCPT TO:<management@ -----. com>: host mailx.insigno.net [151.12.107.22]: 451 Temporary local problem - please try later
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Are you able to send to other remote mail servers from this PHP application? Or, is this issue occurring no matter what email address you send out to? Have you confirmed the subdomain is not added to the /etc/localdomains file on the remote mail server? Is it only happening when you use the PHP script to send out email, or does the issue occur when using an email client or Webmail?

    Thank you.
     
  3. upsforum

    upsforum Well-Known Member

    Joined:
    Jul 27, 2005
    Messages:
    446
    Likes Received:
    0
    Trophy Points:
    16
    I use php application for send to 3 address email, two address work but the 3rd address not work, this address is active where is located maindomain.com account,

    summarize:

    my vps cpanel with noreply@landing.maindomain.com (on landing.maindomain.com account) sent to 3 addresses:

    1) remote mail 1 [OK]
    2) remote mail 2 [OK]
    3) remote mail with maindomain.com account [NOT WORK] (this server not use cpanel, and i don't know that OS and smtp use)

    DNS of maildomain.com is configured with a record A of landing.maindomain.com to ip of my vps cpanel and without mx record
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Check to see if the domain name associated with your subdomain is located in the following file on your system:

    /etc/localdomains

    It should not exist in this file if it's email is hosted on a remote mail server. Also, do you get the same result when sending with an email client or with Webmail?

    Note the error message indicates that SMTP authentication is not enabled. Please ensure your PHP application is authenticating before attempting to send email via SMTP.

    Thank you.
     
  5. upsforum

    upsforum Well-Known Member

    Joined:
    Jul 27, 2005
    Messages:
    446
    Likes Received:
    0
    Trophy Points:
    16
    I think that the problem is that server smtp of @maindomain.com not is available, is possible? because my customer confirm this on this domainname smtp is inactive.

    But I can disable smtp recipient verification on my vps?
     
  6. upsforum

    upsforum Well-Known Member

    Joined:
    Jul 27, 2005
    Messages:
    446
    Likes Received:
    0
    Trophy Points:
    16
    I don't understand, I added replyto to phpmailer and now work fine
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page