Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

4gb lost to python/mailman ?

Discussion in 'E-mail Discussion' started by nyjimbo, Dec 14, 2010.

  1. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,131
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    New York
    We've been noticing one of our servers losing lots of space on /usr for a while now. Tonight I did the "lsof" for deleted files and found this:

    python 11832 mailman 3u REG 8,3 4741156245 2558314 /usr/local/cpanel/3rdparty/mailman/logs/locks (deleted)

    which if I am reading it right says that this file is 4.7 gb but its not seen due to python running ?.

    Is there a way to get python to release this file or do whatever is necessary to free up the space without having
    to reboot the machine ?.

    I tried restarting syslogd and mailman just in case but nothing happened. Can any kind of signal sent to python do this or is there a command to restart python. I dont think restartsrv_mailman is doing it. I also tried running /usr/local/cpanel/startup without any change.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 nyjimbo, Dec 14, 2010
    Last edited: Dec 14, 2010
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,563
    Likes Received:
    42
    Trophy Points:
    308
    cPanel Access Level:
    Root Administrator
    By now that's likely a an orphaned process. You'll likely need to issue something like kill -9 to terminate the process.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice