"5.3.29 END OF LIFE" - will WHM keep it?

postcd

Well-Known Member
Oct 22, 2010
720
20
68
Hello,

if i will be using PHP 5.3.29 END OF LIFE
do i need to worry about WHM upgrading PHP to higher version somehow automatically when this version is no longer supported by PHP?

As when i tried higher version, many scripts was throwing many errors..
 

PenguinInternet

Well-Known Member
PartnerNOC
Jun 20, 2007
192
24
68
Cardiff, UK
cPanel Access Level
DataCenter Provider
Twitter
No, this won't upgrade automatically - you need to run EasyApache to perform he upgrade. Currently there are no known vulnerabilities in this version, but being end of life I would expect cPanel to withdraw it as soon as any are found. You would be worthwhile looking at upgrading to PHP v5.4 which has very few changes required from v5.3.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello :)

It won't upgrade automatically unless you build Apache/PHP via EasyApache after it's removal. Note that it's likely a good idea to go ahead and start planning on upgrading those scripts to support the newer versions of PHP.

Thank you.