The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

500 error after easyapache manual

Discussion in 'EasyApache' started by nyy, Apr 21, 2003.

  1. nyy

    nyy Member

    Joined:
    Feb 17, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I have selected #6 in easyapache and reconfigured apache with gd, mcript, frontpage, mbstring, etc.
    Now, most of my files are working as usual, but some of my php scripts are not working. 500 Internal Error.

    The script not working is a groupware. I forgot the name of it.
    Anyone know something about this?

    Thanks in advance.
     
    #1 nyy, Apr 21, 2003
    Last edited: Apr 21, 2003
  2. nyy

    nyy Member

    Joined:
    Feb 17, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    In addition, php file is somehow set to 755 eventhough I set it 664. It seems when I access to error log, it is changed.

    Thanks,
     
  3. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    You chose to enable phpsuexec. You should run easyapache again and disable phpsuexec. That is the immediate fix. If you really want to use phpsuexec, which runs php as cgi (hence the 755 permissions), you should weigh the pros and cons. I do believe that there are some php scripts that simply won't work with phpsuexec.
     
  4. YukFoo

    YukFoo Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Yeah, running disabling phpsuexec fixes the problem. However mail will still be returned

    550 cannot route to sender address <nobody@server22.domain.com>

    I wish there was a simple fix for this issue. Many users are starting to complain that the email is being returned, or not getting thru to their clients because of this.

    Please DarkORB come up with a simple solution. :D
     
  5. nyy

    nyy Member

    Joined:
    Feb 17, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Thank you very much.
    The problem is fixed now. :)
     
  6. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    You've disabled phpsuexec, right? Have you also UNchecked the option in tweak settings to disallow the user "nobody"?
     
Loading...

Share This Page