The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

500 error on all cgi scripts all domains

Discussion in 'General Discussion' started by jeroman8, Jun 27, 2003.

  1. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    Suddenly yesterday while installing a common cgi script
    Perl quit on me. Now NO cgi scripts will run at all on any domain on the server.

    500 error, premature end of script headers.
    But all of these worked yesterday.

    I have run: Easyapache, Updated to latest Cpanel, Fixperl and
    suex is disabled on the server.

    All permission is OK, ASCHII Mode = Yes and whatever....
    The scripts worked before !!

    Anyone ??? Please !!!!

    Regards Jeroman

    cPanel.net Support Ticket Number: 16773
     
  2. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    Happened to us two updates ago. Nick says there is nothing in upcp that will change directory permissions, but after one of the updates, it wiped out the ability to use cgi, php on our server. Even phpsuexec was shot. We had lots and lots of angry users. 48hrs later i found the problem, without DarkOrbs's help. The directory permission on /usr/bin/ had mysteriously changed. Check the permssion on /usr/bin and make sure its correct.

    cPanel.net Support Ticket Number:
     
    #2 sexy_guy, Jun 27, 2003
    Last edited: Jun 27, 2003
  3. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    It's 755 now, is that ok ?

    cPanel.net Support Ticket Number:
     
  4. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    My host said he fixed it:

    "This was a permissions/suexec issue, and has been fixed"

    But then right after it's back not working again ?!

    cPanel.net Support Ticket Number:
     
  5. smarcellini

    smarcellini Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    this started happening to me sense the last cpanel apache update.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page