The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

500 internal server error

Discussion in 'General Discussion' started by crossfitborder, Mar 6, 2013.

  1. crossfitborder

    crossfitborder Registered

    Joined:
    Mar 6, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I'm sure you guys get heaps of these, I cannot access my website domain.com

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@domain.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    I went into my error log and here are the most recent lines

    [Thu Mar 07 10:24:21 2013] [error] [client 165.228.245.59] File does not exist: /home/crossfit/public_html/500.shtml
    [Thu Mar 07 10:24:21 2013] [error] [client 165.228.245.59] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/crossfit/public_html/index.php
    [Thu Mar 07 10:23:52 2013] [error] [client 101.162.212.5] File does not exist: /home/crossfit/public_html/500.shtml
    [Thu Mar 07 10:23:09 2013] [error] [client 101.162.212.5] File does not exist: /home/crossfit/public_html/500.shtml
    [Thu Mar 07 10:23:09 2013] [error] [client 101.162.212.5] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/crossfit/public_html/index.php
    [Thu Mar 07 10:21:31 2013] [error] [client 101.162.212.5] File does not exist: /home/crossfit/public_html/404.shtml
    [Thu Mar 07 10:21:31 2013] [error] [client 101.162.212.5] File does not exist: /home/crossfit/public_html/comments
    [Thu Mar 07 10:19:32 2013] [error] [client 66.249.74.223] File does not exist: /home/crossfit/public_html/500.shtml
    [Thu Mar 07 10:19:32 2013] [error] [client 66.249.74.223] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/crossfit/public_html/index.php

    ANy ideas?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    652
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The primary error message I notice is:

    There are several potential causes for this problem. One potential issue could be memory limits imposed in the Apache configuration file. Try running this command:

    Code:
    # grep RLimitMEM /usr/local/apache/conf/httpd.conf
    You may see an output such as:

    Code:
    RLimitMEM 149339477
    If so, try disabling or removing the line in the httpd.conf file, and restarting Apache. Check to see if the issue still persists, and then run the Apache distiller to preserve the change if you find it resolved the issue.

    Thank you.
     
  3. crossfitborder

    crossfitborder Registered

    Joined:
    Mar 6, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I'm completely lost! Sorry, I'm not very familiar with any of this stuff.
     
  4. PlotHost

    PlotHost Well-Known Member

    Joined:
    Apr 29, 2011
    Messages:
    253
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    US
    cPanel Access Level:
    Root Administrator
    Twitter:
    I see you are a Website Owner. Contact your host and tell them about Michael's post.
     
  5. crossfitborder

    crossfitborder Registered

    Joined:
    Mar 6, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    At least you are being helpful!

    My host keeps telling me to check my permissions and referring me to the same page... I've checked permissions and none are set to 700.

    I tried reinstalling Wordpress through fantastico and this came up:

    Warning: system() has been disabled for security reasons in /tmp/cpanel_phpengine.1362957998.439014LC9Z0HlOFW on line 1611

    Warning: system() has been disabled for security reasons in /tmp/cpanel_phpengine.1362957998.439014LC9Z0HlOFW on line 1623
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  7. Nishant80

    Nishant80 Well-Known Member

    Joined:
    May 7, 2012
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Did you check if your /tmp directory is full?
     
Loading...

Share This Page