The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

500 Internal Server Error

Discussion in 'General Discussion' started by mipaunm, May 17, 2013.

  1. mipaunm

    mipaunm Registered

    Joined:
    May 17, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hy....

    On my site, I have error :

    any idea?

    thnak you

    - - - Updated - - -

    error_log


    [Fri May 17 23:27:53 2013] [notice] SSL FIPS mode disabled
    [Fri May 17 23:27:53 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Fri May 17 23:27:53 2013] [notice] SSL FIPS mode disabled
    [Fri May 17 23:27:53 2013] [notice] Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 configured -- resuming normal operations
    DBI connect('database=leechprotect:host=localhost','leechprotect',...) failed: Access denied for user 'leechprotect'@'localhost' (using password: YES) at /usr/local/cpanel/bin/leechprotect line 236
    [Fri May 17 23:37:00 2013] [notice] Graceful restart requested, doing restart
    [Fri May 17 23:37:00 2013] [notice] SSL FIPS mode disabled
    [Fri May 17 23:37:01 2013] [notice] Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 configured -- resuming normal operations
    DBI connect('database=leechprotect:host=localhost','leechprotect',...) failed: Access denied for user 'leechprotect'@'localhost' (using password: YES) at /usr/local/cpanel/bin/leechprotect line 236
    [Fri May 17 23:37:02 2013] [warn] long lost child came home! (pid 9602)
    [Fri May 17 23:37:08 2013] [notice] Graceful restart requested, doing restart
    [Fri May 17 23:37:08 2013] [notice] SSL FIPS mode disabled
    [Fri May 17 23:37:08 2013] [notice] Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 configured -- resuming normal operations
    DBI connect('database=leechprotect:host=localhost','leechprotect',...) failed: Access denied for user 'leechprotect'@'localhost' (using password: YES) at /usr/local/cpanel/bin/leechprotect line 236
    [Fri May 17 23:37:09 2013] [warn] long lost child came home! (pid 9686)
    [Fri May 17 23:39:35 2013] [notice] Graceful restart requested, doing restart
    [Fri May 17 23:39:35 2013] [notice] SSL FIPS mode disabled
    [Fri May 17 23:39:35 2013] [notice] Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 configured -- resuming normal operations
    [Fri May 17 23:51:41 2013] [notice] Graceful restart requested, doing restart
    [Fri May 17 23:51:41 2013] [notice] SSL FIPS mode disabled
    [Fri May 17 23:51:42 2013] [notice] Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 configured -- resuming normal operations
    [Sat May 18 10:40:41 2013] [error] [client 10.100.11.100] File does not exist: /usr/local/apache/htdocs/favicon.ico
    [Sat May 18 10:40:41 2013] [error] [client 10.100.11.100] File does not exist: /usr/local/apache/htdocs/favicon.ico
    [Sat May 18 10:52:18 2013] [error] [client 10.100.11.100] SoftException in Application.cpp:357: UID of script "/home/simpeg/public_html/index.php" is smaller than min_uid
    [Sat May 18 10:52:18 2013] [error] [client 10.100.11.100] Premature end of script headers: index.php
    [Sat May 18 10:52:18 2013] [error] [client 10.100.11.100] File does not exist: /home/simpeg/public_html/sys_cpanel, referer: http://10.100.11.100/~simpeg/
     
  2. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    I would guess that file /home/simpeg/public_html/index.php is owned by root.
     
  3. Veeble-Adam

    Veeble-Adam Active Member

    Joined:
    May 7, 2013
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Change the ownership of the file to "simpeg" and this should fix the problem.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    29,162
    Likes Received:
    517
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Check on the ownership of the index.php file to ensure it's owned by the account username. It's a good idea to access FTP/SSH as the account username when uploading or extracting files so you do not have to manually change the ownership values.

    Thank you.
     
Loading...

Share This Page