500 Internal Server Error

ajay18

Registered
Sep 16, 2008
4
0
51
hi,

i have prob when going to my site - it says 500 Internel server error

Code:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------Apache/2.2.9 (Unix) mod_ssl/2.2.9 OpenSSL/0.9.7a DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

plz. help me to solve this prob...i want to fix this error. how to do that in cpanel? any help appricated
 

darren.nolan

Well-Known Member
Oct 4, 2007
259
0
66
Mate you need to give a lot more information about your error. What are you trying to access when this happens?

If it's a PHP file, ensure permissions are 644 for files and 755 for directories when running suPHP. Also ensure you have no PHP flags in a .htaccess (try disabling .htaccess if you have this file in the same directory by renaming it to something else).

What have you recently changed or uploaded to produce this error.

And before someone else yells at you, just remember not to double post the same question (lots of ppl don't like it, kk?).

:)
 

ajay18

Registered
Sep 16, 2008
4
0
51
Help me out

ok suree...

well...when i access to my site - it says Internal Error 500...well, im trying go into my board and my blog...well, recently it showing more times the error...

i dunno how to fix that prob.

what u mean .htaccess? well, got to change the name of .htaccess? in all directories or just in one directory? edit the .htacess?

by the way,how to run scripts in cpanel?

how to try disabling the .htaccess?

well...i have .htaccess in all directories...

well, recently i installed mods for my board and blogs...

any help appricated

thanks
 

darren.nolan

Well-Known Member
Oct 4, 2007
259
0
66
If you've added some mods recently they would more than likely be causing the problem. So this wouldn't be a cPanel error as such.

Your hosting provider would be able to shed some more light on the situation for you.

But I believe .htaccess may be causing the problems.

Try renaming .htaccess files to something else (like .htaccess-backup) and testing to see if that clears your problem.

.htaccess files work recursively, which means if you have .htaccess in your /public_html directory, those settings will affect anything below it too like /public_html/sub-directory

So change the file in your public_html directory. This might kill your links and stop things from linking, but it would give you an indication of what your problem is.

If it is a .htaccess problem, you'll need to go into the file and work out which sections are the problem - through trial and error.

I would again suggest that your host would be able to help you in this regards.
 

ajay18

Registered
Sep 16, 2008
4
0
51
Help

well...

i renamed as .htaccess-backup it created 2 copies one .htaccess & .htaccess-backup

well, when i did it...well, the page didnt work...

after tht i deleted which i renamed it...then after sometime it says again internal error 500...when i refresh it one or twice then it works...

well, wat is the problem?

is there a way to fix it up?

well, i checked the server status...everything is ok...well, i saw one is failed...

exim (exim-4.69-6_cpanel_maildir) - this shows failed...

wat is this?

by the way, is it prob with Apache?

thanks...any help appreciated
 

darren.nolan

Well-Known Member
Oct 4, 2007
259
0
66
So we've confirmed that .htaccess is your problem and was caused more than likely by a mod you added to your site.

You really need to get in touch with your host and discuss your problem, and while you are there ask why Exim is down.

.htaccess isn't related to cPanel so these aren't the best forums for this particular problem.