Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

500 server errors when CGI is php_handler

Discussion in 'General Discussion' started by moonray, Nov 23, 2009.

  1. moonray

    moonray Registered

    Joined:
    Nov 23, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    51
    [SOLVED] 500 server errors when CGI is php_handler

    Hello,

    I have checked all these basics before posting here:

    1. Permissions
    . . . a. 755 for folders and 644 for all files in public_html and below in all accounts on my VPS
    . . . b. 755 for /usr/local/cpanel/3rdparty/bin/php and /usr/local/cpanel/3rdparty/bin/php-cgi
    2. Ownership set to user:user for all accounts (using # /scripts/chownpublichtmls)
    3. No php_value or php_flag in .htaccess files

    phpinfo()

    PHP Version 5.2.11
    System: Linux host.mydomain.com 2.6.9-023stab048.6-enterprise #1 SMP Mon Nov 17 19:09:18 MSK 2008 i686
    Configure Command: './configure' '--disable-pdo' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstring' '--enable-sockets' '--prefix=/usr/local' '--with-apxs2=/usr/local/apache/bin/apxs' '--with-curl=/opt/curlssl/' '--with-gd' '--with-gettext' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libxml-dir=/opt/xml2/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-pgsql=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-zlib' '--with-zlib-dir=/usr'

    The Problem:

    1. I want to enable PHP suEXEC with Mod_suphp Support
    2. When I enable suphp/CGI as the php_handler (through WHM >> Service Configuration >> Apache Configuration >> Configure Suexec and PHP), I get 500 errors on ALL accounts of VPS.
    3. When php_handler is set to DSO, sites are up, but it creates problems for my scripts (as permissions are max 755/644 for folders/files).

    What else should I look at?

    Any other info that will be useful?

    My hosting technical support has not been able to help me so far.

    Thanks in advance,
    moonray

    EDIT
    SOLUTION


    http://forums.cpanel.net/f5/500-internal-server-errors-all-sudden-112269.html

    Checked the size of these TWO files (these have a max limit of 2GB):
    /usr/local/apache/logs/suexec_log
    /usr/local/apache/logs/suphp_log

    Both were >2GB in size. Just renamed them to something else, like suexec_log_toolarge...

    IT's Working NOW!

    Thanks again to this great forum! I will check here before I ask anything from my hosting support ;)

    moonray
     
    #1 moonray, Nov 23, 2009
    Last edited: Nov 23, 2009
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice