The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

550 Sender verify failed - errors

Discussion in 'Security' started by knipper, Apr 29, 2004.

  1. knipper

    knipper Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Hey everyone,

    I'm having problems with the above error when trying to send mail from osCommerce, or a formmail TYPE php script. All of the noted settings below were installed on a brand new server with no domains. I then added a test domain, and installed the items which are trying to send mail.

    Here's the current config...

    suexec installed
    phpsuexec installed

    In addiion I have:

    1) Prevent the user 'nobody' from sending out mail to remote addresses

    2)Verify the existance of email senders

    3) Php's open_basedir protection prevents users from opening files outside of their home directory with php

    4) SMTP Tweak - This SMTP tweak will prevent users from bypassing the mail server to send mail (This is a common practice used by spammers). It will only allow the MTA (mail transport agent), mailman, and root to connect to remote SMTP servers

    I checked the exim_mainlog and here is what I get. (changed users/IP's, etc. for privacy)

    2004-04-28 10:33:31 1BIq7v-0004Es-20 <= scubagoo@my.servername.com U=scubagoo P=local S=616
    2004-04-28 10:33:35 1BIq7v-0004Es-20 ** johndoe@mydomain.com R=lookuphost T=remote_smtp: SMTP error from remote mailer after RCPT TO:<johndoe@mydomain.com>: host mydomain.com [209.xxx.xxx.xxx]: 550-Verification failed for <scubagoo@my.servername.com>\n550-Unrouteable address\n550 Sender verify failed
    2004-04-28 10:33:35 1BIq7z-0004F7-FI <= <> R=1BIq7v-0004Es-20 U=mailnull P=local S=1963
    2004-04-28 10:33:35 1BIq7v-0004Es-20 Completed
    2004-04-28 10:33:35 1BIq7z-0004F7-FI => scubagoo <scubagoo@my.servername.com> R=localuser T=local_delivery
    2004-04-28 10:33:35 1BIq7z-0004F7-FI Completed

    I'm trying to determine if it is phpsuexec, or the disallow nobody which is preventing mail from going outbound, or any of the other tweaks.

    All input is appreciated. Anyone suggest where to start? Thanks in advance!
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    First things first:

    Do you have an DNS A record for my.servername.com?

    Have you waited for it to propagate?

    Do you have an rDNS entry for your main IP address?

    If all those are Yes, then I would suggest switching off the SMTP Tweak and trying again.
     
  3. knipper

    knipper Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Thanks Chirpy...

    Yes, all items have A records, RDNS, and has propegated. I did try to disable the SMTP tweak, but will check again. I may have missed something.

    What services should be restarted after making that change?

    PS... I followed your mailscanner upgrade, and it worked great w/no problems. Thanks. ;)
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Glad your MailScanner upgrade worked :)

    It may not be necessary to restart anything, though restarting exim wouldn't hurt:
    /etc/init.d/exim restart
     
  5. knipper

    knipper Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Nope, STill the same.

    However I did notice that the mail in this line:
    2004-04-30 13:16:53 1BJbd7-0002jM-RF <= scubagoo@my.servername.com U=scubagoo P=local S=511

    Is being sent from the domain username, but from the server address, not the domain name that the user belongs too. Is this normal?

    I.E. Should the mail be sending from scubagoo@scubagoo_domain.com??

    Thanks.
     
  6. knipper

    knipper Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    OK.... Here's an update!

    It seems the problem only exists when sending to another CPanel server. I was able to send to an AOL address, and to my work address as well with no problems.

    I then tried several addresses of domains on one of my old servers (cPanel) and got the same error as my original post.

    I did find this thread:
    http://forums.cpanel.net/showthread.php?s=&threadid=223&perpage=15&pagenumber=1 here and was wondering what anyone thought I should do before I upgrade/make blind changes.

    Suggestions?
     
  7. knipper

    knipper Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    I found what was causing my error. As you recall my problem was getting scripts to send e-mail to my old cPanel box.

    The domain, which is my hostname on the new machine, had previously been parked on my old server.

    Even though I had removed the park, and made sure the DNS records were correct, There was still a problem.

    What happened is the domain was still listed in the localhosts file. So when my new server tried to send email to the old box, the old box returned an error as it thought the domain was local on that machine.

    After removing the domain from the localhosts file on the "old" server, my problem went away.
     
    #7 knipper, May 2, 2004
    Last edited: May 2, 2004
  8. cikul

    cikul Well-Known Member

    Joined:
    Nov 15, 2002
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    What is localhost file?
     
  9. knipper

    knipper Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Opppssss...

    Sorry about that it was the localdomains file. Located in /etc/

    This is a file that shows all domains that reside on the server. Even though I had removed the domain name, and all traces of DNS were gone, the entry was still in the localhosts file.

    So, when my "new" server tried to e-mail my "old" server, the old server said sent an error, as it thought the domain that was sending the mail was still "local".

    Hope that helps.
     
  10. iski4kix

    iski4kix Member
    PartnerNOC

    Joined:
    Apr 4, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Any time you get 550 sender failed error you need to check your passwd and shadow permissions in /home/username/etc/domain.com they should be 644 and 640 respectively I guarentee they aren't
     
  11. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Evidentally not in this case.
     
  12. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    140
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    new york
    I have had the same problem

    One server could not send mail to the other.
    Server A could not send mail from PHP apps to server B
    But server B had no problems sending mail to server A

    The cure was to uncheck Verify the existence of email senders in WHM on the receiving server.

    Somehow I think there is a problem on server B since I think this is not a fix but at least we have mail both ways now

    Vin
     
  13. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Hi Vin,

    Whenever I've seen this it's been due to one or other server not having their hostname A record setup correctly in the authoratitive zone file for the domain that it is on.
     
Loading...
Similar Threads - 550 Sender verify
  1. upsforum
    Replies:
    2
    Views:
    632

Share This Page