550 Too many MIME parts

Operating System & Version
CentOS 6.10
cPanel & WHM Version
11.86.0.40

ChaosC

Registered
Aug 7, 2013
2
1
53
cPanel Access Level
Root Administrator
Hi all,

We've been successfully running cPanel on a VPS for many years. We're facing an issue where a client can't receive specific emails from a sender/host. Not all emails from the sender is blocked, the ones being blocked apparently contain attachments of old emails which is being used in a court case.

I've searched Google and can find no suggestion, fix or setting for this error (I found one for Postfix, but we use Exim).

The failure message which the sender receives is as follows:

===
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

[email protected]
host example.net [xxx.xx.xx.xx]
SMTP error from remote mail server after end of data:
550 Too many MIME parts: 154 > 100
[email protected]
host example.net [xxx.xx.xx.xx]
SMTP error from remote mail server after end of data:
550 Too many MIME parts: 154 > 100
===

Where can we change the setting, even if for a limited time, to allow a maximum of say, 200 maximum MIME parts in one email. I can understand that this will have a negative impact on server performance, but it is absolutely critical.

Can anyone please shed some light on this problem?

Best regards
ChaosC
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,496
1,009
313
cPanel Access Level
Root Administrator
Hey there! The link posted by @devil2580 does talk about the error, but it doesn't provide a solution for Exim.

My searching has found this is a pretty obscure value buried deep in Exim itself. There isn't going to be a way in cPanel or WHM to adjust that value.

The only reference I was able to find was from a 16-year-old thread here: RE: [exim] MIME errors and MIME ACL

and I am no longer able to find any reference to those configuration options in the Exim documentation. It might be best to post to the Exim users list to see if that is even still adjustable, as from what I'm seeing there is not a way to change that value.
 
  • Like
Reactions: cPJustinD

ChaosC

Registered
Aug 7, 2013
2
1
53
cPanel Access Level
Root Administrator
Thank you @devil2580 and @cPRex for your replies, much appreciated.

I previously looked at both posts and also came to the conclusion, even after going through the Exim documentation, that it doesn't seem like a well known variable - if it's even still in use somehow/somewhere. All leads end up up in dead-ends :-(

I'll post back if I'm lucky enough to find anything of value.
 
  • Like
Reactions: cPRex